NetIrc2 Namespace

NetIrc2 Namespace NetIRC2 IRC Client Library for .NET

NetIRC2 is an easy-to-use .NET IRC client library. It supports all major features relevant to making a chat client or bot.

NetIRC2 has full support for synchronization contexts. You can use it from a Windows Forms or WPF GUI thread and chat events will be automatically dispatched, allowing you to completely ignore multithreading. It uses byte arrays internally so mixed encodings can be handled. The IrcClient class can even be used as a component in the Forms Designer.

Because it speeds up connect times with some IRC servers, an Ident server is included as well.

Classes
 | Class | Description
Public class | IdentServer | Answers requests using the Ident protocol (RFC 1413). Many IRC servers try to connect to a client's Ident server.
Public class | IrcClient | Communicates with an Internet Relay Chat server.
Public class | IrcClientConnectionOptions | Provides options used by the Connect(String, Int32, IrcClientConnectionOptions) command.
Public class | IrcIdentity | Stores an IRC user's identity information - their nickname, username, and hostname.
Public class | IrcString | Allows string-style manipulation of arrays of bytes. IRC does not define an encoding, so this provides for encoding-agnostic parsing.
Enumerations
 | Enumeration | Description
Public enumeration | IrcReplyCode | Many of the common IRC error and reply codes.

Online Copyright 2013 James F. Bellinger (http://www.zer7.com/software.php?page=netirc)

Send Feedback on this topic to jfb@zer7.com.


IdentServer Class

IdentServer Class NetIRC2 IRC Client Library for .NET
Answers requests using the Ident protocol (RFC 1413). Many IRC servers try to connect to a client's Ident server.
Inheritance Hierarchy
Online System Object
NetIrc2 IdentServer

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class IdentServer : IComponent,
    IDisposable
public class IdentServer : IComponent,
    IDisposable
Public Class IdentServer _
    Implements IComponent, IDisposable
Public Class IdentServer _
    Implements IComponent, IDisposable
public ref class IdentServer : IComponent,
    IDisposable
public ref class IdentServer : IComponent,
    IDisposable
type IdentServer =
    class
        interface IComponent
        interface IDisposable
    end
type IdentServer =
    class
        interface IComponent
        interface IDisposable
    end
See Also
IdentServer Members


IdentServer Members

IdentServer Members NetIRC2 IRC Client Library for .NET

The IdentServer type exposes the following members.
Constructors
 | Name | Description
Public method | IdentServer | Initializes a new instance of the IdentServer class
Back to Top
Methods
 | Name | Description
Public method | Start(Int32) | Starts the Ident server.
Public method | Start(IPEndPoint) | Starts the Ident server, listening on the specified endpoint.
Public method | Stop | Stops the Ident server and disconnects all connected clients.
Back to Top
Properties
 | Name | Description
Public property | OperatingSystem | The name of the operating system running on the computer. By default, WIN32 will be used on Windows, and UNIX will be used elsewhere.
Public property | UserID | The Ident user ID to reply with. Set this to match the IRC username.
Back to Top
See Also
IdentServer Class


IdentServer Constructor

IdentServer Constructor NetIRC2 IRC Client Library for .NET
Initializes a new instance of the IdentServer class

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IdentServer()
public IdentServer()
Public Sub New
Public Sub New
public:
IdentServer()
public:
IdentServer()
new : unit -> IdentServer
new : unit -> IdentServer
See Also
IdentServer Class
IdentServer Members


IdentServer Methods

IdentServer Methods NetIRC2 IRC Client Library for .NET
The IdentServer type exposes the following members.
Methods
 | Name | Description
Public method | Start(Int32) | Starts the Ident server.
Public method | Start(IPEndPoint) | Starts the Ident server, listening on the specified endpoint.
Public method | Stop | Stops the Ident server and disconnects all connected clients.
Back to Top
See Also
IdentServer Class


Start Method

IdentServer Start Method NetIRC2 IRC Client Library for .NET
Overload List
 | Name | Description
Public method | Start(Int32) | Starts the Ident server.
Public method | Start(IPEndPoint) | Starts the Ident server, listening on the specified endpoint.
Back to Top
See Also
IdentServer Class
IdentServer Members


Start Method (Int32)

IdentServer Start Method (Int32) NetIRC2 IRC Client Library for .NET
Starts the Ident server.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Start(
    int port = 113
)
public void Start(
    int port = 113
)
Public Sub Start ( _
    Optional port As Integer = 113 _
)
Public Sub Start ( _
    Optional port As Integer = 113 _
)
public:
void Start(
    int port = 113
)
public:
void Start(
    int port = 113
)
member Start :
        ?port : int
(* Defaults:
        let _port = defaultArg port 113
*)
-> unit
member Start :
        ?port : int
(* Defaults:
        let _port = defaultArg port 113
*)
-> unit

Parameters

port (Optional)
Type: Online System Int32
The port to listen on. The standard port is 113.
See Also
IdentServer Class
IdentServer Members
Start Overload


Start Method (IPEndPoint)

IdentServer Start Method (IPEndPoint) NetIRC2 IRC Client Library for .NET
Starts the Ident server, listening on the specified endpoint.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Start(
    IPEndPoint endPoint
)
public void Start(
    IPEndPoint endPoint
)
Public Sub Start ( _
    endPoint As IPEndPoint _
)
Public Sub Start ( _
    endPoint As IPEndPoint _
)
public:
void Start(
    IPEndPoint^ endPoint
)
public:
void Start(
    IPEndPoint^ endPoint
)
member Start :
        endPoint : IPEndPoint -> unit
member Start :
        endPoint : IPEndPoint -> unit

Parameters

endPoint
Type: Online System.Net IPEndPoint
The endpoint to listen on.
See Also
IdentServer Class
IdentServer Members
Start Overload


Stop Method

IdentServer Stop Method NetIRC2 IRC Client Library for .NET
Stops the Ident server and disconnects all connected clients.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Stop()
public void Stop()
Public Sub Stop
Public Sub Stop
public:
void Stop()
public:
void Stop()
member Stop : unit -> unit
member Stop : unit -> unit
See Also
IdentServer Class
IdentServer Members


IdentServer Properties

IdentServer Properties NetIRC2 IRC Client Library for .NET
The IdentServer type exposes the following members.
Properties
 | Name | Description
Public property | OperatingSystem | The name of the operating system running on the computer. By default, WIN32 will be used on Windows, and UNIX will be used elsewhere.
Public property | UserID | The Ident user ID to reply with. Set this to match the IRC username.
Back to Top
See Also
IdentServer Class


OperatingSystem Property

IdentServer OperatingSystem Property NetIRC2 IRC Client Library for .NET
The name of the operating system running on the computer. By default, WIN32 will be used on Windows, and UNIX will be used elsewhere.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString OperatingSystem { get; set; }
public IrcString OperatingSystem { get; set; }
Public Property OperatingSystem As IrcString
    Get
    Set
Public Property OperatingSystem As IrcString
    Get
    Set
public:
property IrcString^ OperatingSystem {
    IrcString^ get ();
    void set (IrcString^ value);
}
public:
property IrcString^ OperatingSystem {
    IrcString^ get ();
    void set (IrcString^ value);
}
member OperatingSystem : IrcString with get, set
member OperatingSystem : IrcString with get, set
See Also
IdentServer Class
IdentServer Members


UserID Property

IdentServer UserID Property NetIRC2 IRC Client Library for .NET
The Ident user ID to reply with. Set this to match the IRC username.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString UserID { get; set; }
public IrcString UserID { get; set; }
Public Property UserID As IrcString
    Get
    Set
Public Property UserID As IrcString
    Get
    Set
public:
property IrcString^ UserID {
    IrcString^ get ();
    void set (IrcString^ value);
}
public:
property IrcString^ UserID {
    IrcString^ get ();
    void set (IrcString^ value);
}
member UserID : IrcString with get, set
member UserID : IrcString with get, set
See Also
IdentServer Class
IdentServer Members


IrcClient Class

IrcClient Class NetIRC2 IRC Client Library for .NET
Communicates with an Internet Relay Chat server.
Inheritance Hierarchy
Online System Object
NetIrc2 IrcClient

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class IrcClient : IComponent, IDisposable
public class IrcClient : IComponent, IDisposable
Public Class IrcClient _
    Implements IComponent, IDisposable
Public Class IrcClient _
    Implements IComponent, IDisposable
public ref class IrcClient : IComponent,
    IDisposable
public ref class IrcClient : IComponent,
    IDisposable
type IrcClient =
    class
        interface IComponent
        interface IDisposable
    end
type IrcClient =
    class
        interface IComponent
        interface IDisposable
    end
See Also
IrcClient Members


IrcClient Members

IrcClient Members NetIRC2 IRC Client Library for .NET

The IrcClient type exposes the following members.
Constructors
 | Name | Description
Public method | IrcClient | Creates a new IRC client.
Back to Top
Methods
 | Name | Description
Public method | ChangeChannelTopic | Changes the channel topic.
Public method | ChangeName | Changes the client's nickname.
Public method | ChatAction | Sends an action message to the specified user or channel.
Public method | Close | Closes the network connection.
Public method | Connect(Stream, IrcClientConnectionOptions) | Connects to an IRC server specified by a stream.
Public method | Connect(IPEndPoint, IrcClientConnectionOptions) | Connects to an IRC server specified by an endpoint.
Public method | Connect(String, Int32, IrcClientConnectionOptions) | Connects to an IRC server.
Public method | CtcpCommand | Sends a CTCP command to the specified user or channel.
Public method | CtcpReply | Replies to a CTCP command from a user or channel.
Public method | DccCommand | Sends a DCC command to the specified user or channel.
Public method | Invite | Invites the specified user to the channel. Channel operator access may be required.
Public method | IrcCommand(IrcStatement) | Sends a premade IRC statement to the server.
Public method | IrcCommand(IrcString, IrcString ) | Constructs and sends an IRC command to the server.
Public method | Join | Joins the specified channel.
Public method | Kick | Kicks the specified user from the channel. Channel operator access may be required.
Public method | Leave | Leaves the specified channel.
Public method | ListChannels | Requests a listing of available channels on the server.
Public method | LogIn | Logs in to the server.
Public method | LogOut | Logs out from the server.
Public method | Message | Sends a message to the specified user or channel.
Public method | Mode | Changes a channel or user's mode.
Public method | Notice | Sends a notice to the specified user.
Public method | Ping | Pings the specified user.
Back to Top
Properties
 | Name | Description
Public property | ClientVersion | The client version. This will be sent in reply to a CTCP VERSION query.
Public property | IsConnected | Whether the client is connected to a server.
Public property | SyncRoot | The synchronization object for sending IRC commands.
Back to Top
Events
 | Name | Description
Public event | Closed | Called when the connection is terminated.
Public event | Connected | Called when a connection is established.
Public event | GotChannelListBegin | Called when the server has begun sending the channel list.
Public event | GotChannelListEnd | Called when the server has finished sending the channel list.
Public event | GotChannelListEntry | Called for each entry of the channel list.
Public event | GotChannelTopicChange | Called when a channel's topic changes.
Public event | GotChatAction | Called when someone sends a chat action message.
Public event | GotInvitation | Called when the client receives an invitation to join a channel.
Public event | GotIrcError | Called when an error occurs.
Public event | GotJoinChannel | Called when someone joins a channel.
Public event | GotLeaveChannel | Called when someone leaves a channel.
Public event | GotMessage | Called when someone sends a message.
Public event | GotMode | Called when a channel or user's mode is changed.
Public event | GotMotdBegin | Called when the server has begun sending the Message of the Day.
Public event | GotMotdEnd | Called when the server has finished sending the Message of the Day.
Public event | GotMotdText | Called for each line of the Message of the Day sent by the server.
Public event | GotNameChange | Called when someone changes their name.
Public event | GotNameListEnd | Called at the completion of a channel's user list.
Public event | GotNameListReply | Called when the server is sending a channel's user list.
Public event | GotNotice | Called when someone sends a notice. Notices differ from ordinary messages in that, by convention, one should not send an automated reply in response (such as 'I am away from the keyboard.').
Public event | GotPingReply | Called on a user's reply to a ping.
Public event | GotUserKicked | Called when a user is kicked from a channel.
Public event | GotUserQuit | Called when a user disconnects from the server.
Public event | GotWelcomeMessage | Called when the server sends the welcome message.
Back to Top
See Also
IrcClient Class


IrcClient Constructor

IrcClient Constructor NetIRC2 IRC Client Library for .NET
Creates a new IRC client.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcClient()
public IrcClient()
Public Sub New
Public Sub New
public:
IrcClient()
public:
IrcClient()
new : unit -> IrcClient
new : unit -> IrcClient
See Also
IrcClient Class
IrcClient Members


IrcClient Methods

IrcClient Methods NetIRC2 IRC Client Library for .NET
The IrcClient type exposes the following members.
Methods
 | Name | Description
Public method | ChangeChannelTopic | Changes the channel topic.
Public method | ChangeName | Changes the client's nickname.
Public method | ChatAction | Sends an action message to the specified user or channel.
Public method | Close | Closes the network connection.
Public method | Connect(Stream, IrcClientConnectionOptions) | Connects to an IRC server specified by a stream.
Public method | Connect(IPEndPoint, IrcClientConnectionOptions) | Connects to an IRC server specified by an endpoint.
Public method | Connect(String, Int32, IrcClientConnectionOptions) | Connects to an IRC server.
Public method | CtcpCommand | Sends a CTCP command to the specified user or channel.
Public method | CtcpReply | Replies to a CTCP command from a user or channel.
Public method | DccCommand | Sends a DCC command to the specified user or channel.
Public method | Invite | Invites the specified user to the channel. Channel operator access may be required.
Public method | IrcCommand(IrcStatement) | Sends a premade IRC statement to the server.
Public method | IrcCommand(IrcString, IrcString ) | Constructs and sends an IRC command to the server.
Public method | Join | Joins the specified channel.
Public method | Kick | Kicks the specified user from the channel. Channel operator access may be required.
Public method | Leave | Leaves the specified channel.
Public method | ListChannels | Requests a listing of available channels on the server.
Public method | LogIn | Logs in to the server.
Public method | LogOut | Logs out from the server.
Public method | Message | Sends a message to the specified user or channel.
Public method | Mode | Changes a channel or user's mode.
Public method | Notice | Sends a notice to the specified user.
Public method | Ping | Pings the specified user.
Back to Top
See Also
IrcClient Class


ChangeChannelTopic Method

IrcClient ChangeChannelTopic Method NetIRC2 IRC Client Library for .NET
Changes the channel topic.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ChangeChannelTopic(
    IrcString channel,
    IrcString newTopic
)
public void ChangeChannelTopic(
    IrcString channel,
    IrcString newTopic
)
Public Sub ChangeChannelTopic ( _
    channel As IrcString, _
    newTopic As IrcString _
)
Public Sub ChangeChannelTopic ( _
    channel As IrcString, _
    newTopic As IrcString _
)
public:
void ChangeChannelTopic(
    IrcString^ channel,
    IrcString^ newTopic
)
public:
void ChangeChannelTopic(
    IrcString^ channel,
    IrcString^ newTopic
)
member ChangeChannelTopic :
        channel : IrcString *
        newTopic : IrcString -> unit
member ChangeChannelTopic :
        channel : IrcString *
        newTopic : IrcString -> unit

Parameters

channel
Type: NetIrc2 IrcString
The channel whose topic to change.
newTopic
Type: NetIrc2 IrcString
The new channel topic.
See Also
IrcClient Class
IrcClient Members


ChangeName Method

IrcClient ChangeName Method NetIRC2 IRC Client Library for .NET
Changes the client's nickname.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ChangeName(
    IrcString newName
)
public void ChangeName(
    IrcString newName
)
Public Sub ChangeName ( _
    newName As IrcString _
)
Public Sub ChangeName ( _
    newName As IrcString _
)
public:
void ChangeName(
    IrcString^ newName
)
public:
void ChangeName(
    IrcString^ newName
)
member ChangeName :
        newName : IrcString -> unit
member ChangeName :
        newName : IrcString -> unit

Parameters

newName
Type: NetIrc2 IrcString
The nickname to change to.
See Also
IrcClient Class
IrcClient Members


ChatAction Method

IrcClient ChatAction Method NetIRC2 IRC Client Library for .NET
Sends an action message to the specified user or channel.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ChatAction(
    IrcString recipient,
    IrcString message
)
public void ChatAction(
    IrcString recipient,
    IrcString message
)
Public Sub ChatAction ( _
    recipient As IrcString, _
    message As IrcString _
)
Public Sub ChatAction ( _
    recipient As IrcString, _
    message As IrcString _
)
public:
void ChatAction(
    IrcString^ recipient,
    IrcString^ message
)
public:
void ChatAction(
    IrcString^ recipient,
    IrcString^ message
)
member ChatAction :
        recipient : IrcString *
        message : IrcString -> unit
member ChatAction :
        recipient : IrcString *
        message : IrcString -> unit

Parameters

recipient
Type: NetIrc2 IrcString
The user or channel to send the action message to.
message
Type: NetIrc2 IrcString
The message to send.
See Also
IrcClient Class
IrcClient Members


Close Method

IrcClient Close Method NetIRC2 IRC Client Library for .NET
Closes the network connection.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Close()
public void Close()
Public Sub Close
Public Sub Close
public:
void Close()
public:
void Close()
member Close : unit -> unit
member Close : unit -> unit
See Also
IrcClient Class
IrcClient Members


Connect Method

IrcClient Connect Method NetIRC2 IRC Client Library for .NET
Overload List
 | Name | Description
Public method | Connect(Stream, IrcClientConnectionOptions) | Connects to an IRC server specified by a stream.
Public method | Connect(IPEndPoint, IrcClientConnectionOptions) | Connects to an IRC server specified by an endpoint.
Public method | Connect(String, Int32, IrcClientConnectionOptions) | Connects to an IRC server.
Back to Top
See Also
IrcClient Class
IrcClient Members


Connect Method (Stream, IrcClientConnectionOptions)

IrcClient Connect Method (Stream, IrcClientConnectionOptions) NetIRC2 IRC Client Library for .NET
Connects to an IRC server specified by a stream.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Connect(
    Stream stream,
    IrcClientConnectionOptions options = null
)
public void Connect(
    Stream stream,
    IrcClientConnectionOptions options = null
)
Public Sub Connect ( _
    stream As Stream, _
    Optional options As IrcClientConnectionOptions = Nothing _
)
Public Sub Connect ( _
    stream As Stream, _
    Optional options As IrcClientConnectionOptions = Nothing _
)
public:
void Connect(
    Stream^ stream,
    IrcClientConnectionOptions^ options = nullptr
)
public:
void Connect(
    Stream^ stream,
    IrcClientConnectionOptions^ options = nullptr
)
member Connect :
        stream : Stream *
        ?options : IrcClientConnectionOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
member Connect :
        stream : Stream *
        ?options : IrcClientConnectionOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

stream
Type: Online System.IO Stream
The stream.
options (Optional)
Type: NetIrc2 IrcClientConnectionOptions
Options for the connection, if any, or null.
See Also
IrcClient Class
IrcClient Members
Connect Overload


Connect Method (IPEndPoint, IrcClientConnectionOptions)

IrcClient Connect Method (IPEndPoint, IrcClientConnectionOptions) NetIRC2 IRC Client Library for .NET
Connects to an IRC server specified by an endpoint.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Connect(
    IPEndPoint endPoint,
    IrcClientConnectionOptions options = null
)
public void Connect(
    IPEndPoint endPoint,
    IrcClientConnectionOptions options = null
)
Public Sub Connect ( _
    endPoint As IPEndPoint, _
    Optional options As IrcClientConnectionOptions = Nothing _
)
Public Sub Connect ( _
    endPoint As IPEndPoint, _
    Optional options As IrcClientConnectionOptions = Nothing _
)
public:
void Connect(
    IPEndPoint^ endPoint,
    IrcClientConnectionOptions^ options = nullptr
)
public:
void Connect(
    IPEndPoint^ endPoint,
    IrcClientConnectionOptions^ options = nullptr
)
member Connect :
        endPoint : IPEndPoint *
        ?options : IrcClientConnectionOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit
member Connect :
        endPoint : IPEndPoint *
        ?options : IrcClientConnectionOptions
(* Defaults:
        let _options = defaultArg options null
*)
-> unit

Parameters

endPoint
Type: Online System.Net IPEndPoint
The IP endpoint to connect to.
options (Optional)
Type: NetIrc2 IrcClientConnectionOptions
Options for the connection, if any, or null.
See Also
IrcClient Class
IrcClient Members
Connect Overload


Connect Method (String, Int32, IrcClientConnectionOptions)

IrcClient Connect Method (String, Int32, IrcClientConnectionOptions) NetIRC2 IRC Client Library for .NET
Connects to an IRC server.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Connect(
    string hostname,
    int port = 6667,
    IrcClientConnectionOptions options = null
)
public void Connect(
    string hostname,
    int port = 6667,
    IrcClientConnectionOptions options = null
)
Public Sub Connect ( _
    hostname As String, _
    Optional port As Integer = 6667, _
    Optional options As IrcClientConnectionOptions = Nothing _
)
Public Sub Connect ( _
    hostname As String, _
    Optional port As Integer = 6667, _
    Optional options As IrcClientConnectionOptions = Nothing _
)
public:
void Connect(
    String^ hostname,
    int port = 6667,
    IrcClientConnectionOptions^ options = nullptr
)
public:
void Connect(
    String^ hostname,
    int port = 6667,
    IrcClientConnectionOptions^ options = nullptr
)
member Connect :
        hostname : string *
        ?port : int *
        ?options : IrcClientConnectionOptions
(* Defaults:
        let _port = defaultArg port 6667
        let _options = defaultArg options null
*)
-> unit
member Connect :
        hostname : string *
        ?port : int *
        ?options : IrcClientConnectionOptions
(* Defaults:
        let _port = defaultArg port 6667
        let _options = defaultArg options null
*)
-> unit

Parameters

hostname
Type: Online System String
The server hostname.
port (Optional)
Type: Online System Int32
The server port.
options (Optional)
Type: NetIrc2 IrcClientConnectionOptions
Options for the connection, if any, or null.
See Also
IrcClient Class
IrcClient Members
Connect Overload


CtcpCommand Method

IrcClient CtcpCommand Method NetIRC2 IRC Client Library for .NET
Sends a CTCP command to the specified user or channel.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CtcpCommand(
    IrcString recipient,
    IrcString command,
    IrcString[] parameters,
    bool escapeParameters = true
)
public void CtcpCommand(
    IrcString recipient,
    IrcString command,
    IrcString[] parameters,
    bool escapeParameters = true
)
Public Sub CtcpCommand ( _
    recipient As IrcString, _
    command As IrcString, _
    parameters As IrcString(), _
    Optional escapeParameters As Boolean = True _
)
Public Sub CtcpCommand ( _
    recipient As IrcString, _
    command As IrcString, _
    parameters As IrcString(), _
    Optional escapeParameters As Boolean = True _
)
public:
void CtcpCommand(
    IrcString^ recipient,
    IrcString^ command,
    array<IrcString^>^ parameters,
    bool escapeParameters = true
)
public:
void CtcpCommand(
    IrcString^ recipient,
    IrcString^ command,
    array<IrcString^>^ parameters,
    bool escapeParameters = true
)
member CtcpCommand :
        recipient : IrcString *
        command : IrcString *
        parameters : IrcString[] *
        ?escapeParameters : bool
(* Defaults:
        let _escapeParameters = defaultArg escapeParameters true
*)
-> unit
member CtcpCommand :
        recipient : IrcString *
        command : IrcString *
        parameters : IrcString[] *
        ?escapeParameters : bool
(* Defaults:
        let _escapeParameters = defaultArg escapeParameters true
*)
-> unit

Parameters

recipient
Type: NetIrc2 IrcString
The user or channel to send the command to.
command
Type: NetIrc2 IrcString
The CTCP command.
parameters
Type: NetIrc2 IrcString
The CTCP command parameters.
escapeParameters (Optional)
Type: Online System Boolean
true to quote parameters with spaces in them, and escape backslashes and quotation marks.
See Also
IrcClient Class
IrcClient Members


CtcpReply Method

IrcClient CtcpReply Method NetIRC2 IRC Client Library for .NET
Replies to a CTCP command from a user or channel.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CtcpReply(
    IrcString recipient,
    IrcString command,
    IrcString[] parameters,
    bool escapeParameters = true
)
public void CtcpReply(
    IrcString recipient,
    IrcString command,
    IrcString[] parameters,
    bool escapeParameters = true
)
Public Sub CtcpReply ( _
    recipient As IrcString, _
    command As IrcString, _
    parameters As IrcString(), _
    Optional escapeParameters As Boolean = True _
)
Public Sub CtcpReply ( _
    recipient As IrcString, _
    command As IrcString, _
    parameters As IrcString(), _
    Optional escapeParameters As Boolean = True _
)
public:
void CtcpReply(
    IrcString^ recipient,
    IrcString^ command,
    array<IrcString^>^ parameters,
    bool escapeParameters = true
)
public:
void CtcpReply(
    IrcString^ recipient,
    IrcString^ command,
    array<IrcString^>^ parameters,
    bool escapeParameters = true
)
member CtcpReply :
        recipient : IrcString *
        command : IrcString *
        parameters : IrcString[] *
        ?escapeParameters : bool
(* Defaults:
        let _escapeParameters = defaultArg escapeParameters true
*)
-> unit
member CtcpReply :
        recipient : IrcString *
        command : IrcString *
        parameters : IrcString[] *
        ?escapeParameters : bool
(* Defaults:
        let _escapeParameters = defaultArg escapeParameters true
*)
-> unit

Parameters

recipient
Type: NetIrc2 IrcString
The user or channel to send the reply to.
command
Type: NetIrc2 IrcString
The CTCP command.
parameters
Type: NetIrc2 IrcString
The CTCP command reply parameters.
escapeParameters (Optional)
Type: Online System Boolean
true to quote parameters with spaces in them, and escape backslashes and quotation marks.
See Also
IrcClient Class
IrcClient Members


DccCommand Method

IrcClient DccCommand Method NetIRC2 IRC Client Library for .NET
Sends a DCC command to the specified user or channel.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DccCommand(
    IrcString recipient,
    IrcString command,
    params IrcString[] parameters
)
public void DccCommand(
    IrcString recipient,
    IrcString command,
    params IrcString[] parameters
)
Public Sub DccCommand ( _
    recipient As IrcString, _
    command As IrcString, _
    ParamArray parameters As IrcString() _
)
Public Sub DccCommand ( _
    recipient As IrcString, _
    command As IrcString, _
    ParamArray parameters As IrcString() _
)
public:
void DccCommand(
    IrcString^ recipient,
    IrcString^ command,
    ... array<IrcString^>^ parameters
)
public:
void DccCommand(
    IrcString^ recipient,
    IrcString^ command,
    ... array<IrcString^>^ parameters
)
member DccCommand :
        recipient : IrcString *
        command : IrcString *
        parameters : IrcString[] -> unit
member DccCommand :
        recipient : IrcString *
        command : IrcString *
        parameters : IrcString[] -> unit

Parameters

recipient
Type: NetIrc2 IrcString
The user or channel to send the command to.
command
Type: NetIrc2 IrcString
The DCC command.
parameters
Type: NetIrc2 IrcString
The DCC command parameters.
See Also
IrcClient Class
IrcClient Members


Invite Method

IrcClient Invite Method NetIRC2 IRC Client Library for .NET
Invites the specified user to the channel. Channel operator access may be required.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Invite(
    IrcString user,
    IrcString channel
)
public void Invite(
    IrcString user,
    IrcString channel
)
Public Sub Invite ( _
    user As IrcString, _
    channel As IrcString _
)
Public Sub Invite ( _
    user As IrcString, _
    channel As IrcString _
)
public:
void Invite(
    IrcString^ user,
    IrcString^ channel
)
public:
void Invite(
    IrcString^ user,
    IrcString^ channel
)
member Invite :
        user : IrcString *
        channel : IrcString -> unit
member Invite :
        user : IrcString *
        channel : IrcString -> unit

Parameters

user
Type: NetIrc2 IrcString
The user to invite.
channel
Type: NetIrc2 IrcString
The channel to invite the user to.
See Also
IrcClient Class
IrcClient Members


IrcCommand Method

IrcClient IrcCommand Method NetIRC2 IRC Client Library for .NET
Overload List
 | Name | Description
Public method | IrcCommand(IrcStatement) | Sends a premade IRC statement to the server.
Public method | IrcCommand(IrcString, IrcString ) | Constructs and sends an IRC command to the server.
Back to Top
See Also
IrcClient Class
IrcClient Members


IrcCommand Method (IrcStatement)

IrcClient IrcCommand Method (IrcStatement) NetIRC2 IRC Client Library for .NET
Sends a premade IRC statement to the server.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IrcCommand(
    IrcStatement statement
)
public bool IrcCommand(
    IrcStatement statement
)
Public Function IrcCommand ( _
    statement As IrcStatement _
) As Boolean
Public Function IrcCommand ( _
    statement As IrcStatement _
) As Boolean
public:
bool IrcCommand(
    IrcStatement^ statement
)
public:
bool IrcCommand(
    IrcStatement^ statement
)
member IrcCommand :
        statement : IrcStatement -> bool
member IrcCommand :
        statement : IrcStatement -> bool

Parameters

statement
Type: NetIrc2.Parsing IrcStatement
The statement to send.

Return Value

true if the statement was sent successfully.
See Also
IrcClient Class
IrcClient Members
IrcCommand Overload


IrcCommand Method (IrcString, IrcString[])

IrcClient IrcCommand Method (IrcString, IrcString ) NetIRC2 IRC Client Library for .NET
Constructs and sends an IRC command to the server.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IrcCommand(
    IrcString command,
    params IrcString[] parameters
)
public bool IrcCommand(
    IrcString command,
    params IrcString[] parameters
)
Public Function IrcCommand ( _
    command As IrcString, _
    ParamArray parameters As IrcString() _
) As Boolean
Public Function IrcCommand ( _
    command As IrcString, _
    ParamArray parameters As IrcString() _
) As Boolean
public:
bool IrcCommand(
    IrcString^ command,
    ... array<IrcString^>^ parameters
)
public:
bool IrcCommand(
    IrcString^ command,
    ... array<IrcString^>^ parameters
)
member IrcCommand :
        command : IrcString *
        parameters : IrcString[] -> bool
member IrcCommand :
        command : IrcString *
        parameters : IrcString[] -> bool

Parameters

command
Type: NetIrc2 IrcString
The command to send.
parameters
Type: NetIrc2 IrcString
The command's parameters.

Return Value

true if the command was sent successfully.
See Also
IrcClient Class
IrcClient Members
IrcCommand Overload


Join Method

IrcClient Join Method NetIRC2 IRC Client Library for .NET
Joins the specified channel.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Join(
    IrcString channel,
    IrcString key = null
)
public void Join(
    IrcString channel,
    IrcString key = null
)
Public Sub Join ( _
    channel As IrcString, _
    Optional key As IrcString = Nothing _
)
Public Sub Join ( _
    channel As IrcString, _
    Optional key As IrcString = Nothing _
)
public:
void Join(
    IrcString^ channel,
    IrcString^ key = nullptr
)
public:
void Join(
    IrcString^ channel,
    IrcString^ key = nullptr
)
member Join :
        channel : IrcString *
        ?key : IrcString
(* Defaults:
        let _key = defaultArg key null
*)
-> unit
member Join :
        channel : IrcString *
        ?key : IrcString
(* Defaults:
        let _key = defaultArg key null
*)
-> unit

Parameters

channel
Type: NetIrc2 IrcString
The channel to join.
key (Optional)
Type: NetIrc2 IrcString
The channel key, or null if a key is unnecessary.
See Also
IrcClient Class
IrcClient Members


Kick Method

IrcClient Kick Method NetIRC2 IRC Client Library for .NET
Kicks the specified user from the channel. Channel operator access may be required.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Kick(
    IrcString user,
    IrcString channel,
    IrcString reason
)
public void Kick(
    IrcString user,
    IrcString channel,
    IrcString reason
)
Public Sub Kick ( _
    user As IrcString, _
    channel As IrcString, _
    reason As IrcString _
)
Public Sub Kick ( _
    user As IrcString, _
    channel As IrcString, _
    reason As IrcString _
)
public:
void Kick(
    IrcString^ user,
    IrcString^ channel,
    IrcString^ reason
)
public:
void Kick(
    IrcString^ user,
    IrcString^ channel,
    IrcString^ reason
)
member Kick :
        user : IrcString *
        channel : IrcString *
        reason : IrcString -> unit
member Kick :
        user : IrcString *
        channel : IrcString *
        reason : IrcString -> unit

Parameters

user
Type: NetIrc2 IrcString
The user to kick.
channel
Type: NetIrc2 IrcString
The channel to kick the user from.
reason
Type: NetIrc2 IrcString
The reason the user was kicked, or null to give no reason.
See Also
IrcClient Class
IrcClient Members


Leave Method

IrcClient Leave Method NetIRC2 IRC Client Library for .NET
Leaves the specified channel.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Leave(
    IrcString channel
)
public void Leave(
    IrcString channel
)
Public Sub Leave ( _
    channel As IrcString _
)
Public Sub Leave ( _
    channel As IrcString _
)
public:
void Leave(
    IrcString^ channel
)
public:
void Leave(
    IrcString^ channel
)
member Leave :
        channel : IrcString -> unit
member Leave :
        channel : IrcString -> unit

Parameters

channel
Type: NetIrc2 IrcString
The channel to leave.
See Also
IrcClient Class
IrcClient Members


ListChannels Method

IrcClient ListChannels Method NetIRC2 IRC Client Library for .NET
Requests a listing of available channels on the server.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ListChannels()
public void ListChannels()
Public Sub ListChannels
Public Sub ListChannels
public:
void ListChannels()
public:
void ListChannels()
member ListChannels : unit -> unit
member ListChannels : unit -> unit
See Also
IrcClient Class
IrcClient Members


LogIn Method

IrcClient LogIn Method NetIRC2 IRC Client Library for .NET
Logs in to the server.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void LogIn(
    IrcString username,
    IrcString realname,
    IrcString nickname,
    IrcString hostname = null,
    IrcString servername = null,
    IrcString password = null
)
public void LogIn(
    IrcString username,
    IrcString realname,
    IrcString nickname,
    IrcString hostname = null,
    IrcString servername = null,
    IrcString password = null
)
Public Sub LogIn ( _
    username As IrcString, _
    realname As IrcString, _
    nickname As IrcString, _
    Optional hostname As IrcString = Nothing, _
    Optional servername As IrcString = Nothing, _
    Optional password As IrcString = Nothing _
)
Public Sub LogIn ( _
    username As IrcString, _
    realname As IrcString, _
    nickname As IrcString, _
    Optional hostname As IrcString = Nothing, _
    Optional servername As IrcString = Nothing, _
    Optional password As IrcString = Nothing _
)
public:
void LogIn(
    IrcString^ username,
    IrcString^ realname,
    IrcString^ nickname,
    IrcString^ hostname = nullptr,
    IrcString^ servername = nullptr,
    IrcString^ password = nullptr
)
public:
void LogIn(
    IrcString^ username,
    IrcString^ realname,
    IrcString^ nickname,
    IrcString^ hostname = nullptr,
    IrcString^ servername = nullptr,
    IrcString^ password = nullptr
)
member LogIn :
        username : IrcString *
        realname : IrcString *
        nickname : IrcString *
        ?hostname : IrcString *
        ?servername : IrcString *
        ?password : IrcString
(* Defaults:
        let _hostname = defaultArg hostname null
        let _servername = defaultArg servername null
        let _password = defaultArg password null
*)
-> unit
member LogIn :
        username : IrcString *
        realname : IrcString *
        nickname : IrcString *
        ?hostname : IrcString *
        ?servername : IrcString *
        ?password : IrcString
(* Defaults:
        let _hostname = defaultArg hostname null
        let _servername = defaultArg servername null
        let _password = defaultArg password null
*)
-> unit

Parameters

username
Type: NetIrc2 IrcString
A username. If you aren't using a password, this can be anything you want.
realname
Type: NetIrc2 IrcString
Your real name, or some made up name.
nickname
Type: NetIrc2 IrcString
The IRC nickname to use.
hostname (Optional)
Type: NetIrc2 IrcString
The hostname to send, or null to send a default value.
servername (Optional)
Type: NetIrc2 IrcString
The servername to send, or null to send a default value.
password (Optional)
Type: NetIrc2 IrcString
The connection password, or null to not use one.
See Also
IrcClient Class
IrcClient Members


LogOut Method

IrcClient LogOut Method NetIRC2 IRC Client Library for .NET
Logs out from the server.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void LogOut(
    string quitMessage = null
)
public void LogOut(
    string quitMessage = null
)
Public Sub LogOut ( _
    Optional quitMessage As String = Nothing _
)
Public Sub LogOut ( _
    Optional quitMessage As String = Nothing _
)
public:
void LogOut(
    String^ quitMessage = nullptr
)
public:
void LogOut(
    String^ quitMessage = nullptr
)
member LogOut :
        ?quitMessage : string
(* Defaults:
        let _quitMessage = defaultArg quitMessage null
*)
-> unit
member LogOut :
        ?quitMessage : string
(* Defaults:
        let _quitMessage = defaultArg quitMessage null
*)
-> unit

Parameters

quitMessage (Optional)
Type: Online System String
The quit message, or null.
See Also
IrcClient Class
IrcClient Members


Message Method

IrcClient Message Method NetIRC2 IRC Client Library for .NET
Sends a message to the specified user or channel.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Message(
    IrcString recipient,
    IrcString message
)
public void Message(
    IrcString recipient,
    IrcString message
)
Public Sub Message ( _
    recipient As IrcString, _
    message As IrcString _
)
Public Sub Message ( _
    recipient As IrcString, _
    message As IrcString _
)
public:
void Message(
    IrcString^ recipient,
    IrcString^ message
)
public:
void Message(
    IrcString^ recipient,
    IrcString^ message
)
member Message :
        recipient : IrcString *
        message : IrcString -> unit
member Message :
        recipient : IrcString *
        message : IrcString -> unit

Parameters

recipient
Type: NetIrc2 IrcString
The user or channel to send the message to.
message
Type: NetIrc2 IrcString
The message to send.
See Also
IrcClient Class
IrcClient Members


Mode Method

IrcClient Mode Method NetIRC2 IRC Client Library for .NET
Changes a channel or user's mode.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Mode(
    IrcString target,
    IrcString command,
    params IrcString[] parameters
)
public void Mode(
    IrcString target,
    IrcString command,
    params IrcString[] parameters
)
Public Sub Mode ( _
    target As IrcString, _
    command As IrcString, _
    ParamArray parameters As IrcString() _
)
Public Sub Mode ( _
    target As IrcString, _
    command As IrcString, _
    ParamArray parameters As IrcString() _
)
public:
void Mode(
    IrcString^ target,
    IrcString^ command,
    ... array<IrcString^>^ parameters
)
public:
void Mode(
    IrcString^ target,
    IrcString^ command,
    ... array<IrcString^>^ parameters
)
member Mode :
        target : IrcString *
        command : IrcString *
        parameters : IrcString[] -> unit
member Mode :
        target : IrcString *
        command : IrcString *
        parameters : IrcString[] -> unit

Parameters

target
Type: NetIrc2 IrcString
The channel or user to change the mode of.
command
Type: NetIrc2 IrcString
The mode change, for example +o or +v.
parameters
Type: NetIrc2 IrcString
The mode change parameters.
See Also
IrcClient Class
IrcClient Members


Notice Method

IrcClient Notice Method NetIRC2 IRC Client Library for .NET
Sends a notice to the specified user.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Notice(
    IrcString recipient,
    string message
)
public void Notice(
    IrcString recipient,
    string message
)
Public Sub Notice ( _
    recipient As IrcString, _
    message As String _
)
Public Sub Notice ( _
    recipient As IrcString, _
    message As String _
)
public:
void Notice(
    IrcString^ recipient,
    String^ message
)
public:
void Notice(
    IrcString^ recipient,
    String^ message
)
member Notice :
        recipient : IrcString *
        message : string -> unit
member Notice :
        recipient : IrcString *
        message : string -> unit

Parameters

recipient
Type: NetIrc2 IrcString
The user to send the notice to.
message
Type: Online System String
The message to send.
See Also
IrcClient Class
IrcClient Members


Ping Method

IrcClient Ping Method NetIRC2 IRC Client Library for .NET
Pings the specified user.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Ping(
    IrcString userToPing
)
public void Ping(
    IrcString userToPing
)
Public Sub Ping ( _
    userToPing As IrcString _
)
Public Sub Ping ( _
    userToPing As IrcString _
)
public:
void Ping(
    IrcString^ userToPing
)
public:
void Ping(
    IrcString^ userToPing
)
member Ping :
        userToPing : IrcString -> unit
member Ping :
        userToPing : IrcString -> unit

Parameters

userToPing
Type: NetIrc2 IrcString
The user to ping.
See Also
IrcClient Class
IrcClient Members


IrcClient Properties

IrcClient Properties NetIRC2 IRC Client Library for .NET
The IrcClient type exposes the following members.
Properties
 | Name | Description
Public property | ClientVersion | The client version. This will be sent in reply to a CTCP VERSION query.
Public property | IsConnected | Whether the client is connected to a server.
Public property | SyncRoot | The synchronization object for sending IRC commands.
Back to Top
See Also
IrcClient Class


ClientVersion Property

IrcClient ClientVersion Property NetIRC2 IRC Client Library for .NET
The client version. This will be sent in reply to a CTCP VERSION query.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString ClientVersion { get; set; }
public IrcString ClientVersion { get; set; }
Public Property ClientVersion As IrcString
    Get
    Set
Public Property ClientVersion As IrcString
    Get
    Set
public:
property IrcString^ ClientVersion {
    IrcString^ get ();
    void set (IrcString^ value);
}
public:
property IrcString^ ClientVersion {
    IrcString^ get ();
    void set (IrcString^ value);
}
member ClientVersion : IrcString with get, set
member ClientVersion : IrcString with get, set
See Also
IrcClient Class
IrcClient Members


IsConnected Property

IrcClient IsConnected Property NetIRC2 IRC Client Library for .NET
Whether the client is connected to a server.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsConnected { get; private set; }
public bool IsConnected { get; private set; }
Public Property IsConnected As Boolean
    Get
    Private Set
Public Property IsConnected As Boolean
    Get
    Private Set
public:
property bool IsConnected {
    bool get ();
    private: void set (bool value);
}
public:
property bool IsConnected {
    bool get ();
    private: void set (bool value);
}
member IsConnected : bool with get, private set
member IsConnected : bool with get, private set
See Also
IrcClient Class
IrcClient Members


SyncRoot Property

IrcClient SyncRoot Property NetIRC2 IRC Client Library for .NET
The synchronization object for sending IRC commands.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object SyncRoot { get; private set; }
public Object SyncRoot { get; private set; }
Public Property SyncRoot As Object
    Get
    Private Set
Public Property SyncRoot As Object
    Get
    Private Set
public:
property Object^ SyncRoot {
    Object^ get ();
    private: void set (Object^ value);
}
public:
property Object^ SyncRoot {
    Object^ get ();
    private: void set (Object^ value);
}
member SyncRoot : Object with get, private set
member SyncRoot : Object with get, private set
See Also
IrcClient Class
IrcClient Members


IrcClient Events

IrcClient Events NetIRC2 IRC Client Library for .NET
The IrcClient type exposes the following members.
Events
 | Name | Description
Public event | Closed | Called when the connection is terminated.
Public event | Connected | Called when a connection is established.
Public event | GotChannelListBegin | Called when the server has begun sending the channel list.
Public event | GotChannelListEnd | Called when the server has finished sending the channel list.
Public event | GotChannelListEntry | Called for each entry of the channel list.
Public event | GotChannelTopicChange | Called when a channel's topic changes.
Public event | GotChatAction | Called when someone sends a chat action message.
Public event | GotInvitation | Called when the client receives an invitation to join a channel.
Public event | GotIrcError | Called when an error occurs.
Public event | GotJoinChannel | Called when someone joins a channel.
Public event | GotLeaveChannel | Called when someone leaves a channel.
Public event | GotMessage | Called when someone sends a message.
Public event | GotMode | Called when a channel or user's mode is changed.
Public event | GotMotdBegin | Called when the server has begun sending the Message of the Day.
Public event | GotMotdEnd | Called when the server has finished sending the Message of the Day.
Public event | GotMotdText | Called for each line of the Message of the Day sent by the server.
Public event | GotNameChange | Called when someone changes their name.
Public event | GotNameListEnd | Called at the completion of a channel's user list.
Public event | GotNameListReply | Called when the server is sending a channel's user list.
Public event | GotNotice | Called when someone sends a notice. Notices differ from ordinary messages in that, by convention, one should not send an automated reply in response (such as 'I am away from the keyboard.').
Public event | GotPingReply | Called on a user's reply to a ping.
Public event | GotUserKicked | Called when a user is kicked from a channel.
Public event | GotUserQuit | Called when a user disconnects from the server.
Public event | GotWelcomeMessage | Called when the server sends the welcome message.
Back to Top
See Also
IrcClient Class


Closed Event

IrcClient Closed Event NetIRC2 IRC Client Library for .NET
Called when the connection is terminated.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler Closed
public event EventHandler Closed
Public Event Closed As EventHandler
Public Event Closed As EventHandler
public:
 event EventHandler^ Closed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ Closed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Closed : IEvent<EventHandler,
    EventArgs>
member Closed : IEvent<EventHandler,
    EventArgs>
See Also
IrcClient Class
IrcClient Members


Connected Event

IrcClient Connected Event NetIRC2 IRC Client Library for .NET
Called when a connection is established.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler Connected
public event EventHandler Connected
Public Event Connected As EventHandler
Public Event Connected As EventHandler
public:
 event EventHandler^ Connected {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ Connected {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Connected : IEvent<EventHandler,
    EventArgs>
member Connected : IEvent<EventHandler,
    EventArgs>
See Also
IrcClient Class
IrcClient Members


GotChannelListBegin Event

IrcClient GotChannelListBegin Event NetIRC2 IRC Client Library for .NET
Called when the server has begun sending the channel list.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler GotChannelListBegin
public event EventHandler GotChannelListBegin
Public Event GotChannelListBegin As EventHandler
Public Event GotChannelListBegin As EventHandler
public:
 event EventHandler^ GotChannelListBegin {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ GotChannelListBegin {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member GotChannelListBegin : IEvent<EventHandler,
    EventArgs>
member GotChannelListBegin : IEvent<EventHandler,
    EventArgs>
See Also
IrcClient Class
IrcClient Members


GotChannelListEnd Event

IrcClient GotChannelListEnd Event NetIRC2 IRC Client Library for .NET
Called when the server has finished sending the channel list.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler GotChannelListEnd
public event EventHandler GotChannelListEnd
Public Event GotChannelListEnd As EventHandler
Public Event GotChannelListEnd As EventHandler
public:
 event EventHandler^ GotChannelListEnd {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ GotChannelListEnd {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member GotChannelListEnd : IEvent<EventHandler,
    EventArgs>
member GotChannelListEnd : IEvent<EventHandler,
    EventArgs>
See Also
IrcClient Class
IrcClient Members


GotChannelListEntry Event

IrcClient GotChannelListEntry Event NetIRC2 IRC Client Library for .NET
Called for each entry of the channel list.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<ChannelListEntryEventArgs> GotChannelListEntry
public event EventHandler<ChannelListEntryEventArgs> GotChannelListEntry
Public Event GotChannelListEntry As EventHandler(Of ChannelListEntryEventArgs)
Public Event GotChannelListEntry As EventHandler(Of ChannelListEntryEventArgs)
public:
 event EventHandler<ChannelListEntryEventArgs^>^ GotChannelListEntry {
    void add (EventHandler<ChannelListEntryEventArgs^>^ value);
    void remove (EventHandler<ChannelListEntryEventArgs^>^ value);
}
public:
 event EventHandler<ChannelListEntryEventArgs^>^ GotChannelListEntry {
    void add (EventHandler<ChannelListEntryEventArgs^>^ value);
    void remove (EventHandler<ChannelListEntryEventArgs^>^ value);
}
member GotChannelListEntry : IEvent<EventHandler<ChannelListEntryEventArgs>,
    ChannelListEntryEventArgs>
member GotChannelListEntry : IEvent<EventHandler<ChannelListEntryEventArgs>,
    ChannelListEntryEventArgs>
See Also
IrcClient Class
IrcClient Members


GotChannelTopicChange Event

IrcClient GotChannelTopicChange Event NetIRC2 IRC Client Library for .NET
Called when a channel's topic changes.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<ChannelTopicChangeEventArgs> GotChannelTopicChange
public event EventHandler<ChannelTopicChangeEventArgs> GotChannelTopicChange
Public Event GotChannelTopicChange As EventHandler(Of ChannelTopicChangeEventArgs)
Public Event GotChannelTopicChange As EventHandler(Of ChannelTopicChangeEventArgs)
public:
 event EventHandler<ChannelTopicChangeEventArgs^>^ GotChannelTopicChange {
    void add (EventHandler<ChannelTopicChangeEventArgs^>^ value);
    void remove (EventHandler<ChannelTopicChangeEventArgs^>^ value);
}
public:
 event EventHandler<ChannelTopicChangeEventArgs^>^ GotChannelTopicChange {
    void add (EventHandler<ChannelTopicChangeEventArgs^>^ value);
    void remove (EventHandler<ChannelTopicChangeEventArgs^>^ value);
}
member GotChannelTopicChange : IEvent<EventHandler<ChannelTopicChangeEventArgs>,
    ChannelTopicChangeEventArgs>
member GotChannelTopicChange : IEvent<EventHandler<ChannelTopicChangeEventArgs>,
    ChannelTopicChangeEventArgs>
See Also
IrcClient Class
IrcClient Members


GotChatAction Event

IrcClient GotChatAction Event NetIRC2 IRC Client Library for .NET
Called when someone sends a chat action message.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<ChatMessageEventArgs> GotChatAction
public event EventHandler<ChatMessageEventArgs> GotChatAction
Public Event GotChatAction As EventHandler(Of ChatMessageEventArgs)
Public Event GotChatAction As EventHandler(Of ChatMessageEventArgs)
public:
 event EventHandler<ChatMessageEventArgs^>^ GotChatAction {
    void add (EventHandler<ChatMessageEventArgs^>^ value);
    void remove (EventHandler<ChatMessageEventArgs^>^ value);
}
public:
 event EventHandler<ChatMessageEventArgs^>^ GotChatAction {
    void add (EventHandler<ChatMessageEventArgs^>^ value);
    void remove (EventHandler<ChatMessageEventArgs^>^ value);
}
member GotChatAction : IEvent<EventHandler<ChatMessageEventArgs>,
    ChatMessageEventArgs>
member GotChatAction : IEvent<EventHandler<ChatMessageEventArgs>,
    ChatMessageEventArgs>
See Also
IrcClient Class
IrcClient Members


GotInvitation Event

IrcClient GotInvitation Event NetIRC2 IRC Client Library for .NET
Called when the client receives an invitation to join a channel.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<InvitationEventArgs> GotInvitation
public event EventHandler<InvitationEventArgs> GotInvitation
Public Event GotInvitation As EventHandler(Of InvitationEventArgs)
Public Event GotInvitation As EventHandler(Of InvitationEventArgs)
public:
 event EventHandler<InvitationEventArgs^>^ GotInvitation {
    void add (EventHandler<InvitationEventArgs^>^ value);
    void remove (EventHandler<InvitationEventArgs^>^ value);
}
public:
 event EventHandler<InvitationEventArgs^>^ GotInvitation {
    void add (EventHandler<InvitationEventArgs^>^ value);
    void remove (EventHandler<InvitationEventArgs^>^ value);
}
member GotInvitation : IEvent<EventHandler<InvitationEventArgs>,
    InvitationEventArgs>
member GotInvitation : IEvent<EventHandler<InvitationEventArgs>,
    InvitationEventArgs>
See Also
IrcClient Class
IrcClient Members


GotIrcError Event

IrcClient GotIrcError Event NetIRC2 IRC Client Library for .NET
Called when an error occurs.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<IrcErrorEventArgs> GotIrcError
public event EventHandler<IrcErrorEventArgs> GotIrcError
Public Event GotIrcError As EventHandler(Of IrcErrorEventArgs)
Public Event GotIrcError As EventHandler(Of IrcErrorEventArgs)
public:
 event EventHandler<IrcErrorEventArgs^>^ GotIrcError {
    void add (EventHandler<IrcErrorEventArgs^>^ value);
    void remove (EventHandler<IrcErrorEventArgs^>^ value);
}
public:
 event EventHandler<IrcErrorEventArgs^>^ GotIrcError {
    void add (EventHandler<IrcErrorEventArgs^>^ value);
    void remove (EventHandler<IrcErrorEventArgs^>^ value);
}
member GotIrcError : IEvent<EventHandler<IrcErrorEventArgs>,
    IrcErrorEventArgs>
member GotIrcError : IEvent<EventHandler<IrcErrorEventArgs>,
    IrcErrorEventArgs>
See Also
IrcClient Class
IrcClient Members


GotJoinChannel Event

IrcClient GotJoinChannel Event NetIRC2 IRC Client Library for .NET
Called when someone joins a channel.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<JoinLeaveEventArgs> GotJoinChannel
public event EventHandler<JoinLeaveEventArgs> GotJoinChannel
Public Event GotJoinChannel As EventHandler(Of JoinLeaveEventArgs)
Public Event GotJoinChannel As EventHandler(Of JoinLeaveEventArgs)
public:
 event EventHandler<JoinLeaveEventArgs^>^ GotJoinChannel {
    void add (EventHandler<JoinLeaveEventArgs^>^ value);
    void remove (EventHandler<JoinLeaveEventArgs^>^ value);
}
public:
 event EventHandler<JoinLeaveEventArgs^>^ GotJoinChannel {
    void add (EventHandler<JoinLeaveEventArgs^>^ value);
    void remove (EventHandler<JoinLeaveEventArgs^>^ value);
}
member GotJoinChannel : IEvent<EventHandler<JoinLeaveEventArgs>,
    JoinLeaveEventArgs>
member GotJoinChannel : IEvent<EventHandler<JoinLeaveEventArgs>,
    JoinLeaveEventArgs>
See Also
IrcClient Class
IrcClient Members


GotLeaveChannel Event

IrcClient GotLeaveChannel Event NetIRC2 IRC Client Library for .NET
Called when someone leaves a channel.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<JoinLeaveEventArgs> GotLeaveChannel
public event EventHandler<JoinLeaveEventArgs> GotLeaveChannel
Public Event GotLeaveChannel As EventHandler(Of JoinLeaveEventArgs)
Public Event GotLeaveChannel As EventHandler(Of JoinLeaveEventArgs)
public:
 event EventHandler<JoinLeaveEventArgs^>^ GotLeaveChannel {
    void add (EventHandler<JoinLeaveEventArgs^>^ value);
    void remove (EventHandler<JoinLeaveEventArgs^>^ value);
}
public:
 event EventHandler<JoinLeaveEventArgs^>^ GotLeaveChannel {
    void add (EventHandler<JoinLeaveEventArgs^>^ value);
    void remove (EventHandler<JoinLeaveEventArgs^>^ value);
}
member GotLeaveChannel : IEvent<EventHandler<JoinLeaveEventArgs>,
    JoinLeaveEventArgs>
member GotLeaveChannel : IEvent<EventHandler<JoinLeaveEventArgs>,
    JoinLeaveEventArgs>
See Also
IrcClient Class
IrcClient Members


GotMessage Event

IrcClient GotMessage Event NetIRC2 IRC Client Library for .NET
Called when someone sends a message.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<ChatMessageEventArgs> GotMessage
public event EventHandler<ChatMessageEventArgs> GotMessage
Public Event GotMessage As EventHandler(Of ChatMessageEventArgs)
Public Event GotMessage As EventHandler(Of ChatMessageEventArgs)
public:
 event EventHandler<ChatMessageEventArgs^>^ GotMessage {
    void add (EventHandler<ChatMessageEventArgs^>^ value);
    void remove (EventHandler<ChatMessageEventArgs^>^ value);
}
public:
 event EventHandler<ChatMessageEventArgs^>^ GotMessage {
    void add (EventHandler<ChatMessageEventArgs^>^ value);
    void remove (EventHandler<ChatMessageEventArgs^>^ value);
}
member GotMessage : IEvent<EventHandler<ChatMessageEventArgs>,
    ChatMessageEventArgs>
member GotMessage : IEvent<EventHandler<ChatMessageEventArgs>,
    ChatMessageEventArgs>
See Also
IrcClient Class
IrcClient Members


GotMode Event

IrcClient GotMode Event NetIRC2 IRC Client Library for .NET
Called when a channel or user's mode is changed.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<ModeEventArgs> GotMode
public event EventHandler<ModeEventArgs> GotMode
Public Event GotMode As EventHandler(Of ModeEventArgs)
Public Event GotMode As EventHandler(Of ModeEventArgs)
public:
 event EventHandler<ModeEventArgs^>^ GotMode {
    void add (EventHandler<ModeEventArgs^>^ value);
    void remove (EventHandler<ModeEventArgs^>^ value);
}
public:
 event EventHandler<ModeEventArgs^>^ GotMode {
    void add (EventHandler<ModeEventArgs^>^ value);
    void remove (EventHandler<ModeEventArgs^>^ value);
}
member GotMode : IEvent<EventHandler<ModeEventArgs>,
    ModeEventArgs>
member GotMode : IEvent<EventHandler<ModeEventArgs>,
    ModeEventArgs>
See Also
IrcClient Class
IrcClient Members


GotMotdBegin Event

IrcClient GotMotdBegin Event NetIRC2 IRC Client Library for .NET
Called when the server has begun sending the Message of the Day.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler GotMotdBegin
public event EventHandler GotMotdBegin
Public Event GotMotdBegin As EventHandler
Public Event GotMotdBegin As EventHandler
public:
 event EventHandler^ GotMotdBegin {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ GotMotdBegin {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member GotMotdBegin : IEvent<EventHandler,
    EventArgs>
member GotMotdBegin : IEvent<EventHandler,
    EventArgs>
See Also
IrcClient Class
IrcClient Members


GotMotdEnd Event

IrcClient GotMotdEnd Event NetIRC2 IRC Client Library for .NET
Called when the server has finished sending the Message of the Day.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler GotMotdEnd
public event EventHandler GotMotdEnd
Public Event GotMotdEnd As EventHandler
Public Event GotMotdEnd As EventHandler
public:
 event EventHandler^ GotMotdEnd {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
public:
 event EventHandler^ GotMotdEnd {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member GotMotdEnd : IEvent<EventHandler,
    EventArgs>
member GotMotdEnd : IEvent<EventHandler,
    EventArgs>
See Also
IrcClient Class
IrcClient Members


GotMotdText Event

IrcClient GotMotdText Event NetIRC2 IRC Client Library for .NET
Called for each line of the Message of the Day sent by the server.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<SimpleMessageEventArgs> GotMotdText
public event EventHandler<SimpleMessageEventArgs> GotMotdText
Public Event GotMotdText As EventHandler(Of SimpleMessageEventArgs)
Public Event GotMotdText As EventHandler(Of SimpleMessageEventArgs)
public:
 event EventHandler<SimpleMessageEventArgs^>^ GotMotdText {
    void add (EventHandler<SimpleMessageEventArgs^>^ value);
    void remove (EventHandler<SimpleMessageEventArgs^>^ value);
}
public:
 event EventHandler<SimpleMessageEventArgs^>^ GotMotdText {
    void add (EventHandler<SimpleMessageEventArgs^>^ value);
    void remove (EventHandler<SimpleMessageEventArgs^>^ value);
}
member GotMotdText : IEvent<EventHandler<SimpleMessageEventArgs>,
    SimpleMessageEventArgs>
member GotMotdText : IEvent<EventHandler<SimpleMessageEventArgs>,
    SimpleMessageEventArgs>
See Also
IrcClient Class
IrcClient Members


GotNameChange Event

IrcClient GotNameChange Event NetIRC2 IRC Client Library for .NET
Called when someone changes their name.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<NameChangeEventArgs> GotNameChange
public event EventHandler<NameChangeEventArgs> GotNameChange
Public Event GotNameChange As EventHandler(Of NameChangeEventArgs)
Public Event GotNameChange As EventHandler(Of NameChangeEventArgs)
public:
 event EventHandler<NameChangeEventArgs^>^ GotNameChange {
    void add (EventHandler<NameChangeEventArgs^>^ value);
    void remove (EventHandler<NameChangeEventArgs^>^ value);
}
public:
 event EventHandler<NameChangeEventArgs^>^ GotNameChange {
    void add (EventHandler<NameChangeEventArgs^>^ value);
    void remove (EventHandler<NameChangeEventArgs^>^ value);
}
member GotNameChange : IEvent<EventHandler<NameChangeEventArgs>,
    NameChangeEventArgs>
member GotNameChange : IEvent<EventHandler<NameChangeEventArgs>,
    NameChangeEventArgs>
See Also
IrcClient Class
IrcClient Members


GotNameListEnd Event

IrcClient GotNameListEnd Event NetIRC2 IRC Client Library for .NET
Called at the completion of a channel's user list.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<NameListEndEventArgs> GotNameListEnd
public event EventHandler<NameListEndEventArgs> GotNameListEnd
Public Event GotNameListEnd As EventHandler(Of NameListEndEventArgs)
Public Event GotNameListEnd As EventHandler(Of NameListEndEventArgs)
public:
 event EventHandler<NameListEndEventArgs^>^ GotNameListEnd {
    void add (EventHandler<NameListEndEventArgs^>^ value);
    void remove (EventHandler<NameListEndEventArgs^>^ value);
}
public:
 event EventHandler<NameListEndEventArgs^>^ GotNameListEnd {
    void add (EventHandler<NameListEndEventArgs^>^ value);
    void remove (EventHandler<NameListEndEventArgs^>^ value);
}
member GotNameListEnd : IEvent<EventHandler<NameListEndEventArgs>,
    NameListEndEventArgs>
member GotNameListEnd : IEvent<EventHandler<NameListEndEventArgs>,
    NameListEndEventArgs>
See Also
IrcClient Class
IrcClient Members


GotNameListReply Event

IrcClient GotNameListReply Event NetIRC2 IRC Client Library for .NET
Called when the server is sending a channel's user list.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<NameListReplyEventArgs> GotNameListReply
public event EventHandler<NameListReplyEventArgs> GotNameListReply
Public Event GotNameListReply As EventHandler(Of NameListReplyEventArgs)
Public Event GotNameListReply As EventHandler(Of NameListReplyEventArgs)
public:
 event EventHandler<NameListReplyEventArgs^>^ GotNameListReply {
    void add (EventHandler<NameListReplyEventArgs^>^ value);
    void remove (EventHandler<NameListReplyEventArgs^>^ value);
}
public:
 event EventHandler<NameListReplyEventArgs^>^ GotNameListReply {
    void add (EventHandler<NameListReplyEventArgs^>^ value);
    void remove (EventHandler<NameListReplyEventArgs^>^ value);
}
member GotNameListReply : IEvent<EventHandler<NameListReplyEventArgs>,
    NameListReplyEventArgs>
member GotNameListReply : IEvent<EventHandler<NameListReplyEventArgs>,
    NameListReplyEventArgs>
See Also
IrcClient Class
IrcClient Members


GotNotice Event

IrcClient GotNotice Event NetIRC2 IRC Client Library for .NET
Called when someone sends a notice. Notices differ from ordinary messages in that, by convention, one should not send an automated reply in response (such as 'I am away from the keyboard.').

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<ChatMessageEventArgs> GotNotice
public event EventHandler<ChatMessageEventArgs> GotNotice
Public Event GotNotice As EventHandler(Of ChatMessageEventArgs)
Public Event GotNotice As EventHandler(Of ChatMessageEventArgs)
public:
 event EventHandler<ChatMessageEventArgs^>^ GotNotice {
    void add (EventHandler<ChatMessageEventArgs^>^ value);
    void remove (EventHandler<ChatMessageEventArgs^>^ value);
}
public:
 event EventHandler<ChatMessageEventArgs^>^ GotNotice {
    void add (EventHandler<ChatMessageEventArgs^>^ value);
    void remove (EventHandler<ChatMessageEventArgs^>^ value);
}
member GotNotice : IEvent<EventHandler<ChatMessageEventArgs>,
    ChatMessageEventArgs>
member GotNotice : IEvent<EventHandler<ChatMessageEventArgs>,
    ChatMessageEventArgs>
See Also
IrcClient Class
IrcClient Members


GotPingReply Event

IrcClient GotPingReply Event NetIRC2 IRC Client Library for .NET
Called on a user's reply to a ping.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<PingReplyEventArgs> GotPingReply
public event EventHandler<PingReplyEventArgs> GotPingReply
Public Event GotPingReply As EventHandler(Of PingReplyEventArgs)
Public Event GotPingReply As EventHandler(Of PingReplyEventArgs)
public:
 event EventHandler<PingReplyEventArgs^>^ GotPingReply {
    void add (EventHandler<PingReplyEventArgs^>^ value);
    void remove (EventHandler<PingReplyEventArgs^>^ value);
}
public:
 event EventHandler<PingReplyEventArgs^>^ GotPingReply {
    void add (EventHandler<PingReplyEventArgs^>^ value);
    void remove (EventHandler<PingReplyEventArgs^>^ value);
}
member GotPingReply : IEvent<EventHandler<PingReplyEventArgs>,
    PingReplyEventArgs>
member GotPingReply : IEvent<EventHandler<PingReplyEventArgs>,
    PingReplyEventArgs>
See Also
IrcClient Class
IrcClient Members


GotUserKicked Event

IrcClient GotUserKicked Event NetIRC2 IRC Client Library for .NET
Called when a user is kicked from a channel.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<KickEventArgs> GotUserKicked
public event EventHandler<KickEventArgs> GotUserKicked
Public Event GotUserKicked As EventHandler(Of KickEventArgs)
Public Event GotUserKicked As EventHandler(Of KickEventArgs)
public:
 event EventHandler<KickEventArgs^>^ GotUserKicked {
    void add (EventHandler<KickEventArgs^>^ value);
    void remove (EventHandler<KickEventArgs^>^ value);
}
public:
 event EventHandler<KickEventArgs^>^ GotUserKicked {
    void add (EventHandler<KickEventArgs^>^ value);
    void remove (EventHandler<KickEventArgs^>^ value);
}
member GotUserKicked : IEvent<EventHandler<KickEventArgs>,
    KickEventArgs>
member GotUserKicked : IEvent<EventHandler<KickEventArgs>,
    KickEventArgs>
See Also
IrcClient Class
IrcClient Members


GotUserQuit Event

IrcClient GotUserQuit Event NetIRC2 IRC Client Library for .NET
Called when a user disconnects from the server.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<QuitEventArgs> GotUserQuit
public event EventHandler<QuitEventArgs> GotUserQuit
Public Event GotUserQuit As EventHandler(Of QuitEventArgs)
Public Event GotUserQuit As EventHandler(Of QuitEventArgs)
public:
 event EventHandler<QuitEventArgs^>^ GotUserQuit {
    void add (EventHandler<QuitEventArgs^>^ value);
    void remove (EventHandler<QuitEventArgs^>^ value);
}
public:
 event EventHandler<QuitEventArgs^>^ GotUserQuit {
    void add (EventHandler<QuitEventArgs^>^ value);
    void remove (EventHandler<QuitEventArgs^>^ value);
}
member GotUserQuit : IEvent<EventHandler<QuitEventArgs>,
    QuitEventArgs>
member GotUserQuit : IEvent<EventHandler<QuitEventArgs>,
    QuitEventArgs>
See Also
IrcClient Class
IrcClient Members


GotWelcomeMessage Event

IrcClient GotWelcomeMessage Event NetIRC2 IRC Client Library for .NET
Called when the server sends the welcome message.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event EventHandler<SimpleMessageEventArgs> GotWelcomeMessage
public event EventHandler<SimpleMessageEventArgs> GotWelcomeMessage
Public Event GotWelcomeMessage As EventHandler(Of SimpleMessageEventArgs)
Public Event GotWelcomeMessage As EventHandler(Of SimpleMessageEventArgs)
public:
 event EventHandler<SimpleMessageEventArgs^>^ GotWelcomeMessage {
    void add (EventHandler<SimpleMessageEventArgs^>^ value);
    void remove (EventHandler<SimpleMessageEventArgs^>^ value);
}
public:
 event EventHandler<SimpleMessageEventArgs^>^ GotWelcomeMessage {
    void add (EventHandler<SimpleMessageEventArgs^>^ value);
    void remove (EventHandler<SimpleMessageEventArgs^>^ value);
}
member GotWelcomeMessage : IEvent<EventHandler<SimpleMessageEventArgs>,
    SimpleMessageEventArgs>
member GotWelcomeMessage : IEvent<EventHandler<SimpleMessageEventArgs>,
    SimpleMessageEventArgs>
See Also
IrcClient Class
IrcClient Members


IrcClientConnectionOptions Class

IrcClientConnectionOptions Class NetIRC2 IRC Client Library for .NET
Provides options used by the Connect(String, Int32, IrcClientConnectionOptions) command.
Inheritance Hierarchy
Online System Object
NetIrc2 IrcClientConnectionOptions

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class IrcClientConnectionOptions
public class IrcClientConnectionOptions
Public Class IrcClientConnectionOptions
Public Class IrcClientConnectionOptions
public ref class IrcClientConnectionOptions
public ref class IrcClientConnectionOptions
type IrcClientConnectionOptions =  class end
type IrcClientConnectionOptions =  class end
See Also
IrcClientConnectionOptions Members


IrcClientConnectionOptions Members

IrcClientConnectionOptions Members NetIRC2 IRC Client Library for .NET

The IrcClientConnectionOptions type exposes the following members.
Constructors
 | Name | Description
Public method | IrcClientConnectionOptions | Initializes a new instance of the IrcClientConnectionOptions class
Back to Top
Properties
 | Name | Description
Public property | Ssl | true to use SSL.
Public property | SslCertificateValidationCallback | The SSL certificate validation callback. If you are using SSL, the callback is not set, and the SSL certificate is invalid, the connection will fail. This can be used to offer the user an option to connect despite the invalid SSL certificate.
Public property | SslHostname | The SSL hostname. You must set this if you are using SSL.
Public property | SynchronizationContext | The synchronization context for the connection. If this is null, IRC events will be raised in an arbitrary thread. If this is not null, all IRC events will be posted to the synchronization context. By default, the synchronization context is captured at construction time. What this means: If you create and use the IRC client from a Windows Forms, WPF, or other GUI thread, events will be raised on the same thread and you will not have to worry about multithreading at all.
Back to Top
See Also
IrcClientConnectionOptions Class


IrcClientConnectionOptions Constructor

IrcClientConnectionOptions Constructor NetIRC2 IRC Client Library for .NET
Initializes a new instance of the IrcClientConnectionOptions class

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcClientConnectionOptions()
public IrcClientConnectionOptions()
Public Sub New
Public Sub New
public:
IrcClientConnectionOptions()
public:
IrcClientConnectionOptions()
new : unit -> IrcClientConnectionOptions
new : unit -> IrcClientConnectionOptions
See Also
IrcClientConnectionOptions Class
IrcClientConnectionOptions Members


IrcClientConnectionOptions Properties

IrcClientConnectionOptions Properties NetIRC2 IRC Client Library for .NET
The IrcClientConnectionOptions type exposes the following members.
Properties
 | Name | Description
Public property | Ssl | true to use SSL.
Public property | SslCertificateValidationCallback | The SSL certificate validation callback. If you are using SSL, the callback is not set, and the SSL certificate is invalid, the connection will fail. This can be used to offer the user an option to connect despite the invalid SSL certificate.
Public property | SslHostname | The SSL hostname. You must set this if you are using SSL.
Public property | SynchronizationContext | The synchronization context for the connection. If this is null, IRC events will be raised in an arbitrary thread. If this is not null, all IRC events will be posted to the synchronization context. By default, the synchronization context is captured at construction time. What this means: If you create and use the IRC client from a Windows Forms, WPF, or other GUI thread, events will be raised on the same thread and you will not have to worry about multithreading at all.
Back to Top
See Also
IrcClientConnectionOptions Class


Ssl Property

IrcClientConnectionOptions Ssl Property NetIRC2 IRC Client Library for .NET
true to use SSL.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Ssl { get; set; }
public bool Ssl { get; set; }
Public Property Ssl As Boolean
    Get
    Set
Public Property Ssl As Boolean
    Get
    Set
public:
property bool Ssl {
    bool get ();
    void set (bool value);
}
public:
property bool Ssl {
    bool get ();
    void set (bool value);
}
member Ssl : bool with get, set
member Ssl : bool with get, set
See Also
IrcClientConnectionOptions Class
IrcClientConnectionOptions Members


SslCertificateValidationCallback Property

IrcClientConnectionOptions SslCertificateValidationCallback Property NetIRC2 IRC Client Library for .NET
The SSL certificate validation callback. If you are using SSL, the callback is not set, and the SSL certificate is invalid, the connection will fail. This can be used to offer the user an option to connect despite the invalid SSL certificate.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public RemoteCertificateValidationCallback SslCertificateValidationCallback { get; set; }
public RemoteCertificateValidationCallback SslCertificateValidationCallback { get; set; }
Public Property SslCertificateValidationCallback As RemoteCertificateValidationCallback
    Get
    Set
Public Property SslCertificateValidationCallback As RemoteCertificateValidationCallback
    Get
    Set
public:
property RemoteCertificateValidationCallback^ SslCertificateValidationCallback {
    RemoteCertificateValidationCallback^ get ();
    void set (RemoteCertificateValidationCallback^ value);
}
public:
property RemoteCertificateValidationCallback^ SslCertificateValidationCallback {
    RemoteCertificateValidationCallback^ get ();
    void set (RemoteCertificateValidationCallback^ value);
}
member SslCertificateValidationCallback : RemoteCertificateValidationCallback with get, set
member SslCertificateValidationCallback : RemoteCertificateValidationCallback with get, set
See Also
IrcClientConnectionOptions Class
IrcClientConnectionOptions Members


SslHostname Property

IrcClientConnectionOptions SslHostname Property NetIRC2 IRC Client Library for .NET
The SSL hostname. You must set this if you are using SSL.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string SslHostname { get; set; }
public string SslHostname { get; set; }
Public Property SslHostname As String
    Get
    Set
Public Property SslHostname As String
    Get
    Set
public:
property String^ SslHostname {
    String^ get ();
    void set (String^ value);
}
public:
property String^ SslHostname {
    String^ get ();
    void set (String^ value);
}
member SslHostname : string with get, set
member SslHostname : string with get, set
See Also
IrcClientConnectionOptions Class
IrcClientConnectionOptions Members


SynchronizationContext Property

IrcClientConnectionOptions SynchronizationContext Property NetIRC2 IRC Client Library for .NET
The synchronization context for the connection. If this is null, IRC events will be raised in an arbitrary thread. If this is not null, all IRC events will be posted to the synchronization context. By default, the synchronization context is captured at construction time. What this means: If you create and use the IRC client from a Windows Forms, WPF, or other GUI thread, events will be raised on the same thread and you will not have to worry about multithreading at all.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SynchronizationContext SynchronizationContext { get; set; }
public SynchronizationContext SynchronizationContext { get; set; }
Public Property SynchronizationContext As SynchronizationContext
    Get
    Set
Public Property SynchronizationContext As SynchronizationContext
    Get
    Set
public:
property SynchronizationContext^ SynchronizationContext {
    SynchronizationContext^ get ();
    void set (SynchronizationContext^ value);
}
public:
property SynchronizationContext^ SynchronizationContext {
    SynchronizationContext^ get ();
    void set (SynchronizationContext^ value);
}
member SynchronizationContext : SynchronizationContext with get, set
member SynchronizationContext : SynchronizationContext with get, set
See Also
IrcClientConnectionOptions Class
IrcClientConnectionOptions Members


IrcIdentity Class

IrcIdentity Class NetIRC2 IRC Client Library for .NET
Stores an IRC user's identity information - their nickname, username, and hostname.
Inheritance Hierarchy
Online System Object
NetIrc2 IrcIdentity

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class IrcIdentity
public class IrcIdentity
Public Class IrcIdentity
Public Class IrcIdentity
public ref class IrcIdentity
public ref class IrcIdentity
type IrcIdentity =  class end
type IrcIdentity =  class end
See Also
IrcIdentity Members


IrcIdentity Members

IrcIdentity Members NetIRC2 IRC Client Library for .NET

The IrcIdentity type exposes the following members.
Constructors
 | Name | Description
Public method | IrcIdentity | Creates a new (blank) IRC identity.
Back to Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Online Object is equal to the current Online Object. (Overrides Online Object Equals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Online Object GetHashCode .)
Public method | ToIrcString | Converts an IRC identity into an IRC string.
Public method | ToString | Returns a Online String that represents the current Online Object. (Overrides Online Object ToString .)
 | TryParse | Tries to parse a string to get an IRC identity. IRC identities are formatted as nickname!username@hostname.
Back to Top
Operators
Name | Description
Equality | Compares two identities for equality.
(IrcIdentity to IrcString) | Converts an IRC identity into an IRC string.
Inequality | Compares two identities for inequality.
Back to Top
Properties
 | Name | Description
Public property | Hostname | The user's hostname.
Public property | Nickname | The user's IRC nickname (the name shown in channels).
Public property | Username | The username.
Back to Top
See Also
IrcIdentity Class


IrcIdentity Constructor

IrcIdentity Constructor NetIRC2 IRC Client Library for .NET
Creates a new (blank) IRC identity.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcIdentity()
public IrcIdentity()
Public Sub New
Public Sub New
public:
IrcIdentity()
public:
IrcIdentity()
new : unit -> IrcIdentity
new : unit -> IrcIdentity
See Also
IrcIdentity Class
IrcIdentity Members


IrcIdentity Methods

IrcIdentity Methods NetIRC2 IRC Client Library for .NET
The IrcIdentity type exposes the following members.
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Online Object is equal to the current Online Object. (Overrides Online Object Equals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Online Object GetHashCode .)
Public method | ToIrcString | Converts an IRC identity into an IRC string.
Public method | ToString | Returns a Online String that represents the current Online Object. (Overrides Online Object ToString .)
 | TryParse | Tries to parse a string to get an IRC identity. IRC identities are formatted as nickname!username@hostname.
Back to Top
See Also
IrcIdentity Class


Equals Method

IrcIdentity Equals Method NetIRC2 IRC Client Library for .NET
Determines whether the specified Online Object is equal to the current Online Object.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object
The Online Object to compare with the current Online Object.

Return Value

true if the specified Online Object is equal to the current Online Object; otherwise, false.
See Also
IrcIdentity Class
IrcIdentity Members


GetHashCode Method

IrcIdentity GetHashCode Method NetIRC2 IRC Client Library for .NET
Serves as a hash function for a particular type.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

A hash code for the current Online Object.
See Also
IrcIdentity Class
IrcIdentity Members


ToIrcString Method

IrcIdentity ToIrcString Method NetIRC2 IRC Client Library for .NET
Converts an IRC identity into an IRC string.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString ToIrcString()
public IrcString ToIrcString()
Public Function ToIrcString As IrcString
Public Function ToIrcString As IrcString
public:
IrcString^ ToIrcString()
public:
IrcString^ ToIrcString()
member ToIrcString : unit -> IrcString
member ToIrcString : unit -> IrcString

Return Value

The IRC string.
See Also
IrcIdentity Class
IrcIdentity Members


ToString Method

IrcIdentity ToString Method NetIRC2 IRC Client Library for .NET
Returns a Online String that represents the current Online Object.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

A Online String that represents the current Online Object.
See Also
IrcIdentity Class
IrcIdentity Members


TryParse Method

IrcIdentity TryParse Method NetIRC2 IRC Client Library for .NET
Tries to parse a string to get an IRC identity. IRC identities are formatted as nickname!username@hostname.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TryParse(
    IrcString string,
    out IrcIdentity identity
)
public static bool TryParse(
    IrcString string,
    out IrcIdentity identity
)
Public Shared Function TryParse ( _
    string As IrcString, _
    <OutAttribute> ByRef identity As IrcIdentity _
) As Boolean
Public Shared Function TryParse ( _
    string As IrcString, _
    <OutAttribute> ByRef identity As IrcIdentity _
) As Boolean
public:
static bool TryParse(
    IrcString^ string,
    [OutAttribute] IrcIdentity^% identity
)
public:
static bool TryParse(
    IrcString^ string,
    [OutAttribute] IrcIdentity^% identity
)
static member TryParse :
        string : IrcString *
        identity : IrcIdentity byref -> bool
static member TryParse :
        string : IrcString *
        identity : IrcIdentity byref -> bool

Parameters

string
Type: NetIrc2 IrcString
The string to parse.
identity
Type: NetIrc2 IrcIdentity
The identity, or null if parsing fails.

Return Value

true if parsing completed successfully.
See Also
IrcIdentity Class
IrcIdentity Members


IrcIdentity Operators and Type Conversions

IrcIdentity Operators and Type Conversions NetIRC2 IRC Client Library for .NET
The IrcIdentity type exposes the following members.
Operators
Name | Description
Equality | Compares two identities for equality.
(IrcIdentity to IrcString) | Converts an IRC identity into an IRC string.
Inequality | Compares two identities for inequality.
Back to Top
See Also
IrcIdentity Class


Equality Operator

IrcIdentity Equality Operator NetIRC2 IRC Client Library for .NET
Compares two identities for equality.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    IrcIdentity identity1,
    IrcIdentity identity2
)
public static bool operator ==(
    IrcIdentity identity1,
    IrcIdentity identity2
)
Public Shared Operator = ( _
    identity1 As IrcIdentity, _
    identity2 As IrcIdentity _
) As Boolean
Public Shared Operator = ( _
    identity1 As IrcIdentity, _
    identity2 As IrcIdentity _
) As Boolean
public:
static bool operator ==(
    IrcIdentity^ identity1,
    IrcIdentity^ identity2
)
public:
static bool operator ==(
    IrcIdentity^ identity1,
    IrcIdentity^ identity2
)
static let inline (=)
        identity1 : IrcIdentity *
        identity2 : IrcIdentity  : bool
static let inline (=)
        identity1 : IrcIdentity *
        identity2 : IrcIdentity  : bool

Parameters

identity1
Type: NetIrc2 IrcIdentity
The first identity.
identity2
Type: NetIrc2 IrcIdentity
The second identity.

Return Value

true if the identities are equal.
See Also
IrcIdentity Class
IrcIdentity Members


Implicit Conversion (IrcIdentity to IrcString)

IrcIdentity Conversion (IrcIdentity to IrcString) NetIRC2 IRC Client Library for .NET
Converts an IRC identity into an IRC string.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static implicit operator IrcString (
    IrcIdentity identity
)
public static implicit operator IrcString (
    IrcIdentity identity
)
Public Shared Widening Operator CType ( _
    identity As IrcIdentity _
) As IrcString
Public Shared Widening Operator CType ( _
    identity As IrcIdentity _
) As IrcString
static implicit operator IrcString^ (
    IrcIdentity^ identity
)
static implicit operator IrcString^ (
    IrcIdentity^ identity
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

identity
Type: NetIrc2 IrcIdentity
The IRC identity.

Return Value

The IRC string.
See Also
IrcIdentity Class
IrcIdentity Members


Inequality Operator

IrcIdentity Inequality Operator NetIRC2 IRC Client Library for .NET
Compares two identities for inequality.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    IrcIdentity identity1,
    IrcIdentity identity2
)
public static bool operator !=(
    IrcIdentity identity1,
    IrcIdentity identity2
)
Public Shared Operator <> ( _
    identity1 As IrcIdentity, _
    identity2 As IrcIdentity _
) As Boolean
Public Shared Operator <> ( _
    identity1 As IrcIdentity, _
    identity2 As IrcIdentity _
) As Boolean
public:
static bool operator !=(
    IrcIdentity^ identity1,
    IrcIdentity^ identity2
)
public:
static bool operator !=(
    IrcIdentity^ identity1,
    IrcIdentity^ identity2
)
static let inline (<>)
        identity1 : IrcIdentity *
        identity2 : IrcIdentity  : bool
static let inline (<>)
        identity1 : IrcIdentity *
        identity2 : IrcIdentity  : bool

Parameters

identity1
Type: NetIrc2 IrcIdentity
The first identity.
identity2
Type: NetIrc2 IrcIdentity
The second identity.

Return Value

true if the identities are not equal.
See Also
IrcIdentity Class
IrcIdentity Members


IrcIdentity Properties

IrcIdentity Properties NetIRC2 IRC Client Library for .NET
The IrcIdentity type exposes the following members.
Properties
 | Name | Description
Public property | Hostname | The user's hostname.
Public property | Nickname | The user's IRC nickname (the name shown in channels).
Public property | Username | The username.
Back to Top
See Also
IrcIdentity Class


Hostname Property

IrcIdentity Hostname Property NetIRC2 IRC Client Library for .NET
The user's hostname.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString Hostname { get; set; }
public IrcString Hostname { get; set; }
Public Property Hostname As IrcString
    Get
    Set
Public Property Hostname As IrcString
    Get
    Set
public:
property IrcString^ Hostname {
    IrcString^ get ();
    void set (IrcString^ value);
}
public:
property IrcString^ Hostname {
    IrcString^ get ();
    void set (IrcString^ value);
}
member Hostname : IrcString with get, set
member Hostname : IrcString with get, set
See Also
IrcIdentity Class
IrcIdentity Members


Nickname Property

IrcIdentity Nickname Property NetIRC2 IRC Client Library for .NET
The user's IRC nickname (the name shown in channels).

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString Nickname { get; set; }
public IrcString Nickname { get; set; }
Public Property Nickname As IrcString
    Get
    Set
Public Property Nickname As IrcString
    Get
    Set
public:
property IrcString^ Nickname {
    IrcString^ get ();
    void set (IrcString^ value);
}
public:
property IrcString^ Nickname {
    IrcString^ get ();
    void set (IrcString^ value);
}
member Nickname : IrcString with get, set
member Nickname : IrcString with get, set
See Also
IrcIdentity Class
IrcIdentity Members


Username Property

IrcIdentity Username Property NetIRC2 IRC Client Library for .NET
The username.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString Username { get; set; }
public IrcString Username { get; set; }
Public Property Username As IrcString
    Get
    Set
Public Property Username As IrcString
    Get
    Set
public:
property IrcString^ Username {
    IrcString^ get ();
    void set (IrcString^ value);
}
public:
property IrcString^ Username {
    IrcString^ get ();
    void set (IrcString^ value);
}
member Username : IrcString with get, set
member Username : IrcString with get, set
See Also
IrcIdentity Class
IrcIdentity Members


IrcReplyCode Enumeration

IrcReplyCode Enumeration NetIRC2 IRC Client Library for .NET
Many of the common IRC error and reply codes.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum IrcReplyCode
public enum IrcReplyCode
Public Enumeration IrcReplyCode
Public Enumeration IrcReplyCode
public enum class IrcReplyCode
public enum class IrcReplyCode
type IrcReplyCode
type IrcReplyCode
Members
Member name | Value | Description
NoSuchNickname | 401 | States that a nickname you specified does not exist on the server.
NoSuchServer | 402 | States that a server you specified could be found.
NoSuchChannel | 403 | States that a channel you specified could not be found.
CannotSendToChannel | 404 | States that you are not allowed to send to a specific channel.
TooManyChannels | 405 | States that there are already too many channels on the server.
WasNoSuchNickname | 406 | States that the nickname you asked about never existed.
TooManyTargets | 407 | States that you specified too many targets for your message.
NoOriginSpecified | 409 | States that your ping/pong message did not have an origin parameter.
NoRecipientGiven | 411 | States that you did not specify a target for your message.
NoTextToSend | 412 | States that there was no text to send.
NoTopLevelDomainSpecified | 413 | States that a message could not be delivered, because no top level domain name was specified. In other words, you sent a malformed message.
WildcardInTopLevelDomain | 414 | States that a message could not be delivered, because there was a wildcard in the top level domain name you specified. In other words, you sent a malformed message.
UnknownCommand | 421 | States that the server does not understand your command.
MissingMOTD | 422 | States that the server's Message of the Day file is missing.
NoAdminInfoAvailable | 423 | States that no administrative information could be found. This only occurs in response to a request for said information.
FileError | 424 | States that an error occured when transferring a message. This is a fairly generic message, and does not necessarily mean you did anything incorrectly.
NoNicknameGiven | 431 | States that a nickname parameter was expected and was not received.
ErroneousNickname | 432 | States that the nickname you specified contained invalid characters.
NicknameInUse | 433 | States that the nickname you specified is already in use.
NicknameCollision | 436 | States that the nickname you specified is already in use, but on another server.
ResourceUnavailable | 437 | States that the nickname or channel is temporarily unavailable.
UserNotInChannel | 441 | States that the user specified for a command pertaining to a specific channel is not in the channel.
NotInChannel | 442 | States that you are not in the channel you are trying to act upon.
UserAlreadyInChannel | 443 | States that the user you invited to a channel is already in said channel.
UserNotLoggedIn | 444 | States that the user specified could not be summoned, because they are not logged in.
SummonCommandDisabled | 445 | States that summoning is disabled.
UsersCommandDisabled | 446 | States that the 'USERS' command is disabled.
HaveNotRegistered | 451 | States that you are not registered with the server, and registration is required for an action you attempted.
NotEnoughParameters | 461 | States that an IRC command lacked some parameters.
AlreadyRegistered | 462 | States that you may not reregister with the server.
UnpriviledgedHost | 463 | States that you may not communicate with the server, because you do not have the appropriate priviledges.
IncorrectPassword | 464 | States that the password you specified to connect was invalid.
BannedFromServer | 465 | States that the server has been set up to deny connections to your computer.
ChannelKeyAlreadySet | 467 | States that the channel key has already been set.
ChannelIsFull | 471 | States that the requested channel cannot be joined because it is full.
UnknownModeCharacter | 472 | States that a mode character you sent was invalid.
InviteOnlyChannel | 473 | States that the channel could not be joined because it is invite-only.
BannedFromChannel | 474 | States that you are banned from the channel.
BadChannelKey | 475 | States that the channel could not be joined because the specified channel key was incorrect.
BadChannelName | 479 | States that the channel name contains invalid characters.
NotIRCOperator | 481 | States that the client does not have IRC operator priviledges, which are required for some command that was attempted.
NotChannelOperator | 482 | States that you are not a channel operator for a channel and tried to do an action that required that.
CannotKillServer | 483 | States that you may not kill the server.
HostCannotUseOperCommand | 491 | States that the server is not set up to allow operator commands from your host.
UnknownModeFlag | 501 | States that a mode change on a nickname included an unknown flag.
See Also


IrcString Class

IrcString Class NetIRC2 IRC Client Library for .NET
Allows string-style manipulation of arrays of bytes. IRC does not define an encoding, so this provides for encoding-agnostic parsing.
Inheritance Hierarchy
Online System Object
NetIrc2 IrcString

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class IrcString : IEquatable<IrcString>,
    IList<byte>, ICollection<byte>, IEnumerable<byte>, IEnumerable,
    ISerializable
[SerializableAttribute]
public sealed class IrcString : IEquatable<IrcString>,
    IList<byte>, ICollection<byte>, IEnumerable<byte>, IEnumerable,
    ISerializable
<SerializableAttribute> _
Public NotInheritable Class IrcString _
    Implements IEquatable(Of IrcString), IList(Of Byte),  _
    ICollection(Of Byte), IEnumerable(Of Byte), IEnumerable,  _
    ISerializable
<SerializableAttribute> _
Public NotInheritable Class IrcString _
    Implements IEquatable(Of IrcString), IList(Of Byte),  _
    ICollection(Of Byte), IEnumerable(Of Byte), IEnumerable,  _
    ISerializable
[SerializableAttribute]
public ref class IrcString sealed : IEquatable<IrcString^>,
    IList<unsigned char>, ICollection<unsigned char>, IEnumerable<unsigned char>,
    IEnumerable, ISerializable
[SerializableAttribute]
public ref class IrcString sealed : IEquatable<IrcString^>,
    IList<unsigned char>, ICollection<unsigned char>, IEnumerable<unsigned char>,
    IEnumerable, ISerializable
[<SealedAttribute>]
[<SerializableAttribute>]
type IrcString =
    class
        interface IEquatable<IrcString>
        interface IList<byte>
        interface ICollection<byte>
        interface IEnumerable<byte>
        interface IEnumerable
        interface ISerializable
    end
[<SealedAttribute>]
[<SerializableAttribute>]
type IrcString =
    class
        interface IEquatable<IrcString>
        interface IList<byte>
        interface ICollection<byte>
        interface IEnumerable<byte>
        interface IEnumerable
        interface ISerializable
    end
See Also
IrcString Members


IrcString Members

IrcString Members NetIRC2 IRC Client Library for .NET

The IrcString type exposes the following members.
Constructors
 | Name | Description
Public method | IrcString( Byte ) | Creates an IRC string from a byte array.
Public method | IrcString(String) | Creates an IRC string by converting a .NET string using UTF-8 encoding.
Public method | IrcString(String, Encoding) | Creates an IRC string by converting a .NET string using the specified encoding.
Public method | IrcString( Byte , Int32, Int32) | Creates an IRC string from part of a byte array.
Back to Top
Methods
 | Name | Description
Public method | Contains | Checks if the string contains a particular byte.
Public method | CopyTo | Copies the string into a byte array.
Public method | Equals(Object) | Determines whether the specified Online Object is equal to the current Online Object. (Overrides Online Object Equals(Object).)
Public method | Equals(IrcString) | Compares the current string with another string.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Online Object GetHashCode .)
Public method | IndexOf(Byte) | Scans the string for the first instance of a particular byte.
Public method | IndexOf(Byte, Int32) | Scans part of the string for the first instance of a particular byte.
Public method | IndexOf(Func Byte, Boolean , Int32, Int32) | Scans part of the string for the first byte that matches the specified condition.
 | Join | Joins together a number of strings.
Public method | Split(Byte) | Splits the string into a number of substrings based on a separator.
Public method | Split(Byte, Int32) | Splits the string into a limited number of substrings based on a separator.
Public method | StartsWith | Checks if the start of the current string matches the specified string.
Public method | Substring(Int32) | Extracts the end of a string.
Public method | Substring(Int32, Int32) | Extracts part of a string.
Public method | ToByteArray | Gets the bytes that make up the IRC string.
Public method | ToString | Converts to a .NET string using UTF-8 encoding. (Overrides Online Object ToString .)
Public method | ToString(Encoding) | Converts to a .NET string using the specified encoding.
Back to Top
Operators
Name | Description
Addition | Concatenates two strings.
Equality | Compares two strings for equality.
( Byte to IrcString) | Casts a byte array to an IRC string.
(String to IrcString) | Casts a .NET string to an IRC string using UTF-8 encoding.
(IrcString to String) | Casts the IRC string to a .NET string using UTF-8 encoding.
(IrcString to Byte ) | Casts the IRC string to a byte array.
Inequality | Compares two strings for inequality.
Back to Top
Fields
Name | Description
Empty | A zero-byte string.
Back to Top
Properties
 | Name | Description
Public property | Item | Gets a byte from the IRC string.
Public property | Length | The length of the IRC string, in bytes.
Back to Top
See Also
IrcString Class


IrcString Constructor

IrcString Constructor NetIRC2 IRC Client Library for .NET
Overload List
 | Name | Description
Public method | IrcString( Byte ) | Creates an IRC string from a byte array.
Public method | IrcString(String) | Creates an IRC string by converting a .NET string using UTF-8 encoding.
Public method | IrcString(String, Encoding) | Creates an IRC string by converting a .NET string using the specified encoding.
Public method | IrcString( Byte , Int32, Int32) | Creates an IRC string from part of a byte array.
Back to Top
See Also
IrcString Class
IrcString Members


IrcString Constructor (Byte[])

IrcString Constructor ( Byte ) NetIRC2 IRC Client Library for .NET
Creates an IRC string from a byte array.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString(
    byte[] buffer
)
public IrcString(
    byte[] buffer
)
Public Sub New ( _
    buffer As Byte() _
)
Public Sub New ( _
    buffer As Byte() _
)
public:
IrcString(
    array<unsigned char>^ buffer
)
public:
IrcString(
    array<unsigned char>^ buffer
)
new :
        buffer : byte[] -> IrcString
new :
        buffer : byte[] -> IrcString

Parameters

buffer
Type: Online System Byte
The array of bytes.
See Also
IrcString Class
IrcString Members
IrcString Overload


IrcString Constructor (String)

IrcString Constructor (String) NetIRC2 IRC Client Library for .NET
Creates an IRC string by converting a .NET string using UTF-8 encoding.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString(
    string string
)
public IrcString(
    string string
)
Public Sub New ( _
    string As String _
)
Public Sub New ( _
    string As String _
)
public:
IrcString(
    String^ string
)
public:
IrcString(
    String^ string
)
new :
        string : string -> IrcString
new :
        string : string -> IrcString

Parameters

string
Type: Online System String
The .NET string to convert.
See Also
IrcString Class
IrcString Members
IrcString Overload


IrcString Constructor (String, Encoding)

IrcString Constructor (String, Encoding) NetIRC2 IRC Client Library for .NET
Creates an IRC string by converting a .NET string using the specified encoding.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString(
    string string,
    Encoding encoding
)
public IrcString(
    string string,
    Encoding encoding
)
Public Sub New ( _
    string As String, _
    encoding As Encoding _
)
Public Sub New ( _
    string As String, _
    encoding As Encoding _
)
public:
IrcString(
    String^ string,
    Encoding^ encoding
)
public:
IrcString(
    String^ string,
    Encoding^ encoding
)
new :
        string : string *
        encoding : Encoding -> IrcString
new :
        string : string *
        encoding : Encoding -> IrcString

Parameters

string
Type: Online System String
The .NET string to convert.
encoding
Type: Online System.Text Encoding
The encoding to use.
See Also
IrcString Class
IrcString Members
IrcString Overload


IrcString Constructor (Byte[], Int32, Int32)

IrcString Constructor ( Byte , Int32, Int32) NetIRC2 IRC Client Library for .NET
Creates an IRC string from part of a byte array.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString(
    byte[] buffer,
    int startIndex,
    int length
)
public IrcString(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New ( _
    buffer As Byte(), _
    startIndex As Integer, _
    length As Integer _
)
Public Sub New ( _
    buffer As Byte(), _
    startIndex As Integer, _
    length As Integer _
)
public:
IrcString(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)
public:
IrcString(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> IrcString
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> IrcString

Parameters

buffer
Type: Online System Byte
The array of bytes.
startIndex
Type: Online System Int32
The index of the first byte in the new string.
length
Type: Online System Int32
The number of bytes in the new string.
See Also
IrcString Class
IrcString Members
IrcString Overload


IrcString Fields

IrcString Fields NetIRC2 IRC Client Library for .NET
The IrcString type exposes the following members.
Fields
Name | Description
Empty | A zero-byte string.
Back to Top
See Also
IrcString Class


Empty Field

IrcString Empty Field NetIRC2 IRC Client Library for .NET
A zero-byte string.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static readonly IrcString Empty
public static readonly IrcString Empty
Public Shared ReadOnly Empty As IrcString
Public Shared ReadOnly Empty As IrcString
public:
static initonly IrcString^ Empty
public:
static initonly IrcString^ Empty
static val Empty: IrcString
static val Empty: IrcString
See Also
IrcString Class
IrcString Members


IrcString Methods

IrcString Methods NetIRC2 IRC Client Library for .NET
The IrcString type exposes the following members.
Methods
 | Name | Description
Public method | Contains | Checks if the string contains a particular byte.
Public method | CopyTo | Copies the string into a byte array.
Public method | Equals(Object) | Determines whether the specified Online Object is equal to the current Online Object. (Overrides Online Object Equals(Object).)
Public method | Equals(IrcString) | Compares the current string with another string.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides Online Object GetHashCode .)
Public method | IndexOf(Byte) | Scans the string for the first instance of a particular byte.
Public method | IndexOf(Byte, Int32) | Scans part of the string for the first instance of a particular byte.
Public method | IndexOf(Func Byte, Boolean , Int32, Int32) | Scans part of the string for the first byte that matches the specified condition.
 | Join | Joins together a number of strings.
Public method | Split(Byte) | Splits the string into a number of substrings based on a separator.
Public method | Split(Byte, Int32) | Splits the string into a limited number of substrings based on a separator.
Public method | StartsWith | Checks if the start of the current string matches the specified string.
Public method | Substring(Int32) | Extracts the end of a string.
Public method | Substring(Int32, Int32) | Extracts part of a string.
Public method | ToByteArray | Gets the bytes that make up the IRC string.
Public method | ToString | Converts to a .NET string using UTF-8 encoding. (Overrides Online Object ToString .)
Public method | ToString(Encoding) | Converts to a .NET string using the specified encoding.
Back to Top
See Also
IrcString Class


Contains Method

IrcString Contains Method NetIRC2 IRC Client Library for .NET
Checks if the string contains a particular byte.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Contains(
    byte value
)
public bool Contains(
    byte value
)
Public Function Contains ( _
    value As Byte _
) As Boolean
Public Function Contains ( _
    value As Byte _
) As Boolean
public:
virtual bool Contains(
    unsigned char value
) sealed
public:
virtual bool Contains(
    unsigned char value
) sealed
abstract Contains :
        value : byte -> bool
override Contains :
        value : byte -> bool
abstract Contains :
        value : byte -> bool
override Contains :
        value : byte -> bool

Parameters

value
Type: Online System Byte
The byte to look for.

Return Value

true if the string contains the byte.

Implements

Online ICollection T Contains(T)
See Also
IrcString Class
IrcString Members


CopyTo Method

IrcString CopyTo Method NetIRC2 IRC Client Library for .NET
Copies the string into a byte array.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void CopyTo(
    byte[] array,
    int index
)
public void CopyTo(
    byte[] array,
    int index
)
Public Sub CopyTo ( _
    array As Byte(), _
    index As Integer _
)
Public Sub CopyTo ( _
    array As Byte(), _
    index As Integer _
)
public:
virtual void CopyTo(
    array<unsigned char>^ array,
    int index
) sealed
public:
virtual void CopyTo(
    array<unsigned char>^ array,
    int index
) sealed
abstract CopyTo :
        array : byte[] *
        index : int -> unit
override CopyTo :
        array : byte[] *
        index : int -> unit
abstract CopyTo :
        array : byte[] *
        index : int -> unit
override CopyTo :
        array : byte[] *
        index : int -> unit

Parameters

array
Type: Online System Byte
The byte array to copy to.
index
Type: Online System Int32
The starting index to copy to.

Implements

Online ICollection T CopyTo( T , Int32)
See Also
IrcString Class
IrcString Members


Equals Method

IrcString Equals Method NetIRC2 IRC Client Library for .NET
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Online Object is equal to the current Online Object. (Overrides Online Object Equals(Object).)
Public method | Equals(IrcString) | Compares the current string with another string.
Back to Top
See Also
IrcString Class
IrcString Members


Equals Method (Object)

IrcString Equals Method (Object) NetIRC2 IRC Client Library for .NET
Determines whether the specified Online Object is equal to the current Online Object.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool Equals(
    Object obj
)
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: Online System Object
The Online Object to compare with the current Online Object.

Return Value

true if the specified Online Object is equal to the current Online Object; otherwise, false.
See Also
IrcString Class
IrcString Members
Equals Overload


Equals Method (IrcString)

IrcString Equals Method (IrcString) NetIRC2 IRC Client Library for .NET
Compares the current string with another string.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Equals(
    IrcString other
)
public bool Equals(
    IrcString other
)
Public Function Equals ( _
    other As IrcString _
) As Boolean
Public Function Equals ( _
    other As IrcString _
) As Boolean
public:
virtual bool Equals(
    IrcString^ other
) sealed
public:
virtual bool Equals(
    IrcString^ other
) sealed
abstract Equals :
        other : IrcString -> bool
override Equals :
        other : IrcString -> bool
abstract Equals :
        other : IrcString -> bool
override Equals :
        other : IrcString -> bool

Parameters

other
Type: NetIrc2 IrcString
The string to compare with.

Return Value

true if the strings are equal.

Implements

Online IEquatable T Equals(T)
See Also
IrcString Class
IrcString Members
Equals Overload


GetEnumerator Method

IrcString GetEnumerator Method NetIRC2 IRC Client Library for .NET
Returns an enumerator that iterates through the collection.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IEnumerator<byte> GetEnumerator()
public IEnumerator<byte> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of Byte)
Public Function GetEnumerator As IEnumerator(Of Byte)
public:
virtual IEnumerator<unsigned char>^ GetEnumerator() sealed
public:
virtual IEnumerator<unsigned char>^ GetEnumerator() sealed
abstract GetEnumerator : unit -> IEnumerator<byte>
override GetEnumerator : unit -> IEnumerator<byte>
abstract GetEnumerator : unit -> IEnumerator<byte>
override GetEnumerator : unit -> IEnumerator<byte>

Return Value

A Online IEnumerator T that can be used to iterate through the collection.

Implements

Online IEnumerable T GetEnumerator
See Also
IrcString Class
IrcString Members


GetHashCode Method

IrcString GetHashCode Method NetIRC2 IRC Client Library for .NET
Serves as a hash function for a particular type.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override int GetHashCode()
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

A hash code for the current Online Object.
See Also
IrcString Class
IrcString Members


IndexOf Method

IrcString IndexOf Method NetIRC2 IRC Client Library for .NET
Overload List
 | Name | Description
Public method | IndexOf(Byte) | Scans the string for the first instance of a particular byte.
Public method | IndexOf(Byte, Int32) | Scans part of the string for the first instance of a particular byte.
Public method | IndexOf(Func Byte, Boolean , Int32, Int32) | Scans part of the string for the first byte that matches the specified condition.
Back to Top
See Also
IrcString Class
IrcString Members


IndexOf Method (Byte)

IrcString IndexOf Method (Byte) NetIRC2 IRC Client Library for .NET
Scans the string for the first instance of a particular byte.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int IndexOf(
    byte value
)
public int IndexOf(
    byte value
)
Public Function IndexOf ( _
    value As Byte _
) As Integer
Public Function IndexOf ( _
    value As Byte _
) As Integer
public:
virtual int IndexOf(
    unsigned char value
) sealed
public:
virtual int IndexOf(
    unsigned char value
) sealed
abstract IndexOf :
        value : byte -> int
override IndexOf :
        value : byte -> int
abstract IndexOf :
        value : byte -> int
override IndexOf :
        value : byte -> int

Parameters

value
Type: Online System Byte
The byte to look for.

Return Value

The index of the first matching byte, or -1.

Implements

Online IList T IndexOf(T)
See Also
IrcString Class
IrcString Members
IndexOf Overload


IndexOf Method (Byte, Int32)

IrcString IndexOf Method (Byte, Int32) NetIRC2 IRC Client Library for .NET
Scans part of the string for the first instance of a particular byte.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int IndexOf(
    byte value,
    int startIndex
)
public int IndexOf(
    byte value,
    int startIndex
)
Public Function IndexOf ( _
    value As Byte, _
    startIndex As Integer _
) As Integer
Public Function IndexOf ( _
    value As Byte, _
    startIndex As Integer _
) As Integer
public:
int IndexOf(
    unsigned char value,
    int startIndex
)
public:
int IndexOf(
    unsigned char value,
    int startIndex
)
member IndexOf :
        value : byte *
        startIndex : int -> int
member IndexOf :
        value : byte *
        startIndex : int -> int

Parameters

value
Type: Online System Byte
The byte to look for.
startIndex
Type: Online System Int32
The first byte to begin scanning at.

Return Value

The index of the first matching byte, or -1.
See Also
IrcString Class
IrcString Members
IndexOf Overload


IndexOf Method (Func(Byte, Boolean), Int32, Int32)

IrcString IndexOf Method (Func Byte, Boolean , Int32, Int32) NetIRC2 IRC Client Library for .NET
Scans part of the string for the first byte that matches the specified condition.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int IndexOf(
    Func<byte, bool> matchCondition,
    int startIndex,
    int length
)
public int IndexOf(
    Func<byte, bool> matchCondition,
    int startIndex,
    int length
)
Public Function IndexOf ( _
    matchCondition As Func(Of Byte, Boolean), _
    startIndex As Integer, _
    length As Integer _
) As Integer
Public Function IndexOf ( _
    matchCondition As Func(Of Byte, Boolean), _
    startIndex As Integer, _
    length As Integer _
) As Integer
public:
int IndexOf(
    Func<unsigned char, bool>^ matchCondition,
    int startIndex,
    int length
)
public:
int IndexOf(
    Func<unsigned char, bool>^ matchCondition,
    int startIndex,
    int length
)
member IndexOf :
        matchCondition : Func<byte, bool> *
        startIndex : int *
        length : int -> int
member IndexOf :
        matchCondition : Func<byte, bool> *
        startIndex : int *
        length : int -> int

Parameters

matchCondition
Type: Online System Func Online Byte, Online Boolean
The condition to match.
startIndex
Type: Online System Int32
The first byte to begin scanning at.
length
Type: Online System Int32
The distance to scan.

Return Value

The index of the first matching byte, or -1.
See Also
IrcString Class
IrcString Members
IndexOf Overload


Join Method

IrcString Join Method NetIRC2 IRC Client Library for .NET
Joins together a number of strings.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IrcString Join(
    IrcString separator,
    IrcString[] strings
)
public static IrcString Join(
    IrcString separator,
    IrcString[] strings
)
Public Shared Function Join ( _
    separator As IrcString, _
    strings As IrcString() _
) As IrcString
Public Shared Function Join ( _
    separator As IrcString, _
    strings As IrcString() _
) As IrcString
public:
static IrcString^ Join(
    IrcString^ separator,
    array<IrcString^>^ strings
)
public:
static IrcString^ Join(
    IrcString^ separator,
    array<IrcString^>^ strings
)
static member Join :
        separator : IrcString *
        strings : IrcString[] -> IrcString
static member Join :
        separator : IrcString *
        strings : IrcString[] -> IrcString

Parameters

separator
Type: NetIrc2 IrcString
The string to separate individual strings with.
strings
Type: NetIrc2 IrcString
The strings to join.

Return Value

The joined string.
See Also
IrcString Class
IrcString Members


Split Method

IrcString Split Method NetIRC2 IRC Client Library for .NET
Overload List
 | Name | Description
Public method | Split(Byte) | Splits the string into a number of substrings based on a separator.
Public method | Split(Byte, Int32) | Splits the string into a limited number of substrings based on a separator.
Back to Top
See Also
IrcString Class
IrcString Members


Split Method (Byte)

IrcString Split Method (Byte) NetIRC2 IRC Client Library for .NET
Splits the string into a number of substrings based on a separator.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString[] Split(
    byte separator
)
public IrcString[] Split(
    byte separator
)
Public Function Split ( _
    separator As Byte _
) As IrcString()
Public Function Split ( _
    separator As Byte _
) As IrcString()
public:
array<IrcString^>^ Split(
    unsigned char separator
)
public:
array<IrcString^>^ Split(
    unsigned char separator
)
member Split :
        separator : byte -> IrcString[]
member Split :
        separator : byte -> IrcString[]

Parameters

separator
Type: Online System Byte
The byte to separate strings by.

Return Value

An array of substrings.
See Also
IrcString Class
IrcString Members
Split Overload


Split Method (Byte, Int32)

IrcString Split Method (Byte, Int32) NetIRC2 IRC Client Library for .NET
Splits the string into a limited number of substrings based on a separator.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString[] Split(
    byte separator,
    int count
)
public IrcString[] Split(
    byte separator,
    int count
)
Public Function Split ( _
    separator As Byte, _
    count As Integer _
) As IrcString()
Public Function Split ( _
    separator As Byte, _
    count As Integer _
) As IrcString()
public:
array<IrcString^>^ Split(
    unsigned char separator,
    int count
)
public:
array<IrcString^>^ Split(
    unsigned char separator,
    int count
)
member Split :
        separator : byte *
        count : int -> IrcString[]
member Split :
        separator : byte *
        count : int -> IrcString[]

Parameters

separator
Type: Online System Byte
The byte to separate strings by.
count
Type: Online System Int32
The maximum number of substrings. The last substring will contain the remaining bytes.

Return Value

An array of substrings.
See Also
IrcString Class
IrcString Members
Split Overload


StartsWith Method

IrcString StartsWith Method NetIRC2 IRC Client Library for .NET
Checks if the start of the current string matches the specified string.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool StartsWith(
    IrcString value
)
public bool StartsWith(
    IrcString value
)
Public Function StartsWith ( _
    value As IrcString _
) As Boolean
Public Function StartsWith ( _
    value As IrcString _
) As Boolean
public:
bool StartsWith(
    IrcString^ value
)
public:
bool StartsWith(
    IrcString^ value
)
member StartsWith :
        value : IrcString -> bool
member StartsWith :
        value : IrcString -> bool

Parameters

value
Type: NetIrc2 IrcString
The string to match with.

Return Value

true if the current string starts with value.
See Also
IrcString Class
IrcString Members


Substring Method

IrcString Substring Method NetIRC2 IRC Client Library for .NET
Overload List
 | Name | Description
Public method | Substring(Int32) | Extracts the end of a string.
Public method | Substring(Int32, Int32) | Extracts part of a string.
Back to Top
See Also
IrcString Class
IrcString Members


Substring Method (Int32)

IrcString Substring Method (Int32) NetIRC2 IRC Client Library for .NET
Extracts the end of a string.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString Substring(
    int startIndex
)
public IrcString Substring(
    int startIndex
)
Public Function Substring ( _
    startIndex As Integer _
) As IrcString
Public Function Substring ( _
    startIndex As Integer _
) As IrcString
public:
IrcString^ Substring(
    int startIndex
)
public:
IrcString^ Substring(
    int startIndex
)
member Substring :
        startIndex : int -> IrcString
member Substring :
        startIndex : int -> IrcString

Parameters

startIndex
Type: Online System Int32
The index of the first byte in the substring.

Return Value

The substring.
See Also
IrcString Class
IrcString Members
Substring Overload


Substring Method (Int32, Int32)

IrcString Substring Method (Int32, Int32) NetIRC2 IRC Client Library for .NET
Extracts part of a string.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString Substring(
    int startIndex,
    int length
)
public IrcString Substring(
    int startIndex,
    int length
)
Public Function Substring ( _
    startIndex As Integer, _
    length As Integer _
) As IrcString
Public Function Substring ( _
    startIndex As Integer, _
    length As Integer _
) As IrcString
public:
IrcString^ Substring(
    int startIndex,
    int length
)
public:
IrcString^ Substring(
    int startIndex,
    int length
)
member Substring :
        startIndex : int *
        length : int -> IrcString
member Substring :
        startIndex : int *
        length : int -> IrcString

Parameters

startIndex
Type: Online System Int32
The index of the first byte in the substring.
length
Type: Online System Int32
The number of bytes to extract.

Return Value

The substring.
See Also
IrcString Class
IrcString Members
Substring Overload


ToByteArray Method

IrcString ToByteArray Method NetIRC2 IRC Client Library for .NET
Gets the bytes that make up the IRC string.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] ToByteArray()
public byte[] ToByteArray()
Public Function ToByteArray As Byte()
Public Function ToByteArray As Byte()
public:
array<unsigned char>^ ToByteArray()
public:
array<unsigned char>^ ToByteArray()
member ToByteArray : unit -> byte[]
member ToByteArray : unit -> byte[]

Return Value

An array of bytes.
See Also
IrcString Class
IrcString Members


ToString Method

IrcString ToString Method NetIRC2 IRC Client Library for .NET
Overload List
 | Name | Description
Public method | ToString | Converts to a .NET string using UTF-8 encoding. (Overrides Online Object ToString .)
Public method | ToString(Encoding) | Converts to a .NET string using the specified encoding.
Back to Top
See Also
IrcString Class
IrcString Members


ToString Method

IrcString ToString Method NetIRC2 IRC Client Library for .NET
Converts to a .NET string using UTF-8 encoding.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override string ToString()
public override string ToString()
Public Overrides Function ToString As String
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

The converted string.
See Also
IrcString Class
IrcString Members
ToString Overload


ToString Method (Encoding)

IrcString ToString Method (Encoding) NetIRC2 IRC Client Library for .NET
Converts to a .NET string using the specified encoding.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ToString(
    Encoding encoding
)
public string ToString(
    Encoding encoding
)
Public Function ToString ( _
    encoding As Encoding _
) As String
Public Function ToString ( _
    encoding As Encoding _
) As String
public:
String^ ToString(
    Encoding^ encoding
)
public:
String^ ToString(
    Encoding^ encoding
)
member ToString :
        encoding : Encoding -> string
member ToString :
        encoding : Encoding -> string

Parameters

encoding
Type: Online System.Text Encoding
The encoding to use in the conversion.

Return Value

The converted string.
See Also
IrcString Class
IrcString Members
ToString Overload


IrcString Operators and Type Conversions

IrcString Operators and Type Conversions NetIRC2 IRC Client Library for .NET
The IrcString type exposes the following members.
Operators
Name | Description
Addition | Concatenates two strings.
Equality | Compares two strings for equality.
( Byte to IrcString) | Casts a byte array to an IRC string.
(String to IrcString) | Casts a .NET string to an IRC string using UTF-8 encoding.
(IrcString to String) | Casts the IRC string to a .NET string using UTF-8 encoding.
(IrcString to Byte ) | Casts the IRC string to a byte array.
Inequality | Compares two strings for inequality.
Back to Top
See Also
IrcString Class


Addition Operator

IrcString Addition Operator NetIRC2 IRC Client Library for .NET
Concatenates two strings.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static IrcString operator +(
    IrcString string1,
    IrcString string2
)
public static IrcString operator +(
    IrcString string1,
    IrcString string2
)
Public Shared Operator + ( _
    string1 As IrcString, _
    string2 As IrcString _
) As IrcString
Public Shared Operator + ( _
    string1 As IrcString, _
    string2 As IrcString _
) As IrcString
public:
static IrcString^ operator +(
    IrcString^ string1,
    IrcString^ string2
)
public:
static IrcString^ operator +(
    IrcString^ string1,
    IrcString^ string2
)
static let inline (+)
        string1 : IrcString *
        string2 : IrcString  : IrcString
static let inline (+)
        string1 : IrcString *
        string2 : IrcString  : IrcString

Parameters

string1
Type: NetIrc2 IrcString
The first string.
string2
Type: NetIrc2 IrcString
The second string.

Return Value

A string that is the concatentaion of the two.
See Also
IrcString Class
IrcString Members


Equality Operator

IrcString Equality Operator NetIRC2 IRC Client Library for .NET
Compares two strings for equality.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator ==(
    IrcString string1,
    IrcString string2
)
public static bool operator ==(
    IrcString string1,
    IrcString string2
)
Public Shared Operator = ( _
    string1 As IrcString, _
    string2 As IrcString _
) As Boolean
Public Shared Operator = ( _
    string1 As IrcString, _
    string2 As IrcString _
) As Boolean
public:
static bool operator ==(
    IrcString^ string1,
    IrcString^ string2
)
public:
static bool operator ==(
    IrcString^ string1,
    IrcString^ string2
)
static let inline (=)
        string1 : IrcString *
        string2 : IrcString  : bool
static let inline (=)
        string1 : IrcString *
        string2 : IrcString  : bool

Parameters

string1
Type: NetIrc2 IrcString
The first string.
string2
Type: NetIrc2 IrcString
The second string.

Return Value

true if the strings are equal.
See Also
IrcString Class
IrcString Members


Implicit Conversion Operators

IrcString Conversion Operators NetIRC2 IRC Client Library for .NET
Overload List
Name | Description
( Byte to IrcString) | Casts a byte array to an IRC string.
(String to IrcString) | Casts a .NET string to an IRC string using UTF-8 encoding.
(IrcString to String) | Casts the IRC string to a .NET string using UTF-8 encoding.
(IrcString to Byte ) | Casts the IRC string to a byte array.
Back to Top
See Also
IrcString Class
IrcString Members


Implicit Conversion (Byte[] to IrcString)

IrcString Conversion ( Byte to IrcString) NetIRC2 IRC Client Library for .NET
Casts a byte array to an IRC string.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static implicit operator IrcString (
    byte[] buffer
)
public static implicit operator IrcString (
    byte[] buffer
)
Public Shared Widening Operator CType ( _
    buffer As Byte() _
) As IrcString
Public Shared Widening Operator CType ( _
    buffer As Byte() _
) As IrcString
static implicit operator IrcString^ (
    array<unsigned char>^ buffer
)
static implicit operator IrcString^ (
    array<unsigned char>^ buffer
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

buffer
Type: Online System Byte
The array of bytes.

Return Value

An IRC string.
See Also
IrcString Class
IrcString Members
Overload


Implicit Conversion (String to IrcString)

IrcString Conversion (String to IrcString) NetIRC2 IRC Client Library for .NET
Casts a .NET string to an IRC string using UTF-8 encoding.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static implicit operator IrcString (
    string string
)
public static implicit operator IrcString (
    string string
)
Public Shared Widening Operator CType ( _
    string As String _
) As IrcString
Public Shared Widening Operator CType ( _
    string As String _
) As IrcString
static implicit operator IrcString^ (
    String^ string
)
static implicit operator IrcString^ (
    String^ string
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

string
Type: Online System String
The .NET string.

Return Value

An IRC string.
See Also
IrcString Class
IrcString Members
Overload


Implicit Conversion (IrcString to String)

IrcString Conversion (IrcString to String) NetIRC2 IRC Client Library for .NET
Casts the IRC string to a .NET string using UTF-8 encoding.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static implicit operator string (
    IrcString string
)
public static implicit operator string (
    IrcString string
)
Public Shared Widening Operator CType ( _
    string As IrcString _
) As String
Public Shared Widening Operator CType ( _
    string As IrcString _
) As String
static implicit operator String^ (
    IrcString^ string
)
static implicit operator String^ (
    IrcString^ string
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

string
Type: NetIrc2 IrcString
The IRC string.

Return Value

A .NET string.
See Also
IrcString Class
IrcString Members
Overload


Implicit Conversion (IrcString to Byte[])

IrcString Conversion (IrcString to Byte ) NetIRC2 IRC Client Library for .NET
Casts the IRC string to a byte array.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static implicit operator byte[] (
    IrcString string
)
public static implicit operator byte[] (
    IrcString string
)
Public Shared Widening Operator CType ( _
    string As IrcString _
) As Byte()
Public Shared Widening Operator CType ( _
    string As IrcString _
) As Byte()
static implicit operator array<unsigned char>^ (
    IrcString^ string
)
static implicit operator array<unsigned char>^ (
    IrcString^ string
)
F# does not support the declaration of new casting operators.
F# does not support the declaration of new casting operators.

Parameters

string
Type: NetIrc2 IrcString
The IRC string.

Return Value

An array of bytes
See Also
IrcString Class
IrcString Members
Overload


Inequality Operator

IrcString Inequality Operator NetIRC2 IRC Client Library for .NET
Compares two strings for inequality.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool operator !=(
    IrcString string1,
    IrcString string2
)
public static bool operator !=(
    IrcString string1,
    IrcString string2
)
Public Shared Operator <> ( _
    string1 As IrcString, _
    string2 As IrcString _
) As Boolean
Public Shared Operator <> ( _
    string1 As IrcString, _
    string2 As IrcString _
) As Boolean
public:
static bool operator !=(
    IrcString^ string1,
    IrcString^ string2
)
public:
static bool operator !=(
    IrcString^ string1,
    IrcString^ string2
)
static let inline (<>)
        string1 : IrcString *
        string2 : IrcString  : bool
static let inline (<>)
        string1 : IrcString *
        string2 : IrcString  : bool

Parameters

string1
Type: NetIrc2 IrcString
The first string.
string2
Type: NetIrc2 IrcString
The second string.

Return Value

true if the strings are not equal.
See Also
IrcString Class
IrcString Members


IrcString Properties

IrcString Properties NetIRC2 IRC Client Library for .NET
The IrcString type exposes the following members.
Properties
 | Name | Description
Public property | Item | Gets a byte from the IRC string.
Public property | Length | The length of the IRC string, in bytes.
Back to Top
See Also
IrcString Class


Item Property

IrcString Item Property NetIRC2 IRC Client Library for .NET
Gets a byte from the IRC string.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte this[
    int index
] { get; set; }
public byte this[
    int index
] { get; set; }
Public Default Property Item ( _
    index As Integer _
) As Byte
    Get
    Set
Public Default Property Item ( _
    index As Integer _
) As Byte
    Get
    Set
public:
virtual property unsigned char default[int index] {
    unsigned char get (int index) sealed;
    void set (int index, unsigned char value) sealed;
}
public:
virtual property unsigned char default[int index] {
    unsigned char get (int index) sealed;
    void set (int index, unsigned char value) sealed;
}
abstract Item : byte with get, set
override Item : byte with get, set
abstract Item : byte with get, set
override Item : byte with get, set

Parameters

index
Type: Online System Int32
The index into the byte array.

Return Value

The byte at the specified index.

Implements

Online IList T Item Int32
See Also
IrcString Class
IrcString Members


Length Property

IrcString Length Property NetIRC2 IRC Client Library for .NET
The length of the IRC string, in bytes.

Namespace: NetIrc2
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Length { get; }
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get
Public ReadOnly Property Length As Integer
    Get
public:
property int Length {
    int get ();
}
public:
property int Length {
    int get ();
}
member Length : int with get
member Length : int with get
See Also
IrcString Class
IrcString Members


NetIrc2.Details Namespace

NetIrc2.Details Namespace NetIRC2 IRC Client Library for .NET
These classes support NetIRC2 but are not necessarily interesting when using the library.
Classes
 | Class | Description
Public class | IrcStringTypeConverter | Converts between IrcString and Online String. This class is used by Visual Studio's various Designers.


IrcStringTypeConverter Class

IrcStringTypeConverter Class NetIRC2 IRC Client Library for .NET
Converts between IrcString and Online String. This class is used by Visual Studio's various Designers.
Inheritance Hierarchy
Online System Object
Online System.ComponentModel TypeConverter
NetIrc2.Details IrcStringTypeConverter

Namespace: NetIrc2.Details
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class IrcStringTypeConverter : TypeConverter
public class IrcStringTypeConverter : TypeConverter
Public Class IrcStringTypeConverter _
    Inherits TypeConverter
Public Class IrcStringTypeConverter _
    Inherits TypeConverter
public ref class IrcStringTypeConverter : public TypeConverter
public ref class IrcStringTypeConverter : public TypeConverter
type IrcStringTypeConverter =
    class
        inherit TypeConverter
    end
type IrcStringTypeConverter =
    class
        inherit TypeConverter
    end
See Also
IrcStringTypeConverter Members
NetIrc2.Details Namespace


IrcStringTypeConverter Members

IrcStringTypeConverter Members NetIRC2 IRC Client Library for .NET

The IrcStringTypeConverter type exposes the following members.
Constructors
 | Name | Description
Public method | IrcStringTypeConverter | Initializes a new instance of the IrcStringTypeConverter class
Back to Top
Methods
 | Name | Description
Public method | CanConvertFrom | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides Online TypeConverter CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides Online TypeConverter CanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides Online TypeConverter ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertTo | Converts the given value object to the specified type, using the specified context and culture information. (Overrides Online TypeConverter ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Back to Top
See Also
IrcStringTypeConverter Class
NetIrc2.Details Namespace


IrcStringTypeConverter Constructor

IrcStringTypeConverter Constructor NetIRC2 IRC Client Library for .NET
Initializes a new instance of the IrcStringTypeConverter class

Namespace: NetIrc2.Details
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcStringTypeConverter()
public IrcStringTypeConverter()
Public Sub New
Public Sub New
public:
IrcStringTypeConverter()
public:
IrcStringTypeConverter()
new : unit -> IrcStringTypeConverter
new : unit -> IrcStringTypeConverter
See Also
IrcStringTypeConverter Class
IrcStringTypeConverter Members
NetIrc2.Details Namespace


IrcStringTypeConverter Methods

IrcStringTypeConverter Methods NetIRC2 IRC Client Library for .NET
The IrcStringTypeConverter type exposes the following members.
Methods
 | Name | Description
Public method | CanConvertFrom | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides Online TypeConverter CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides Online TypeConverter CanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides Online TypeConverter ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertTo | Converts the given value object to the specified type, using the specified context and culture information. (Overrides Online TypeConverter ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Back to Top
See Also
IrcStringTypeConverter Class
NetIrc2.Details Namespace


CanConvertFrom Method

IrcStringTypeConverter CanConvertFrom Method NetIRC2 IRC Client Library for .NET
Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Namespace: NetIrc2.Details
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override
abstract CanConvertFrom :
        context : ITypeDescriptorContext *
        sourceType : Type -> bool
override CanConvertFrom :
        context : ITypeDescriptorContext *
        sourceType : Type -> bool
abstract CanConvertFrom :
        context : ITypeDescriptorContext *
        sourceType : Type -> bool
override CanConvertFrom :
        context : ITypeDescriptorContext *
        sourceType : Type -> bool

Parameters

context
Type: Online System.ComponentModel ITypeDescriptorContext
An Online ITypeDescriptorContext that provides a format context.
sourceType
Type: Online System Type
A Online Type that represents the type you want to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.
See Also
IrcStringTypeConverter Class
IrcStringTypeConverter Members
NetIrc2.Details Namespace


CanConvertTo Method

IrcStringTypeConverter CanConvertTo Method NetIRC2 IRC Client Library for .NET
Returns whether this converter can convert the object to the specified type, using the specified context.

Namespace: NetIrc2.Details
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo ( _
    context As ITypeDescriptorContext, _
    destinationType As Type _
) As Boolean
Public Overrides Function CanConvertTo ( _
    context As ITypeDescriptorContext, _
    destinationType As Type _
) As Boolean
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override
abstract CanConvertTo :
        context : ITypeDescriptorContext *
        destinationType : Type -> bool
override CanConvertTo :
        context : ITypeDescriptorContext *
        destinationType : Type -> bool
abstract CanConvertTo :
        context : ITypeDescriptorContext *
        destinationType : Type -> bool
override CanConvertTo :
        context : ITypeDescriptorContext *
        destinationType : Type -> bool

Parameters

context
Type: Online System.ComponentModel ITypeDescriptorContext
An Online ITypeDescriptorContext that provides a format context.
destinationType
Type: Online System Type
A Online Type that represents the type you want to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.
See Also
IrcStringTypeConverter Class
IrcStringTypeConverter Members
NetIrc2.Details Namespace


ConvertFrom Method

IrcStringTypeConverter ConvertFrom Method NetIRC2 IRC Client Library for .NET
Converts the given object to the type of this converter, using the specified context and culture information.

Namespace: NetIrc2.Details
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override
abstract ConvertFrom :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object -> Object
override ConvertFrom :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object -> Object
abstract ConvertFrom :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object -> Object
override ConvertFrom :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object -> Object

Parameters

context
Type: Online System.ComponentModel ITypeDescriptorContext
An Online ITypeDescriptorContext that provides a format context.
culture
Type: Online System.Globalization CultureInfo
The Online CultureInfo to use as the current culture.
value
Type: Online System Object
The Online Object to convert.

Return Value

An Online Object that represents the converted value.
Exceptions
Exception | Condition
Online System NotSupportedException | The conversion cannot be performed.
See Also
IrcStringTypeConverter Class
IrcStringTypeConverter Members
NetIrc2.Details Namespace


ConvertTo Method

IrcStringTypeConverter ConvertTo Method NetIRC2 IRC Client Library for .NET
Converts the given value object to the specified type, using the specified context and culture information.

Namespace: NetIrc2.Details
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override
abstract ConvertTo :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object *
        destinationType : Type -> Object
override ConvertTo :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object *
        destinationType : Type -> Object
abstract ConvertTo :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object *
        destinationType : Type -> Object
override ConvertTo :
        context : ITypeDescriptorContext *
        culture : CultureInfo *
        value : Object *
        destinationType : Type -> Object

Parameters

context
Type: Online System.ComponentModel ITypeDescriptorContext
An Online ITypeDescriptorContext that provides a format context.
culture
Type: Online System.Globalization CultureInfo
A Online CultureInfo. If null is passed, the current culture is assumed.
value
Type: Online System Object
The Online Object to convert.
destinationType
Type: Online System Type
The Online Type to convert the value parameter to.

Return Value

An Online Object that represents the converted value.
Exceptions
Exception | Condition
Online System ArgumentNullException | The destinationType parameter is null.
Online System NotSupportedException | The conversion cannot be performed.
See Also
IrcStringTypeConverter Class
IrcStringTypeConverter Members
NetIrc2.Details Namespace


NetIrc2.Events Namespace

NetIrc2.Events Namespace NetIRC2 IRC Client Library for .NET
NetIRC2 raises a number of events. These classes store the event information.
Classes
 | Class | Description
Public class | ChannelListEntryEventArgs | Stores an entry of the channel list.
Public class | ChannelTopicChangeEventArgs | Stores a change in a channel's topic.
Public class | ChatMessageEventArgs | Stores a complete chat message.
Public class | InvitationEventArgs | Stores information about a channel invitation.
Public class | IrcErrorEventArgs | Stores an error.
Public class | JoinLeaveEventArgs | Stores information about a user joining or leaving a channel.
Public class | KickEventArgs | Stores information about a user being kicked from a channel.
Public class | ModeEventArgs | Stores a mode change.
Public class | NameChangeEventArgs | Stores information about a name change.
Public class | NameListEndEventArgs | Marks the end of a channel's name list.
Public class | NameListReplyEventArgs | Stores a list of names of users in a channel.
Public class | PingReplyEventArgs | Stores the results of an earlier ping request.
Public class | QuitEventArgs | Stores information about a user disconnecting from an IRC server.
Public class | SimpleMessageEventArgs | Stores a one-line message.
Public class | TargetedMessageEventArgs | Stores a sender and recipient for a targeted action.


ChannelListEntryEventArgs Class

ChannelListEntryEventArgs Class NetIRC2 IRC Client Library for .NET
Stores an entry of the channel list.
Inheritance Hierarchy
Online System Object
Online System EventArgs
NetIrc2.Events ChannelListEntryEventArgs

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ChannelListEntryEventArgs : EventArgs
public class ChannelListEntryEventArgs : EventArgs
Public Class ChannelListEntryEventArgs _
    Inherits EventArgs
Public Class ChannelListEntryEventArgs _
    Inherits EventArgs
public ref class ChannelListEntryEventArgs : public EventArgs
public ref class ChannelListEntryEventArgs : public EventArgs
type ChannelListEntryEventArgs =
    class
        inherit EventArgs
    end
type ChannelListEntryEventArgs =
    class
        inherit EventArgs
    end
See Also
ChannelListEntryEventArgs Members
NetIrc2.Events Namespace


ChannelListEntryEventArgs Members

ChannelListEntryEventArgs Members NetIRC2 IRC Client Library for .NET

The ChannelListEntryEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | ChannelListEntryEventArgs | Creates a new instance of ChannelListEntryEventArgs.
Back to Top
Properties
 | Name | Description
Public property | Channel | The channel name.
Public property | Topic | The channel topic.
Public property | UserCount | The number of users in the channel.
Back to Top
See Also
ChannelListEntryEventArgs Class
NetIrc2.Events Namespace


ChannelListEntryEventArgs Constructor

ChannelListEntryEventArgs Constructor NetIRC2 IRC Client Library for .NET
Creates a new instance of ChannelListEntryEventArgs.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ChannelListEntryEventArgs(
    IrcString channel,
    int userCount,
    IrcString topic
)
public ChannelListEntryEventArgs(
    IrcString channel,
    int userCount,
    IrcString topic
)
Public Sub New ( _
    channel As IrcString, _
    userCount As Integer, _
    topic As IrcString _
)
Public Sub New ( _
    channel As IrcString, _
    userCount As Integer, _
    topic As IrcString _
)
public:
ChannelListEntryEventArgs(
    IrcString^ channel,
    int userCount,
    IrcString^ topic
)
public:
ChannelListEntryEventArgs(
    IrcString^ channel,
    int userCount,
    IrcString^ topic
)
new :
        channel : IrcString *
        userCount : int *
        topic : IrcString -> ChannelListEntryEventArgs
new :
        channel : IrcString *
        userCount : int *
        topic : IrcString -> ChannelListEntryEventArgs

Parameters

channel
Type: NetIrc2 IrcString
The channel name.
userCount
Type: Online System Int32
The number of users in the channel.
topic
Type: NetIrc2 IrcString
The channel topic.
See Also
ChannelListEntryEventArgs Class
ChannelListEntryEventArgs Members
NetIrc2.Events Namespace


ChannelListEntryEventArgs Properties

ChannelListEntryEventArgs Properties NetIRC2 IRC Client Library for .NET
The ChannelListEntryEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Channel | The channel name.
Public property | Topic | The channel topic.
Public property | UserCount | The number of users in the channel.
Back to Top
See Also
ChannelListEntryEventArgs Class
NetIrc2.Events Namespace


Channel Property

ChannelListEntryEventArgs Channel Property NetIRC2 IRC Client Library for .NET
The channel name.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString Channel { get; private set; }
public IrcString Channel { get; private set; }
Public Property Channel As IrcString
    Get
    Private Set
Public Property Channel As IrcString
    Get
    Private Set
public:
property IrcString^ Channel {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
public:
property IrcString^ Channel {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
member Channel : IrcString with get, private set
member Channel : IrcString with get, private set
See Also
ChannelListEntryEventArgs Class
ChannelListEntryEventArgs Members
NetIrc2.Events Namespace


Topic Property

ChannelListEntryEventArgs Topic Property NetIRC2 IRC Client Library for .NET
The channel topic.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString Topic { get; private set; }
public IrcString Topic { get; private set; }
Public Property Topic As IrcString
    Get
    Private Set
Public Property Topic As IrcString
    Get
    Private Set
public:
property IrcString^ Topic {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
public:
property IrcString^ Topic {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
member Topic : IrcString with get, private set
member Topic : IrcString with get, private set
See Also
ChannelListEntryEventArgs Class
ChannelListEntryEventArgs Members
NetIrc2.Events Namespace


UserCount Property

ChannelListEntryEventArgs UserCount Property NetIRC2 IRC Client Library for .NET
The number of users in the channel.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int UserCount { get; private set; }
public int UserCount { get; private set; }
Public Property UserCount As Integer
    Get
    Private Set
Public Property UserCount As Integer
    Get
    Private Set
public:
property int UserCount {
    int get ();
    private: void set (int value);
}
public:
property int UserCount {
    int get ();
    private: void set (int value);
}
member UserCount : int with get, private set
member UserCount : int with get, private set
See Also
ChannelListEntryEventArgs Class
ChannelListEntryEventArgs Members
NetIrc2.Events Namespace


ChannelTopicChangeEventArgs Class

ChannelTopicChangeEventArgs Class NetIRC2 IRC Client Library for .NET
Stores a change in a channel's topic.
Inheritance Hierarchy
Online System Object
Online System EventArgs
NetIrc2.Events ChannelTopicChangeEventArgs

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ChannelTopicChangeEventArgs : EventArgs
public class ChannelTopicChangeEventArgs : EventArgs
Public Class ChannelTopicChangeEventArgs _
    Inherits EventArgs
Public Class ChannelTopicChangeEventArgs _
    Inherits EventArgs
public ref class ChannelTopicChangeEventArgs : public EventArgs
public ref class ChannelTopicChangeEventArgs : public EventArgs
type ChannelTopicChangeEventArgs =
    class
        inherit EventArgs
    end
type ChannelTopicChangeEventArgs =
    class
        inherit EventArgs
    end
See Also
ChannelTopicChangeEventArgs Members
NetIrc2.Events Namespace


ChannelTopicChangeEventArgs Members

ChannelTopicChangeEventArgs Members NetIRC2 IRC Client Library for .NET

The ChannelTopicChangeEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | ChannelTopicChangeEventArgs | Creates a new instance of ChannelTopicChangeEventArgs.
Back to Top
Properties
 | Name | Description
Public property | Channel | The channel name.
Public property | NewTopic | The new channel topic.
Back to Top
See Also
ChannelTopicChangeEventArgs Class
NetIrc2.Events Namespace


ChannelTopicChangeEventArgs Constructor

ChannelTopicChangeEventArgs Constructor NetIRC2 IRC Client Library for .NET
Creates a new instance of ChannelTopicChangeEventArgs.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ChannelTopicChangeEventArgs(
    IrcString channel,
    IrcString newTopic
)
public ChannelTopicChangeEventArgs(
    IrcString channel,
    IrcString newTopic
)
Public Sub New ( _
    channel As IrcString, _
    newTopic As IrcString _
)
Public Sub New ( _
    channel As IrcString, _
    newTopic As IrcString _
)
public:
ChannelTopicChangeEventArgs(
    IrcString^ channel,
    IrcString^ newTopic
)
public:
ChannelTopicChangeEventArgs(
    IrcString^ channel,
    IrcString^ newTopic
)
new :
        channel : IrcString *
        newTopic : IrcString -> ChannelTopicChangeEventArgs
new :
        channel : IrcString *
        newTopic : IrcString -> ChannelTopicChangeEventArgs

Parameters

channel
Type: NetIrc2 IrcString
The channel name.
newTopic
Type: NetIrc2 IrcString
The new channel topic.
See Also
ChannelTopicChangeEventArgs Class
ChannelTopicChangeEventArgs Members
NetIrc2.Events Namespace


ChannelTopicChangeEventArgs Properties

ChannelTopicChangeEventArgs Properties NetIRC2 IRC Client Library for .NET
The ChannelTopicChangeEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Channel | The channel name.
Public property | NewTopic | The new channel topic.
Back to Top
See Also
ChannelTopicChangeEventArgs Class
NetIrc2.Events Namespace


Channel Property

ChannelTopicChangeEventArgs Channel Property NetIRC2 IRC Client Library for .NET
The channel name.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString Channel { get; private set; }
public IrcString Channel { get; private set; }
Public Property Channel As IrcString
    Get
    Private Set
Public Property Channel As IrcString
    Get
    Private Set
public:
property IrcString^ Channel {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
public:
property IrcString^ Channel {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
member Channel : IrcString with get, private set
member Channel : IrcString with get, private set
See Also
ChannelTopicChangeEventArgs Class
ChannelTopicChangeEventArgs Members
NetIrc2.Events Namespace


NewTopic Property

ChannelTopicChangeEventArgs NewTopic Property NetIRC2 IRC Client Library for .NET
The new channel topic.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString NewTopic { get; private set; }
public IrcString NewTopic { get; private set; }
Public Property NewTopic As IrcString
    Get
    Private Set
Public Property NewTopic As IrcString
    Get
    Private Set
public:
property IrcString^ NewTopic {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
public:
property IrcString^ NewTopic {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
member NewTopic : IrcString with get, private set
member NewTopic : IrcString with get, private set
See Also
ChannelTopicChangeEventArgs Class
ChannelTopicChangeEventArgs Members
NetIrc2.Events Namespace


ChatMessageEventArgs Class

ChatMessageEventArgs Class NetIRC2 IRC Client Library for .NET
Stores a complete chat message.
Inheritance Hierarchy
Online System Object
Online System EventArgs
NetIrc2.Events TargetedMessageEventArgs
NetIrc2.Events ChatMessageEventArgs

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ChatMessageEventArgs : TargetedMessageEventArgs
public class ChatMessageEventArgs : TargetedMessageEventArgs
Public Class ChatMessageEventArgs _
    Inherits TargetedMessageEventArgs
Public Class ChatMessageEventArgs _
    Inherits TargetedMessageEventArgs
public ref class ChatMessageEventArgs : public TargetedMessageEventArgs
public ref class ChatMessageEventArgs : public TargetedMessageEventArgs
type ChatMessageEventArgs =
    class
        inherit TargetedMessageEventArgs
    end
type ChatMessageEventArgs =
    class
        inherit TargetedMessageEventArgs
    end
See Also
ChatMessageEventArgs Members
NetIrc2.Events Namespace


ChatMessageEventArgs Members

ChatMessageEventArgs Members NetIRC2 IRC Client Library for .NET

The ChatMessageEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | ChatMessageEventArgs | Creates an instance of ChatMessageEventArgs.
Back to Top
Properties
 | Name | Description
Public property | Message | The chat message.
Public property | Recipient | The recipient. (Inherited from TargetedMessageEventArgs.)
Public property | Sender | The sender. Be aware that some messages may not have a sender, such as NOTICEs from the server at connect time. In this case the sender will be null. (Inherited from TargetedMessageEventArgs.)
Back to Top
See Also
ChatMessageEventArgs Class
NetIrc2.Events Namespace


ChatMessageEventArgs Constructor

ChatMessageEventArgs Constructor NetIRC2 IRC Client Library for .NET
Creates an instance of ChatMessageEventArgs.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ChatMessageEventArgs(
    IrcIdentity sender,
    IrcString recipient,
    IrcString message
)
public ChatMessageEventArgs(
    IrcIdentity sender,
    IrcString recipient,
    IrcString message
)
Public Sub New ( _
    sender As IrcIdentity, _
    recipient As IrcString, _
    message As IrcString _
)
Public Sub New ( _
    sender As IrcIdentity, _
    recipient As IrcString, _
    message As IrcString _
)
public:
ChatMessageEventArgs(
    IrcIdentity^ sender,
    IrcString^ recipient,
    IrcString^ message
)
public:
ChatMessageEventArgs(
    IrcIdentity^ sender,
    IrcString^ recipient,
    IrcString^ message
)
new :
        sender : IrcIdentity *
        recipient : IrcString *
        message : IrcString -> ChatMessageEventArgs
new :
        sender : IrcIdentity *
        recipient : IrcString *
        message : IrcString -> ChatMessageEventArgs

Parameters

sender
Type: NetIrc2 IrcIdentity
The sender, or null if the message has no sender.
recipient
Type: NetIrc2 IrcString
The recipient.
message
Type: NetIrc2 IrcString
The chat message.
See Also
ChatMessageEventArgs Class
ChatMessageEventArgs Members
NetIrc2.Events Namespace


ChatMessageEventArgs Properties

ChatMessageEventArgs Properties NetIRC2 IRC Client Library for .NET
The ChatMessageEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Message | The chat message.
Public property | Recipient | The recipient. (Inherited from TargetedMessageEventArgs.)
Public property | Sender | The sender. Be aware that some messages may not have a sender, such as NOTICEs from the server at connect time. In this case the sender will be null. (Inherited from TargetedMessageEventArgs.)
Back to Top
See Also
ChatMessageEventArgs Class
NetIrc2.Events Namespace


Message Property

ChatMessageEventArgs Message Property NetIRC2 IRC Client Library for .NET
The chat message.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString Message { get; private set; }
public IrcString Message { get; private set; }
Public Property Message As IrcString
    Get
    Private Set
Public Property Message As IrcString
    Get
    Private Set
public:
property IrcString^ Message {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
public:
property IrcString^ Message {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
member Message : IrcString with get, private set
member Message : IrcString with get, private set
See Also
ChatMessageEventArgs Class
ChatMessageEventArgs Members
NetIrc2.Events Namespace


InvitationEventArgs Class

InvitationEventArgs Class NetIRC2 IRC Client Library for .NET
Stores information about a channel invitation.
Inheritance Hierarchy
Online System Object
Online System EventArgs
NetIrc2.Events TargetedMessageEventArgs
NetIrc2.Events InvitationEventArgs

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class InvitationEventArgs : TargetedMessageEventArgs
public class InvitationEventArgs : TargetedMessageEventArgs
Public Class InvitationEventArgs _
    Inherits TargetedMessageEventArgs
Public Class InvitationEventArgs _
    Inherits TargetedMessageEventArgs
public ref class InvitationEventArgs : public TargetedMessageEventArgs
public ref class InvitationEventArgs : public TargetedMessageEventArgs
type InvitationEventArgs =
    class
        inherit TargetedMessageEventArgs
    end
type InvitationEventArgs =
    class
        inherit TargetedMessageEventArgs
    end
See Also
InvitationEventArgs Members
NetIrc2.Events Namespace


InvitationEventArgs Members

InvitationEventArgs Members NetIRC2 IRC Client Library for .NET

The InvitationEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | InvitationEventArgs | Creates a new instance of InvitationEventArgs.
Back to Top
Properties
 | Name | Description
Public property | Channel | The channel the invitation is for.
Public property | Recipient | The recipient. (Inherited from TargetedMessageEventArgs.)
Public property | Sender | The sender. Be aware that some messages may not have a sender, such as NOTICEs from the server at connect time. In this case the sender will be null. (Inherited from TargetedMessageEventArgs.)
Back to Top
See Also
InvitationEventArgs Class
NetIrc2.Events Namespace


InvitationEventArgs Constructor

InvitationEventArgs Constructor NetIRC2 IRC Client Library for .NET
Creates a new instance of InvitationEventArgs.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public InvitationEventArgs(
    IrcIdentity sender,
    IrcString recipient,
    IrcString channel
)
public InvitationEventArgs(
    IrcIdentity sender,
    IrcString recipient,
    IrcString channel
)
Public Sub New ( _
    sender As IrcIdentity, _
    recipient As IrcString, _
    channel As IrcString _
)
Public Sub New ( _
    sender As IrcIdentity, _
    recipient As IrcString, _
    channel As IrcString _
)
public:
InvitationEventArgs(
    IrcIdentity^ sender,
    IrcString^ recipient,
    IrcString^ channel
)
public:
InvitationEventArgs(
    IrcIdentity^ sender,
    IrcString^ recipient,
    IrcString^ channel
)
new :
        sender : IrcIdentity *
        recipient : IrcString *
        channel : IrcString -> InvitationEventArgs
new :
        sender : IrcIdentity *
        recipient : IrcString *
        channel : IrcString -> InvitationEventArgs

Parameters

sender
Type: NetIrc2 IrcIdentity
The sender of the invitation.
recipient
Type: NetIrc2 IrcString
The recipient of the invitation.
channel
Type: NetIrc2 IrcString
The channel the invitation is for.
See Also
InvitationEventArgs Class
InvitationEventArgs Members
NetIrc2.Events Namespace


InvitationEventArgs Properties

InvitationEventArgs Properties NetIRC2 IRC Client Library for .NET
The InvitationEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Channel | The channel the invitation is for.
Public property | Recipient | The recipient. (Inherited from TargetedMessageEventArgs.)
Public property | Sender | The sender. Be aware that some messages may not have a sender, such as NOTICEs from the server at connect time. In this case the sender will be null. (Inherited from TargetedMessageEventArgs.)
Back to Top
See Also
InvitationEventArgs Class
NetIrc2.Events Namespace


Channel Property

InvitationEventArgs Channel Property NetIRC2 IRC Client Library for .NET
The channel the invitation is for.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString Channel { get; private set; }
public IrcString Channel { get; private set; }
Public Property Channel As IrcString
    Get
    Private Set
Public Property Channel As IrcString
    Get
    Private Set
public:
property IrcString^ Channel {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
public:
property IrcString^ Channel {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
member Channel : IrcString with get, private set
member Channel : IrcString with get, private set
See Also
InvitationEventArgs Class
InvitationEventArgs Members
NetIrc2.Events Namespace


IrcErrorEventArgs Class

IrcErrorEventArgs Class NetIRC2 IRC Client Library for .NET
Stores an error.
Inheritance Hierarchy
Online System Object
Online System EventArgs
NetIrc2.Events IrcErrorEventArgs

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class IrcErrorEventArgs : EventArgs
public class IrcErrorEventArgs : EventArgs
Public Class IrcErrorEventArgs _
    Inherits EventArgs
Public Class IrcErrorEventArgs _
    Inherits EventArgs
public ref class IrcErrorEventArgs : public EventArgs
public ref class IrcErrorEventArgs : public EventArgs
type IrcErrorEventArgs =
    class
        inherit EventArgs
    end
type IrcErrorEventArgs =
    class
        inherit EventArgs
    end
See Also
IrcErrorEventArgs Members
NetIrc2.Events Namespace


IrcErrorEventArgs Members

IrcErrorEventArgs Members NetIRC2 IRC Client Library for .NET

The IrcErrorEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | IrcErrorEventArgs | Creates a new instance of IrcErrorEventArgs.
Back to Top
Properties
 | Name | Description
Public property | Data | The raw IRC statement data. This can be used to garner more information about the error.
Public property | Error | The type of error that has occured.
Back to Top
See Also
IrcErrorEventArgs Class
NetIrc2.Events Namespace


IrcErrorEventArgs Constructor

IrcErrorEventArgs Constructor NetIRC2 IRC Client Library for .NET
Creates a new instance of IrcErrorEventArgs.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcErrorEventArgs(
    IrcReplyCode error,
    IrcStatement data
)
public IrcErrorEventArgs(
    IrcReplyCode error,
    IrcStatement data
)
Public Sub New ( _
    error As IrcReplyCode, _
    data As IrcStatement _
)
Public Sub New ( _
    error As IrcReplyCode, _
    data As IrcStatement _
)
public:
IrcErrorEventArgs(
    IrcReplyCode error,
    IrcStatement^ data
)
public:
IrcErrorEventArgs(
    IrcReplyCode error,
    IrcStatement^ data
)
new :
        error : IrcReplyCode *
        data : IrcStatement -> IrcErrorEventArgs
new :
        error : IrcReplyCode *
        data : IrcStatement -> IrcErrorEventArgs

Parameters

error
Type: NetIrc2 IrcReplyCode
The type of error that has occured.
data
Type: NetIrc2.Parsing IrcStatement
The raw IRC statement data. This can be used to garner more information about the error.
See Also
IrcErrorEventArgs Class
IrcErrorEventArgs Members
NetIrc2.Events Namespace


IrcErrorEventArgs Properties

IrcErrorEventArgs Properties NetIRC2 IRC Client Library for .NET
The IrcErrorEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Data | The raw IRC statement data. This can be used to garner more information about the error.
Public property | Error | The type of error that has occured.
Back to Top
See Also
IrcErrorEventArgs Class
NetIrc2.Events Namespace


Data Property

IrcErrorEventArgs Data Property NetIRC2 IRC Client Library for .NET
The raw IRC statement data. This can be used to garner more information about the error.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcStatement Data { get; private set; }
public IrcStatement Data { get; private set; }
Public Property Data As IrcStatement
    Get
    Private Set
Public Property Data As IrcStatement
    Get
    Private Set
public:
property IrcStatement^ Data {
    IrcStatement^ get ();
    private: void set (IrcStatement^ value);
}
public:
property IrcStatement^ Data {
    IrcStatement^ get ();
    private: void set (IrcStatement^ value);
}
member Data : IrcStatement with get, private set
member Data : IrcStatement with get, private set
See Also
IrcErrorEventArgs Class
IrcErrorEventArgs Members
NetIrc2.Events Namespace


Error Property

IrcErrorEventArgs Error Property NetIRC2 IRC Client Library for .NET
The type of error that has occured.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcReplyCode Error { get; private set; }
public IrcReplyCode Error { get; private set; }
Public Property Error As IrcReplyCode
    Get
    Private Set
Public Property Error As IrcReplyCode
    Get
    Private Set
public:
property IrcReplyCode Error {
    IrcReplyCode get ();
    private: void set (IrcReplyCode value);
}
public:
property IrcReplyCode Error {
    IrcReplyCode get ();
    private: void set (IrcReplyCode value);
}
member Error : IrcReplyCode with get, private set
member Error : IrcReplyCode with get, private set
See Also
IrcErrorEventArgs Class
IrcErrorEventArgs Members
NetIrc2.Events Namespace


JoinLeaveEventArgs Class

JoinLeaveEventArgs Class NetIRC2 IRC Client Library for .NET
Stores information about a user joining or leaving a channel.
Inheritance Hierarchy
Online System Object
Online System EventArgs
NetIrc2.Events JoinLeaveEventArgs

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class JoinLeaveEventArgs : EventArgs
public class JoinLeaveEventArgs : EventArgs
Public Class JoinLeaveEventArgs _
    Inherits EventArgs
Public Class JoinLeaveEventArgs _
    Inherits EventArgs
public ref class JoinLeaveEventArgs : public EventArgs
public ref class JoinLeaveEventArgs : public EventArgs
type JoinLeaveEventArgs =
    class
        inherit EventArgs
    end
type JoinLeaveEventArgs =
    class
        inherit EventArgs
    end
See Also
JoinLeaveEventArgs Members
NetIrc2.Events Namespace


JoinLeaveEventArgs Members

JoinLeaveEventArgs Members NetIRC2 IRC Client Library for .NET

The JoinLeaveEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | JoinLeaveEventArgs | Creates a new instance of JoinLeaveEventArgs.
Back to Top
Methods
 | Name | Description
Public method | GetChannelList | Gets the list of channels joined or left.
Back to Top
Properties
 | Name | Description
Public property | Identity | The user who joined or left the channel(s).
Back to Top
See Also
JoinLeaveEventArgs Class
NetIrc2.Events Namespace


JoinLeaveEventArgs Constructor

JoinLeaveEventArgs Constructor NetIRC2 IRC Client Library for .NET
Creates a new instance of JoinLeaveEventArgs.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public JoinLeaveEventArgs(
    IrcIdentity identity,
    IrcString[] channels
)
public JoinLeaveEventArgs(
    IrcIdentity identity,
    IrcString[] channels
)
Public Sub New ( _
    identity As IrcIdentity, _
    channels As IrcString() _
)
Public Sub New ( _
    identity As IrcIdentity, _
    channels As IrcString() _
)
public:
JoinLeaveEventArgs(
    IrcIdentity^ identity,
    array<IrcString^>^ channels
)
public:
JoinLeaveEventArgs(
    IrcIdentity^ identity,
    array<IrcString^>^ channels
)
new :
        identity : IrcIdentity *
        channels : IrcString[] -> JoinLeaveEventArgs
new :
        identity : IrcIdentity *
        channels : IrcString[] -> JoinLeaveEventArgs

Parameters

identity
Type: NetIrc2 IrcIdentity
The user who joined or left the channel(s).
channels
Type: NetIrc2 IrcString
The list of channels joined or left.
See Also
JoinLeaveEventArgs Class
JoinLeaveEventArgs Members
NetIrc2.Events Namespace


JoinLeaveEventArgs Methods

JoinLeaveEventArgs Methods NetIRC2 IRC Client Library for .NET
The JoinLeaveEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | GetChannelList | Gets the list of channels joined or left.
Back to Top
See Also
JoinLeaveEventArgs Class
NetIrc2.Events Namespace


GetChannelList Method

JoinLeaveEventArgs GetChannelList Method NetIRC2 IRC Client Library for .NET
Gets the list of channels joined or left.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString[] GetChannelList()
public IrcString[] GetChannelList()
Public Function GetChannelList As IrcString()
Public Function GetChannelList As IrcString()
public:
array<IrcString^>^ GetChannelList()
public:
array<IrcString^>^ GetChannelList()
member GetChannelList : unit -> IrcString[]
member GetChannelList : unit -> IrcString[]

Return Value

An array of channel names.
See Also
JoinLeaveEventArgs Class
JoinLeaveEventArgs Members
NetIrc2.Events Namespace


JoinLeaveEventArgs Properties

JoinLeaveEventArgs Properties NetIRC2 IRC Client Library for .NET
The JoinLeaveEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Identity | The user who joined or left the channel(s).
Back to Top
See Also
JoinLeaveEventArgs Class
NetIrc2.Events Namespace


Identity Property

JoinLeaveEventArgs Identity Property NetIRC2 IRC Client Library for .NET
The user who joined or left the channel(s).

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcIdentity Identity { get; private set; }
public IrcIdentity Identity { get; private set; }
Public Property Identity As IrcIdentity
    Get
    Private Set
Public Property Identity As IrcIdentity
    Get
    Private Set
public:
property IrcIdentity^ Identity {
    IrcIdentity^ get ();
    private: void set (IrcIdentity^ value);
}
public:
property IrcIdentity^ Identity {
    IrcIdentity^ get ();
    private: void set (IrcIdentity^ value);
}
member Identity : IrcIdentity with get, private set
member Identity : IrcIdentity with get, private set
See Also
JoinLeaveEventArgs Class
JoinLeaveEventArgs Members
NetIrc2.Events Namespace


KickEventArgs Class

KickEventArgs Class NetIRC2 IRC Client Library for .NET
Stores information about a user being kicked from a channel.
Inheritance Hierarchy
Online System Object
Online System EventArgs
NetIrc2.Events TargetedMessageEventArgs
NetIrc2.Events KickEventArgs

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class KickEventArgs : TargetedMessageEventArgs
public class KickEventArgs : TargetedMessageEventArgs
Public Class KickEventArgs _
    Inherits TargetedMessageEventArgs
Public Class KickEventArgs _
    Inherits TargetedMessageEventArgs
public ref class KickEventArgs : public TargetedMessageEventArgs
public ref class KickEventArgs : public TargetedMessageEventArgs
type KickEventArgs =
    class
        inherit TargetedMessageEventArgs
    end
type KickEventArgs =
    class
        inherit TargetedMessageEventArgs
    end
See Also
KickEventArgs Members
NetIrc2.Events Namespace


KickEventArgs Members

KickEventArgs Members NetIRC2 IRC Client Library for .NET

The KickEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | KickEventArgs | Creates a new instance of KickEventArgs.
Back to Top
Properties
 | Name | Description
Public property | Channel | The channel the user is being kicked from.
Public property | Reason | The reason the user is being kicked, or null if none is given.
Public property | Recipient | The recipient. (Inherited from TargetedMessageEventArgs.)
Public property | Sender | The sender. Be aware that some messages may not have a sender, such as NOTICEs from the server at connect time. In this case the sender will be null. (Inherited from TargetedMessageEventArgs.)
Back to Top
See Also
KickEventArgs Class
NetIrc2.Events Namespace


KickEventArgs Constructor

KickEventArgs Constructor NetIRC2 IRC Client Library for .NET
Creates a new instance of KickEventArgs.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public KickEventArgs(
    IrcIdentity sender,
    IrcString recipient,
    IrcString channel,
    IrcString reason
)
public KickEventArgs(
    IrcIdentity sender,
    IrcString recipient,
    IrcString channel,
    IrcString reason
)
Public Sub New ( _
    sender As IrcIdentity, _
    recipient As IrcString, _
    channel As IrcString, _
    reason As IrcString _
)
Public Sub New ( _
    sender As IrcIdentity, _
    recipient As IrcString, _
    channel As IrcString, _
    reason As IrcString _
)
public:
KickEventArgs(
    IrcIdentity^ sender,
    IrcString^ recipient,
    IrcString^ channel,
    IrcString^ reason
)
public:
KickEventArgs(
    IrcIdentity^ sender,
    IrcString^ recipient,
    IrcString^ channel,
    IrcString^ reason
)
new :
        sender : IrcIdentity *
        recipient : IrcString *
        channel : IrcString *
        reason : IrcString -> KickEventArgs
new :
        sender : IrcIdentity *
        recipient : IrcString *
        channel : IrcString *
        reason : IrcString -> KickEventArgs

Parameters

sender
Type: NetIrc2 IrcIdentity
The user doing the kicking.
recipient
Type: NetIrc2 IrcString
The user being kicked out of the channel.
channel
Type: NetIrc2 IrcString
The channel the user is being kicked from.
reason
Type: NetIrc2 IrcString
The reason the user is being kicked, or null if none is given.
See Also
KickEventArgs Class
KickEventArgs Members
NetIrc2.Events Namespace


KickEventArgs Properties

KickEventArgs Properties NetIRC2 IRC Client Library for .NET
The KickEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Channel | The channel the user is being kicked from.
Public property | Reason | The reason the user is being kicked, or null if none is given.
Public property | Recipient | The recipient. (Inherited from TargetedMessageEventArgs.)
Public property | Sender | The sender. Be aware that some messages may not have a sender, such as NOTICEs from the server at connect time. In this case the sender will be null. (Inherited from TargetedMessageEventArgs.)
Back to Top
See Also
KickEventArgs Class
NetIrc2.Events Namespace


Channel Property

KickEventArgs Channel Property NetIRC2 IRC Client Library for .NET
The channel the user is being kicked from.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString Channel { get; private set; }
public IrcString Channel { get; private set; }
Public Property Channel As IrcString
    Get
    Private Set
Public Property Channel As IrcString
    Get
    Private Set
public:
property IrcString^ Channel {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
public:
property IrcString^ Channel {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
member Channel : IrcString with get, private set
member Channel : IrcString with get, private set
See Also
KickEventArgs Class
KickEventArgs Members
NetIrc2.Events Namespace


Reason Property

KickEventArgs Reason Property NetIRC2 IRC Client Library for .NET
The reason the user is being kicked, or null if none is given.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString Reason { get; private set; }
public IrcString Reason { get; private set; }
Public Property Reason As IrcString
    Get
    Private Set
Public Property Reason As IrcString
    Get
    Private Set
public:
property IrcString^ Reason {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
public:
property IrcString^ Reason {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
member Reason : IrcString with get, private set
member Reason : IrcString with get, private set
See Also
KickEventArgs Class
KickEventArgs Members
NetIrc2.Events Namespace


ModeEventArgs Class

ModeEventArgs Class NetIRC2 IRC Client Library for .NET
Stores a mode change.
Inheritance Hierarchy
Online System Object
Online System EventArgs
NetIrc2.Events TargetedMessageEventArgs
NetIrc2.Events ModeEventArgs

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class ModeEventArgs : TargetedMessageEventArgs
public class ModeEventArgs : TargetedMessageEventArgs
Public Class ModeEventArgs _
    Inherits TargetedMessageEventArgs
Public Class ModeEventArgs _
    Inherits TargetedMessageEventArgs
public ref class ModeEventArgs : public TargetedMessageEventArgs
public ref class ModeEventArgs : public TargetedMessageEventArgs
type ModeEventArgs =
    class
        inherit TargetedMessageEventArgs
    end
type ModeEventArgs =
    class
        inherit TargetedMessageEventArgs
    end
See Also
ModeEventArgs Members
NetIrc2.Events Namespace


ModeEventArgs Members

ModeEventArgs Members NetIRC2 IRC Client Library for .NET

The ModeEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | ModeEventArgs | Creates a new instance of ModeEventArgs.
Back to Top
Methods
 | Name | Description
Public method | GetParameter | Gets a mode change parameter.
Public method | GetParameterList | Gets all of the mode change parameters.
Back to Top
Properties
 | Name | Description
Public property | Command | The mode change, for example +o or +v.
Public property | ParameterCount | The number of parameters.
Public property | Recipient | The recipient. (Inherited from TargetedMessageEventArgs.)
Public property | Sender | The sender. Be aware that some messages may not have a sender, such as NOTICEs from the server at connect time. In this case the sender will be null. (Inherited from TargetedMessageEventArgs.)
Back to Top
See Also
ModeEventArgs Class
NetIrc2.Events Namespace


ModeEventArgs Constructor

ModeEventArgs Constructor NetIRC2 IRC Client Library for .NET
Creates a new instance of ModeEventArgs.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ModeEventArgs(
    IrcIdentity sender,
    IrcString recipient,
    IrcString command,
    IrcString[] parameters
)
public ModeEventArgs(
    IrcIdentity sender,
    IrcString recipient,
    IrcString command,
    IrcString[] parameters
)
Public Sub New ( _
    sender As IrcIdentity, _
    recipient As IrcString, _
    command As IrcString, _
    parameters As IrcString() _
)
Public Sub New ( _
    sender As IrcIdentity, _
    recipient As IrcString, _
    command As IrcString, _
    parameters As IrcString() _
)
public:
ModeEventArgs(
    IrcIdentity^ sender,
    IrcString^ recipient,
    IrcString^ command,
    array<IrcString^>^ parameters
)
public:
ModeEventArgs(
    IrcIdentity^ sender,
    IrcString^ recipient,
    IrcString^ command,
    array<IrcString^>^ parameters
)
new :
        sender : IrcIdentity *
        recipient : IrcString *
        command : IrcString *
        parameters : IrcString[] -> ModeEventArgs
new :
        sender : IrcIdentity *
        recipient : IrcString *
        command : IrcString *
        parameters : IrcString[] -> ModeEventArgs

Parameters

sender
Type: NetIrc2 IrcIdentity
The user changing the mode.
recipient
Type: NetIrc2 IrcString
The target of the mode change. This may be a channel or a user.
command
Type: NetIrc2 IrcString
The mode change, for example +o or +v.
parameters
Type: NetIrc2 IrcString
The mode change parameters.
See Also
ModeEventArgs Class
ModeEventArgs Members
NetIrc2.Events Namespace


ModeEventArgs Methods

ModeEventArgs Methods NetIRC2 IRC Client Library for .NET
The ModeEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | GetParameter | Gets a mode change parameter.
Public method | GetParameterList | Gets all of the mode change parameters.
Back to Top
See Also
ModeEventArgs Class
NetIrc2.Events Namespace


GetParameter Method

ModeEventArgs GetParameter Method NetIRC2 IRC Client Library for .NET
Gets a mode change parameter.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString GetParameter(
    int index
)
public IrcString GetParameter(
    int index
)
Public Function GetParameter ( _
    index As Integer _
) As IrcString
Public Function GetParameter ( _
    index As Integer _
) As IrcString
public:
IrcString^ GetParameter(
    int index
)
public:
IrcString^ GetParameter(
    int index
)
member GetParameter :
        index : int -> IrcString
member GetParameter :
        index : int -> IrcString

Parameters

index
Type: Online System Int32
The index of the parameter.

Return Value

A parameter.
See Also
ModeEventArgs Class
ModeEventArgs Members
NetIrc2.Events Namespace


GetParameterList Method

ModeEventArgs GetParameterList Method NetIRC2 IRC Client Library for .NET
Gets all of the mode change parameters.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString[] GetParameterList()
public IrcString[] GetParameterList()
Public Function GetParameterList As IrcString()
Public Function GetParameterList As IrcString()
public:
array<IrcString^>^ GetParameterList()
public:
array<IrcString^>^ GetParameterList()
member GetParameterList : unit -> IrcString[]
member GetParameterList : unit -> IrcString[]

Return Value

An array of parameters.
See Also
ModeEventArgs Class
ModeEventArgs Members
NetIrc2.Events Namespace


ModeEventArgs Properties

ModeEventArgs Properties NetIRC2 IRC Client Library for .NET
The ModeEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Command | The mode change, for example +o or +v.
Public property | ParameterCount | The number of parameters.
Public property | Recipient | The recipient. (Inherited from TargetedMessageEventArgs.)
Public property | Sender | The sender. Be aware that some messages may not have a sender, such as NOTICEs from the server at connect time. In this case the sender will be null. (Inherited from TargetedMessageEventArgs.)
Back to Top
See Also
ModeEventArgs Class
NetIrc2.Events Namespace


Command Property

ModeEventArgs Command Property NetIRC2 IRC Client Library for .NET
The mode change, for example +o or +v.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString Command { get; private set; }
public IrcString Command { get; private set; }
Public Property Command As IrcString
    Get
    Private Set
Public Property Command As IrcString
    Get
    Private Set
public:
property IrcString^ Command {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
public:
property IrcString^ Command {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
member Command : IrcString with get, private set
member Command : IrcString with get, private set
See Also
ModeEventArgs Class
ModeEventArgs Members
NetIrc2.Events Namespace


ParameterCount Property

ModeEventArgs ParameterCount Property NetIRC2 IRC Client Library for .NET
The number of parameters.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ParameterCount { get; }
public int ParameterCount { get; }
Public ReadOnly Property ParameterCount As Integer
    Get
Public ReadOnly Property ParameterCount As Integer
    Get
public:
property int ParameterCount {
    int get ();
}
public:
property int ParameterCount {
    int get ();
}
member ParameterCount : int with get
member ParameterCount : int with get
See Also
ModeEventArgs Class
ModeEventArgs Members
NetIrc2.Events Namespace


NameChangeEventArgs Class

NameChangeEventArgs Class NetIRC2 IRC Client Library for .NET
Stores information about a name change.
Inheritance Hierarchy
Online System Object
Online System EventArgs
NetIrc2.Events NameChangeEventArgs

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NameChangeEventArgs : EventArgs
public class NameChangeEventArgs : EventArgs
Public Class NameChangeEventArgs _
    Inherits EventArgs
Public Class NameChangeEventArgs _
    Inherits EventArgs
public ref class NameChangeEventArgs : public EventArgs
public ref class NameChangeEventArgs : public EventArgs
type NameChangeEventArgs =
    class
        inherit EventArgs
    end
type NameChangeEventArgs =
    class
        inherit EventArgs
    end
See Also
NameChangeEventArgs Members
NetIrc2.Events Namespace


NameChangeEventArgs Members

NameChangeEventArgs Members NetIRC2 IRC Client Library for .NET

The NameChangeEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | NameChangeEventArgs | Creates a new instance of NameChangeEventArgs.
Back to Top
Properties
 | Name | Description
Public property | Identity | The user who is changing their nickname.
Public property | NewName | The new nickname.
Back to Top
See Also
NameChangeEventArgs Class
NetIrc2.Events Namespace


NameChangeEventArgs Constructor

NameChangeEventArgs Constructor NetIRC2 IRC Client Library for .NET
Creates a new instance of NameChangeEventArgs.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NameChangeEventArgs(
    IrcIdentity identity,
    IrcString newName
)
public NameChangeEventArgs(
    IrcIdentity identity,
    IrcString newName
)
Public Sub New ( _
    identity As IrcIdentity, _
    newName As IrcString _
)
Public Sub New ( _
    identity As IrcIdentity, _
    newName As IrcString _
)
public:
NameChangeEventArgs(
    IrcIdentity^ identity,
    IrcString^ newName
)
public:
NameChangeEventArgs(
    IrcIdentity^ identity,
    IrcString^ newName
)
new :
        identity : IrcIdentity *
        newName : IrcString -> NameChangeEventArgs
new :
        identity : IrcIdentity *
        newName : IrcString -> NameChangeEventArgs

Parameters

identity
Type: NetIrc2 IrcIdentity
The user who is changing their nickname.
newName
Type: NetIrc2 IrcString
The new nickname.
See Also
NameChangeEventArgs Class
NameChangeEventArgs Members
NetIrc2.Events Namespace


NameChangeEventArgs Properties

NameChangeEventArgs Properties NetIRC2 IRC Client Library for .NET
The NameChangeEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Identity | The user who is changing their nickname.
Public property | NewName | The new nickname.
Back to Top
See Also
NameChangeEventArgs Class
NetIrc2.Events Namespace


Identity Property

NameChangeEventArgs Identity Property NetIRC2 IRC Client Library for .NET
The user who is changing their nickname.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcIdentity Identity { get; private set; }
public IrcIdentity Identity { get; private set; }
Public Property Identity As IrcIdentity
    Get
    Private Set
Public Property Identity As IrcIdentity
    Get
    Private Set
public:
property IrcIdentity^ Identity {
    IrcIdentity^ get ();
    private: void set (IrcIdentity^ value);
}
public:
property IrcIdentity^ Identity {
    IrcIdentity^ get ();
    private: void set (IrcIdentity^ value);
}
member Identity : IrcIdentity with get, private set
member Identity : IrcIdentity with get, private set
See Also
NameChangeEventArgs Class
NameChangeEventArgs Members
NetIrc2.Events Namespace


NewName Property

NameChangeEventArgs NewName Property NetIRC2 IRC Client Library for .NET
The new nickname.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString NewName { get; private set; }
public IrcString NewName { get; private set; }
Public Property NewName As IrcString
    Get
    Private Set
Public Property NewName As IrcString
    Get
    Private Set
public:
property IrcString^ NewName {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
public:
property IrcString^ NewName {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
member NewName : IrcString with get, private set
member NewName : IrcString with get, private set
See Also
NameChangeEventArgs Class
NameChangeEventArgs Members
NetIrc2.Events Namespace


NameListEndEventArgs Class

NameListEndEventArgs Class NetIRC2 IRC Client Library for .NET
Marks the end of a channel's name list.
Inheritance Hierarchy
Online System Object
Online System EventArgs
NetIrc2.Events NameListEndEventArgs

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NameListEndEventArgs : EventArgs
public class NameListEndEventArgs : EventArgs
Public Class NameListEndEventArgs _
    Inherits EventArgs
Public Class NameListEndEventArgs _
    Inherits EventArgs
public ref class NameListEndEventArgs : public EventArgs
public ref class NameListEndEventArgs : public EventArgs
type NameListEndEventArgs =
    class
        inherit EventArgs
    end
type NameListEndEventArgs =
    class
        inherit EventArgs
    end
See Also
NameListEndEventArgs Members
NetIrc2.Events Namespace


NameListEndEventArgs Members

NameListEndEventArgs Members NetIRC2 IRC Client Library for .NET

The NameListEndEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | NameListEndEventArgs | Creates a new instance of NameListEndEventArgs.
Back to Top
Properties
 | Name | Description
Public property | Channel | The channel the name list has been sent for.
Back to Top
See Also
NameListEndEventArgs Class
NetIrc2.Events Namespace


NameListEndEventArgs Constructor

NameListEndEventArgs Constructor NetIRC2 IRC Client Library for .NET
Creates a new instance of NameListEndEventArgs.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NameListEndEventArgs(
    IrcString channel
)
public NameListEndEventArgs(
    IrcString channel
)
Public Sub New ( _
    channel As IrcString _
)
Public Sub New ( _
    channel As IrcString _
)
public:
NameListEndEventArgs(
    IrcString^ channel
)
public:
NameListEndEventArgs(
    IrcString^ channel
)
new :
        channel : IrcString -> NameListEndEventArgs
new :
        channel : IrcString -> NameListEndEventArgs

Parameters

channel
Type: NetIrc2 IrcString
The channel the name list has been sent for.
See Also
NameListEndEventArgs Class
NameListEndEventArgs Members
NetIrc2.Events Namespace


NameListEndEventArgs Properties

NameListEndEventArgs Properties NetIRC2 IRC Client Library for .NET
The NameListEndEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Channel | The channel the name list has been sent for.
Back to Top
See Also
NameListEndEventArgs Class
NetIrc2.Events Namespace


Channel Property

NameListEndEventArgs Channel Property NetIRC2 IRC Client Library for .NET
The channel the name list has been sent for.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString Channel { get; private set; }
public IrcString Channel { get; private set; }
Public Property Channel As IrcString
    Get
    Private Set
Public Property Channel As IrcString
    Get
    Private Set
public:
property IrcString^ Channel {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
public:
property IrcString^ Channel {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
member Channel : IrcString with get, private set
member Channel : IrcString with get, private set
See Also
NameListEndEventArgs Class
NameListEndEventArgs Members
NetIrc2.Events Namespace


NameListReplyEventArgs Class

NameListReplyEventArgs Class NetIRC2 IRC Client Library for .NET
Stores a list of names of users in a channel.
Inheritance Hierarchy
Online System Object
Online System EventArgs
NetIrc2.Events NameListReplyEventArgs

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class NameListReplyEventArgs : EventArgs
public class NameListReplyEventArgs : EventArgs
Public Class NameListReplyEventArgs _
    Inherits EventArgs
Public Class NameListReplyEventArgs _
    Inherits EventArgs
public ref class NameListReplyEventArgs : public EventArgs
public ref class NameListReplyEventArgs : public EventArgs
type NameListReplyEventArgs =
    class
        inherit EventArgs
    end
type NameListReplyEventArgs =
    class
        inherit EventArgs
    end
See Also
NameListReplyEventArgs Members
NetIrc2.Events Namespace


NameListReplyEventArgs Members

NameListReplyEventArgs Members NetIRC2 IRC Client Library for .NET

The NameListReplyEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | NameListReplyEventArgs | Creates a new instance of NameListReplyEventArgs.
Back to Top
Methods
 | Name | Description
Public method | GetNameList | Gets the list of names of users in the channel.
Back to Top
Properties
 | Name | Description
Public property | Channel | The channel this list pertains to.
Back to Top
See Also
NameListReplyEventArgs Class
NetIrc2.Events Namespace


NameListReplyEventArgs Constructor

NameListReplyEventArgs Constructor NetIRC2 IRC Client Library for .NET
Creates a new instance of NameListReplyEventArgs.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public NameListReplyEventArgs(
    IrcString channel,
    IrcString[] names
)
public NameListReplyEventArgs(
    IrcString channel,
    IrcString[] names
)
Public Sub New ( _
    channel As IrcString, _
    names As IrcString() _
)
Public Sub New ( _
    channel As IrcString, _
    names As IrcString() _
)
public:
NameListReplyEventArgs(
    IrcString^ channel,
    array<IrcString^>^ names
)
public:
NameListReplyEventArgs(
    IrcString^ channel,
    array<IrcString^>^ names
)
new :
        channel : IrcString *
        names : IrcString[] -> NameListReplyEventArgs
new :
        channel : IrcString *
        names : IrcString[] -> NameListReplyEventArgs

Parameters

channel
Type: NetIrc2 IrcString
The channel this list pertains to.
names
Type: NetIrc2 IrcString
The names of users in the channel.
See Also
NameListReplyEventArgs Class
NameListReplyEventArgs Members
NetIrc2.Events Namespace


NameListReplyEventArgs Methods

NameListReplyEventArgs Methods NetIRC2 IRC Client Library for .NET
The NameListReplyEventArgs type exposes the following members.
Methods
 | Name | Description
Public method | GetNameList | Gets the list of names of users in the channel.
Back to Top
See Also
NameListReplyEventArgs Class
NetIrc2.Events Namespace


GetNameList Method

NameListReplyEventArgs GetNameList Method NetIRC2 IRC Client Library for .NET
Gets the list of names of users in the channel.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString[] GetNameList()
public IrcString[] GetNameList()
Public Function GetNameList As IrcString()
Public Function GetNameList As IrcString()
public:
array<IrcString^>^ GetNameList()
public:
array<IrcString^>^ GetNameList()
member GetNameList : unit -> IrcString[]
member GetNameList : unit -> IrcString[]

Return Value

An array of nicknames.
See Also
NameListReplyEventArgs Class
NameListReplyEventArgs Members
NetIrc2.Events Namespace


NameListReplyEventArgs Properties

NameListReplyEventArgs Properties NetIRC2 IRC Client Library for .NET
The NameListReplyEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Channel | The channel this list pertains to.
Back to Top
See Also
NameListReplyEventArgs Class
NetIrc2.Events Namespace


Channel Property

NameListReplyEventArgs Channel Property NetIRC2 IRC Client Library for .NET
The channel this list pertains to.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString Channel { get; private set; }
public IrcString Channel { get; private set; }
Public Property Channel As IrcString
    Get
    Private Set
Public Property Channel As IrcString
    Get
    Private Set
public:
property IrcString^ Channel {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
public:
property IrcString^ Channel {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
member Channel : IrcString with get, private set
member Channel : IrcString with get, private set
See Also
NameListReplyEventArgs Class
NameListReplyEventArgs Members
NetIrc2.Events Namespace


PingReplyEventArgs Class

PingReplyEventArgs Class NetIRC2 IRC Client Library for .NET
Stores the results of an earlier ping request.
Inheritance Hierarchy
Online System Object
Online System EventArgs
NetIrc2.Events PingReplyEventArgs

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class PingReplyEventArgs : EventArgs
public class PingReplyEventArgs : EventArgs
Public Class PingReplyEventArgs _
    Inherits EventArgs
Public Class PingReplyEventArgs _
    Inherits EventArgs
public ref class PingReplyEventArgs : public EventArgs
public ref class PingReplyEventArgs : public EventArgs
type PingReplyEventArgs =
    class
        inherit EventArgs
    end
type PingReplyEventArgs =
    class
        inherit EventArgs
    end
See Also
PingReplyEventArgs Members
NetIrc2.Events Namespace


PingReplyEventArgs Members

PingReplyEventArgs Members NetIRC2 IRC Client Library for .NET

The PingReplyEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | PingReplyEventArgs | Creates a new instance of PingReplyEventArgs.
Back to Top
Properties
 | Name | Description
Public property | Delay | The ping time, in milliseconds.
Public property | Identity | The sender of the reply.
Back to Top
See Also
PingReplyEventArgs Class
NetIrc2.Events Namespace


PingReplyEventArgs Constructor

PingReplyEventArgs Constructor NetIRC2 IRC Client Library for .NET
Creates a new instance of PingReplyEventArgs.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PingReplyEventArgs(
    IrcIdentity identity,
    int delay
)
public PingReplyEventArgs(
    IrcIdentity identity,
    int delay
)
Public Sub New ( _
    identity As IrcIdentity, _
    delay As Integer _
)
Public Sub New ( _
    identity As IrcIdentity, _
    delay As Integer _
)
public:
PingReplyEventArgs(
    IrcIdentity^ identity,
    int delay
)
public:
PingReplyEventArgs(
    IrcIdentity^ identity,
    int delay
)
new :
        identity : IrcIdentity *
        delay : int -> PingReplyEventArgs
new :
        identity : IrcIdentity *
        delay : int -> PingReplyEventArgs

Parameters

identity
Type: NetIrc2 IrcIdentity
The user who is replying to your ping request.
delay
Type: Online System Int32
The ping time, in milliseconds.
See Also
PingReplyEventArgs Class
PingReplyEventArgs Members
NetIrc2.Events Namespace


PingReplyEventArgs Properties

PingReplyEventArgs Properties NetIRC2 IRC Client Library for .NET
The PingReplyEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Delay | The ping time, in milliseconds.
Public property | Identity | The sender of the reply.
Back to Top
See Also
PingReplyEventArgs Class
NetIrc2.Events Namespace


Delay Property

PingReplyEventArgs Delay Property NetIRC2 IRC Client Library for .NET
The ping time, in milliseconds.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Delay { get; private set; }
public int Delay { get; private set; }
Public Property Delay As Integer
    Get
    Private Set
Public Property Delay As Integer
    Get
    Private Set
public:
property int Delay {
    int get ();
    private: void set (int value);
}
public:
property int Delay {
    int get ();
    private: void set (int value);
}
member Delay : int with get, private set
member Delay : int with get, private set
See Also
PingReplyEventArgs Class
PingReplyEventArgs Members
NetIrc2.Events Namespace


Identity Property

PingReplyEventArgs Identity Property NetIRC2 IRC Client Library for .NET
The sender of the reply.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcIdentity Identity { get; private set; }
public IrcIdentity Identity { get; private set; }
Public Property Identity As IrcIdentity
    Get
    Private Set
Public Property Identity As IrcIdentity
    Get
    Private Set
public:
property IrcIdentity^ Identity {
    IrcIdentity^ get ();
    private: void set (IrcIdentity^ value);
}
public:
property IrcIdentity^ Identity {
    IrcIdentity^ get ();
    private: void set (IrcIdentity^ value);
}
member Identity : IrcIdentity with get, private set
member Identity : IrcIdentity with get, private set
See Also
PingReplyEventArgs Class
PingReplyEventArgs Members
NetIrc2.Events Namespace


QuitEventArgs Class

QuitEventArgs Class NetIRC2 IRC Client Library for .NET
Stores information about a user disconnecting from an IRC server.
Inheritance Hierarchy
Online System Object
Online System EventArgs
NetIrc2.Events QuitEventArgs

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class QuitEventArgs : EventArgs
public class QuitEventArgs : EventArgs
Public Class QuitEventArgs _
    Inherits EventArgs
Public Class QuitEventArgs _
    Inherits EventArgs
public ref class QuitEventArgs : public EventArgs
public ref class QuitEventArgs : public EventArgs
type QuitEventArgs =
    class
        inherit EventArgs
    end
type QuitEventArgs =
    class
        inherit EventArgs
    end
See Also
QuitEventArgs Members
NetIrc2.Events Namespace


QuitEventArgs Members

QuitEventArgs Members NetIRC2 IRC Client Library for .NET

The QuitEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | QuitEventArgs | Creates a new instance of QuitEventArgs.
Back to Top
Properties
 | Name | Description
Public property | Identity | The user who disconnected.
Public property | QuitMessage | The quit message, or null if none was given.
Back to Top
See Also
QuitEventArgs Class
NetIrc2.Events Namespace


QuitEventArgs Constructor

QuitEventArgs Constructor NetIRC2 IRC Client Library for .NET
Creates a new instance of QuitEventArgs.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QuitEventArgs(
    IrcIdentity identity,
    IrcString quitMessage
)
public QuitEventArgs(
    IrcIdentity identity,
    IrcString quitMessage
)
Public Sub New ( _
    identity As IrcIdentity, _
    quitMessage As IrcString _
)
Public Sub New ( _
    identity As IrcIdentity, _
    quitMessage As IrcString _
)
public:
QuitEventArgs(
    IrcIdentity^ identity,
    IrcString^ quitMessage
)
public:
QuitEventArgs(
    IrcIdentity^ identity,
    IrcString^ quitMessage
)
new :
        identity : IrcIdentity *
        quitMessage : IrcString -> QuitEventArgs
new :
        identity : IrcIdentity *
        quitMessage : IrcString -> QuitEventArgs

Parameters

identity
Type: NetIrc2 IrcIdentity
The user who disconnected.
quitMessage
Type: NetIrc2 IrcString
The quit message, or null if none was given.
See Also
QuitEventArgs Class
QuitEventArgs Members
NetIrc2.Events Namespace


QuitEventArgs Properties

QuitEventArgs Properties NetIRC2 IRC Client Library for .NET
The QuitEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Identity | The user who disconnected.
Public property | QuitMessage | The quit message, or null if none was given.
Back to Top
See Also
QuitEventArgs Class
NetIrc2.Events Namespace


Identity Property

QuitEventArgs Identity Property NetIRC2 IRC Client Library for .NET
The user who disconnected.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcIdentity Identity { get; private set; }
public IrcIdentity Identity { get; private set; }
Public Property Identity As IrcIdentity
    Get
    Private Set
Public Property Identity As IrcIdentity
    Get
    Private Set
public:
property IrcIdentity^ Identity {
    IrcIdentity^ get ();
    private: void set (IrcIdentity^ value);
}
public:
property IrcIdentity^ Identity {
    IrcIdentity^ get ();
    private: void set (IrcIdentity^ value);
}
member Identity : IrcIdentity with get, private set
member Identity : IrcIdentity with get, private set
See Also
QuitEventArgs Class
QuitEventArgs Members
NetIrc2.Events Namespace


QuitMessage Property

QuitEventArgs QuitMessage Property NetIRC2 IRC Client Library for .NET
The quit message, or null if none was given.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString QuitMessage { get; private set; }
public IrcString QuitMessage { get; private set; }
Public Property QuitMessage As IrcString
    Get
    Private Set
Public Property QuitMessage As IrcString
    Get
    Private Set
public:
property IrcString^ QuitMessage {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
public:
property IrcString^ QuitMessage {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
member QuitMessage : IrcString with get, private set
member QuitMessage : IrcString with get, private set
See Also
QuitEventArgs Class
QuitEventArgs Members
NetIrc2.Events Namespace


SimpleMessageEventArgs Class

SimpleMessageEventArgs Class NetIRC2 IRC Client Library for .NET
Stores a one-line message.
Inheritance Hierarchy
Online System Object
Online System EventArgs
NetIrc2.Events SimpleMessageEventArgs

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class SimpleMessageEventArgs : EventArgs
public class SimpleMessageEventArgs : EventArgs
Public Class SimpleMessageEventArgs _
    Inherits EventArgs
Public Class SimpleMessageEventArgs _
    Inherits EventArgs
public ref class SimpleMessageEventArgs : public EventArgs
public ref class SimpleMessageEventArgs : public EventArgs
type SimpleMessageEventArgs =
    class
        inherit EventArgs
    end
type SimpleMessageEventArgs =
    class
        inherit EventArgs
    end
See Also
SimpleMessageEventArgs Members
NetIrc2.Events Namespace


SimpleMessageEventArgs Members

SimpleMessageEventArgs Members NetIRC2 IRC Client Library for .NET

The SimpleMessageEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | SimpleMessageEventArgs | Creates a new instance of SimpleMessageEventArgs.
Back to Top
Properties
 | Name | Description
Public property | Message | The message.
Back to Top
See Also
SimpleMessageEventArgs Class
NetIrc2.Events Namespace


SimpleMessageEventArgs Constructor

SimpleMessageEventArgs Constructor NetIRC2 IRC Client Library for .NET
Creates a new instance of SimpleMessageEventArgs.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public SimpleMessageEventArgs(
    IrcString message
)
public SimpleMessageEventArgs(
    IrcString message
)
Public Sub New ( _
    message As IrcString _
)
Public Sub New ( _
    message As IrcString _
)
public:
SimpleMessageEventArgs(
    IrcString^ message
)
public:
SimpleMessageEventArgs(
    IrcString^ message
)
new :
        message : IrcString -> SimpleMessageEventArgs
new :
        message : IrcString -> SimpleMessageEventArgs

Parameters

message
Type: NetIrc2 IrcString
The message.
See Also
SimpleMessageEventArgs Class
SimpleMessageEventArgs Members
NetIrc2.Events Namespace


SimpleMessageEventArgs Properties

SimpleMessageEventArgs Properties NetIRC2 IRC Client Library for .NET
The SimpleMessageEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Message | The message.
Back to Top
See Also
SimpleMessageEventArgs Class
NetIrc2.Events Namespace


Message Property

SimpleMessageEventArgs Message Property NetIRC2 IRC Client Library for .NET
The message.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString Message { get; private set; }
public IrcString Message { get; private set; }
Public Property Message As IrcString
    Get
    Private Set
Public Property Message As IrcString
    Get
    Private Set
public:
property IrcString^ Message {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
public:
property IrcString^ Message {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
member Message : IrcString with get, private set
member Message : IrcString with get, private set
See Also
SimpleMessageEventArgs Class
SimpleMessageEventArgs Members
NetIrc2.Events Namespace


TargetedMessageEventArgs Class

TargetedMessageEventArgs Class NetIRC2 IRC Client Library for .NET
Stores a sender and recipient for a targeted action.
Inheritance Hierarchy
Online System Object
Online System EventArgs
NetIrc2.Events TargetedMessageEventArgs
NetIrc2.Events ChatMessageEventArgs
NetIrc2.Events InvitationEventArgs
NetIrc2.Events KickEventArgs
NetIrc2.Events ModeEventArgs

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class TargetedMessageEventArgs : EventArgs
public class TargetedMessageEventArgs : EventArgs
Public Class TargetedMessageEventArgs _
    Inherits EventArgs
Public Class TargetedMessageEventArgs _
    Inherits EventArgs
public ref class TargetedMessageEventArgs : public EventArgs
public ref class TargetedMessageEventArgs : public EventArgs
type TargetedMessageEventArgs =
    class
        inherit EventArgs
    end
type TargetedMessageEventArgs =
    class
        inherit EventArgs
    end
See Also
TargetedMessageEventArgs Members
NetIrc2.Events Namespace


TargetedMessageEventArgs Members

TargetedMessageEventArgs Members NetIRC2 IRC Client Library for .NET

The TargetedMessageEventArgs type exposes the following members.
Constructors
 | Name | Description
Public method | TargetedMessageEventArgs | Creates a new instance of TargetedMessageEventArgs.
Back to Top
Properties
 | Name | Description
Public property | Recipient | The recipient.
Public property | Sender | The sender. Be aware that some messages may not have a sender, such as NOTICEs from the server at connect time. In this case the sender will be null.
Back to Top
See Also
TargetedMessageEventArgs Class
NetIrc2.Events Namespace


TargetedMessageEventArgs Constructor

TargetedMessageEventArgs Constructor NetIRC2 IRC Client Library for .NET
Creates a new instance of TargetedMessageEventArgs.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TargetedMessageEventArgs(
    IrcIdentity sender,
    IrcString recipient
)
public TargetedMessageEventArgs(
    IrcIdentity sender,
    IrcString recipient
)
Public Sub New ( _
    sender As IrcIdentity, _
    recipient As IrcString _
)
Public Sub New ( _
    sender As IrcIdentity, _
    recipient As IrcString _
)
public:
TargetedMessageEventArgs(
    IrcIdentity^ sender,
    IrcString^ recipient
)
public:
TargetedMessageEventArgs(
    IrcIdentity^ sender,
    IrcString^ recipient
)
new :
        sender : IrcIdentity *
        recipient : IrcString -> TargetedMessageEventArgs
new :
        sender : IrcIdentity *
        recipient : IrcString -> TargetedMessageEventArgs

Parameters

sender
Type: NetIrc2 IrcIdentity
The sender, or null if the message has no sender.
recipient
Type: NetIrc2 IrcString
The recipient.
See Also
TargetedMessageEventArgs Class
TargetedMessageEventArgs Members
NetIrc2.Events Namespace


TargetedMessageEventArgs Properties

TargetedMessageEventArgs Properties NetIRC2 IRC Client Library for .NET
The TargetedMessageEventArgs type exposes the following members.
Properties
 | Name | Description
Public property | Recipient | The recipient.
Public property | Sender | The sender. Be aware that some messages may not have a sender, such as NOTICEs from the server at connect time. In this case the sender will be null.
Back to Top
See Also
TargetedMessageEventArgs Class
NetIrc2.Events Namespace


Recipient Property

TargetedMessageEventArgs Recipient Property NetIRC2 IRC Client Library for .NET
The recipient.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString Recipient { get; private set; }
public IrcString Recipient { get; private set; }
Public Property Recipient As IrcString
    Get
    Private Set
Public Property Recipient As IrcString
    Get
    Private Set
public:
property IrcString^ Recipient {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
public:
property IrcString^ Recipient {
    IrcString^ get ();
    private: void set (IrcString^ value);
}
member Recipient : IrcString with get, private set
member Recipient : IrcString with get, private set
See Also
TargetedMessageEventArgs Class
TargetedMessageEventArgs Members
NetIrc2.Events Namespace


Sender Property

TargetedMessageEventArgs Sender Property NetIRC2 IRC Client Library for .NET
The sender. Be aware that some messages may not have a sender, such as NOTICEs from the server at connect time. In this case the sender will be null.

Namespace: NetIrc2.Events
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcIdentity Sender { get; private set; }
public IrcIdentity Sender { get; private set; }
Public Property Sender As IrcIdentity
    Get
    Private Set
Public Property Sender As IrcIdentity
    Get
    Private Set
public:
property IrcIdentity^ Sender {
    IrcIdentity^ get ();
    private: void set (IrcIdentity^ value);
}
public:
property IrcIdentity^ Sender {
    IrcIdentity^ get ();
    private: void set (IrcIdentity^ value);
}
member Sender : IrcIdentity with get, private set
member Sender : IrcIdentity with get, private set
See Also
TargetedMessageEventArgs Class
TargetedMessageEventArgs Members
NetIrc2.Events Namespace


NetIrc2.Parsing Namespace

NetIrc2.Parsing Namespace NetIRC2 IRC Client Library for .NET
If you are handling a custom IRC statement, or subclassing IrcClient, you may need to deal with the low-level aspects of parsing. These classes support that activity.
Classes
 | Class | Description
Public class | IrcStatement | Reads and writes raw IRC statement lines.
Public class | IrcStatementReceiver | Receives IRC statements from a stream.
Public class | IrcValidation | Validates various parameter types.
Enumerations
 | Enumeration | Description
Public enumeration | IrcStatementParseResult | The result of attempting to parse an IRC statement.


IrcStatement Class

IrcStatement Class NetIRC2 IRC Client Library for .NET
Reads and writes raw IRC statement lines.
Inheritance Hierarchy
Online System Object
NetIrc2.Parsing IrcStatement

Namespace: NetIrc2.Parsing
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class IrcStatement
public class IrcStatement
Public Class IrcStatement
Public Class IrcStatement
public ref class IrcStatement
public ref class IrcStatement
type IrcStatement =  class end
type IrcStatement =  class end
See Also
IrcStatement Members
NetIrc2.Parsing Namespace


IrcStatement Members

IrcStatement Members NetIRC2 IRC Client Library for .NET

The IrcStatement type exposes the following members.
Constructors
 | Name | Description
Public method | IrcStatement | Creates an IRC statement with nothing set.
Public method | IrcStatement(IrcIdentity, IrcString, IrcString ) | Creates an IRC statement.
Back to Top
Methods
 | Name | Description
Public method | ToByteArray | Converts the IRC statement into a byte array, including the ending CR+LF.
Public method | ToByteArray(Boolean ) | Converts the IRC statement into a byte array, including the ending CR+LF, and additionally returns whether the string was truncated.
Public method | ToIrcString | Converts the IRC statement into an IRC string containing all of its bytes, including the ending CR+LF.
Public method | ToIrcString(Boolean ) | Converts the IRC statement into an IRC string containing all of its bytes, including the ending CR+LF, and additionally returns whether the string was truncated.
 | TryParse( Byte , Int32 , Int32, IrcStatement ) | Tries to read a buffer and parse out an IRC statement.
 | TryParse( Byte , Int32 , Int32, IrcStatement , IrcStatementParseResult ) | Tries to read a buffer and parse out an IRC statement. Additionally, on failure, the reason for failure is returned.
Back to Top
Properties
 | Name | Description
Public property | Command | The command, or if the IRC statement is a reply, a three-digit number.
Public property | Parameters | The parameters of the statement.
Public property | ReplyCode | The numeric reply code, if the IRC statement is a reply.
Public property | Source | The source of the statement, if any. This is called the prefix in the IRC specification.
Back to Top
See Also
IrcStatement Class
NetIrc2.Parsing Namespace


IrcStatement Constructor

IrcStatement Constructor NetIRC2 IRC Client Library for .NET
Overload List
 | Name | Description
Public method | IrcStatement | Creates an IRC statement with nothing set.
Public method | IrcStatement(IrcIdentity, IrcString, IrcString ) | Creates an IRC statement.
Back to Top
See Also
IrcStatement Class
IrcStatement Members
NetIrc2.Parsing Namespace


IrcStatement Constructor

IrcStatement Constructor NetIRC2 IRC Client Library for .NET
Creates an IRC statement with nothing set.

Namespace: NetIrc2.Parsing
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcStatement()
public IrcStatement()
Public Sub New
Public Sub New
public:
IrcStatement()
public:
IrcStatement()
new : unit -> IrcStatement
new : unit -> IrcStatement
See Also
IrcStatement Class
IrcStatement Members
IrcStatement Overload
NetIrc2.Parsing Namespace


IrcStatement Constructor (IrcIdentity, IrcString, IrcString[])

IrcStatement Constructor (IrcIdentity, IrcString, IrcString ) NetIRC2 IRC Client Library for .NET
Creates an IRC statement.

Namespace: NetIrc2.Parsing
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcStatement(
    IrcIdentity source,
    IrcString command,
    params IrcString[] parameters
)
public IrcStatement(
    IrcIdentity source,
    IrcString command,
    params IrcString[] parameters
)
Public Sub New ( _
    source As IrcIdentity, _
    command As IrcString, _
    ParamArray parameters As IrcString() _
)
Public Sub New ( _
    source As IrcIdentity, _
    command As IrcString, _
    ParamArray parameters As IrcString() _
)
public:
IrcStatement(
    IrcIdentity^ source,
    IrcString^ command,
    ... array<IrcString^>^ parameters
)
public:
IrcStatement(
    IrcIdentity^ source,
    IrcString^ command,
    ... array<IrcString^>^ parameters
)
new :
        source : IrcIdentity *
        command : IrcString *
        parameters : IrcString[] -> IrcStatement
new :
        source : IrcIdentity *
        command : IrcString *
        parameters : IrcString[] -> IrcStatement

Parameters

source
Type: NetIrc2 IrcIdentity
The source of the statement, if any. This is called the prefix in the IRC specification.
command
Type: NetIrc2 IrcString
The command or three-digit reply code.
parameters
Type: NetIrc2 IrcString
The parameters of the command.
See Also
IrcStatement Class
IrcStatement Members
IrcStatement Overload
NetIrc2.Parsing Namespace


IrcStatement Methods

IrcStatement Methods NetIRC2 IRC Client Library for .NET
Methods
 | Name | Description
Public method | ToByteArray | Converts the IRC statement into a byte array, including the ending CR+LF.
Public method | ToByteArray(Boolean ) | Converts the IRC statement into a byte array, including the ending CR+LF, and additionally returns whether the string was truncated.
Public method | ToIrcString | Converts the IRC statement into an IRC string containing all of its bytes, including the ending CR+LF.
Public method | ToIrcString(Boolean ) | Converts the IRC statement into an IRC string containing all of its bytes, including the ending CR+LF, and additionally returns whether the string was truncated.
 | TryParse( Byte , Int32 , Int32, IrcStatement ) | Tries to read a buffer and parse out an IRC statement.
 | TryParse( Byte , Int32 , Int32, IrcStatement , IrcStatementParseResult ) | Tries to read a buffer and parse out an IRC statement. Additionally, on failure, the reason for failure is returned.
Back to Top
See Also
IrcStatement Class
NetIrc2.Parsing Namespace


ToByteArray Method

IrcStatement ToByteArray Method NetIRC2 IRC Client Library for .NET
Overload List
 | Name | Description
Public method | ToByteArray | Converts the IRC statement into a byte array, including the ending CR+LF.
Public method | ToByteArray(Boolean ) | Converts the IRC statement into a byte array, including the ending CR+LF, and additionally returns whether the string was truncated.
Back to Top
See Also
IrcStatement Class
IrcStatement Members
NetIrc2.Parsing Namespace


ToByteArray Method

IrcStatement ToByteArray Method NetIRC2 IRC Client Library for .NET
Converts the IRC statement into a byte array, including the ending CR+LF.

Namespace: NetIrc2.Parsing
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] ToByteArray()
public byte[] ToByteArray()
Public Function ToByteArray As Byte()
Public Function ToByteArray As Byte()
public:
array<unsigned char>^ ToByteArray()
public:
array<unsigned char>^ ToByteArray()
member ToByteArray : unit -> byte[]
member ToByteArray : unit -> byte[]

Return Value

A byte array.
See Also
IrcStatement Class
IrcStatement Members
ToByteArray Overload
NetIrc2.Parsing Namespace


ToByteArray Method (Boolean)

IrcStatement ToByteArray Method (Boolean ) NetIRC2 IRC Client Library for .NET
Converts the IRC statement into a byte array, including the ending CR+LF, and additionally returns whether the string was truncated.

Namespace: NetIrc2.Parsing
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] ToByteArray(
    out bool truncated
)
public byte[] ToByteArray(
    out bool truncated
)
Public Function ToByteArray ( _
    <OutAttribute> ByRef truncated As Boolean _
) As Byte()
Public Function ToByteArray ( _
    <OutAttribute> ByRef truncated As Boolean _
) As Byte()
public:
array<unsigned char>^ ToByteArray(
    [OutAttribute] bool% truncated
)
public:
array<unsigned char>^ ToByteArray(
    [OutAttribute] bool% truncated
)
member ToByteArray :
        truncated : bool byref -> byte[]
member ToByteArray :
        truncated : bool byref -> byte[]

Parameters

truncated
Type: Online System Boolean
true if the string was too long and had to be truncated.

Return Value

A byte array.
See Also
IrcStatement Class
IrcStatement Members
ToByteArray Overload
NetIrc2.Parsing Namespace


ToIrcString Method

IrcStatement ToIrcString Method NetIRC2 IRC Client Library for .NET
Overload List
 | Name | Description
Public method | ToIrcString | Converts the IRC statement into an IRC string containing all of its bytes, including the ending CR+LF.
Public method | ToIrcString(Boolean ) | Converts the IRC statement into an IRC string containing all of its bytes, including the ending CR+LF, and additionally returns whether the string was truncated.
Back to Top
See Also
IrcStatement Class
IrcStatement Members
NetIrc2.Parsing Namespace


ToIrcString Method

IrcStatement ToIrcString Method NetIRC2 IRC Client Library for .NET
Converts the IRC statement into an IRC string containing all of its bytes, including the ending CR+LF.

Namespace: NetIrc2.Parsing
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString ToIrcString()
public IrcString ToIrcString()
Public Function ToIrcString As IrcString
Public Function ToIrcString As IrcString
public:
IrcString^ ToIrcString()
public:
IrcString^ ToIrcString()
member ToIrcString : unit -> IrcString
member ToIrcString : unit -> IrcString

Return Value

An IRC string.
See Also
IrcStatement Class
IrcStatement Members
ToIrcString Overload
NetIrc2.Parsing Namespace


ToIrcString Method (Boolean)

IrcStatement ToIrcString Method (Boolean ) NetIRC2 IRC Client Library for .NET
Converts the IRC statement into an IRC string containing all of its bytes, including the ending CR+LF, and additionally returns whether the string was truncated.

Namespace: NetIrc2.Parsing
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString ToIrcString(
    out bool truncated
)
public IrcString ToIrcString(
    out bool truncated
)
Public Function ToIrcString ( _
    <OutAttribute> ByRef truncated As Boolean _
) As IrcString
Public Function ToIrcString ( _
    <OutAttribute> ByRef truncated As Boolean _
) As IrcString
public:
IrcString^ ToIrcString(
    [OutAttribute] bool% truncated
)
public:
IrcString^ ToIrcString(
    [OutAttribute] bool% truncated
)
member ToIrcString :
        truncated : bool byref -> IrcString
member ToIrcString :
        truncated : bool byref -> IrcString

Parameters

truncated
Type: Online System Boolean
true if the string was too long and had to be truncated.

Return Value

An IRC string.
See Also
IrcStatement Class
IrcStatement Members
ToIrcString Overload
NetIrc2.Parsing Namespace


TryParse Method

IrcStatement TryParse Method NetIRC2 IRC Client Library for .NET
Overload List
Name | Description
TryParse( Byte , Int32 , Int32, IrcStatement ) | Tries to read a buffer and parse out an IRC statement.
TryParse( Byte , Int32 , Int32, IrcStatement , IrcStatementParseResult ) | Tries to read a buffer and parse out an IRC statement. Additionally, on failure, the reason for failure is returned.
Back to Top
See Also
IrcStatement Class
IrcStatement Members
NetIrc2.Parsing Namespace


TryParse Method (Byte[], Int32, Int32, IrcStatement)

IrcStatement TryParse Method ( Byte , Int32 , Int32, IrcStatement ) NetIRC2 IRC Client Library for .NET
Tries to read a buffer and parse out an IRC statement.

Namespace: NetIrc2.Parsing
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TryParse(
    byte[] buffer,
    ref int offset,
    int count,
    out IrcStatement statement
)
public static bool TryParse(
    byte[] buffer,
    ref int offset,
    int count,
    out IrcStatement statement
)
Public Shared Function TryParse ( _
    buffer As Byte(), _
    ByRef offset As Integer, _
    count As Integer, _
    <OutAttribute> ByRef statement As IrcStatement _
) As Boolean
Public Shared Function TryParse ( _
    buffer As Byte(), _
    ByRef offset As Integer, _
    count As Integer, _
    <OutAttribute> ByRef statement As IrcStatement _
) As Boolean
public:
static bool TryParse(
    array<unsigned char>^ buffer,
    int% offset,
    int count,
    [OutAttribute] IrcStatement^% statement
)
public:
static bool TryParse(
    array<unsigned char>^ buffer,
    int% offset,
    int count,
    [OutAttribute] IrcStatement^% statement
)
static member TryParse :
        buffer : byte[] *
        offset : int byref *
        count : int *
        statement : IrcStatement byref -> bool
static member TryParse :
        buffer : byte[] *
        offset : int byref *
        count : int *
        statement : IrcStatement byref -> bool

Parameters

buffer
Type: Online System Byte
The buffer to read from.
offset
Type: Online System Int32
The offset to begin reading. The parser may advance this, even if parsing fails.
count
Type: Online System Int32
The maximum number of bytes to read.
statement
Type: NetIrc2.Parsing IrcStatement
The statement, if parsing succeeds, or null.

Return Value

true if parsing succeeded.
See Also
IrcStatement Class
IrcStatement Members
TryParse Overload
NetIrc2.Parsing Namespace


TryParse Method (Byte[], Int32, Int32, IrcStatement, IrcStatementParseResult)

IrcStatement TryParse Method ( Byte , Int32 , Int32, IrcStatement , IrcStatementParseResult ) NetIRC2 IRC Client Library for .NET
Tries to read a buffer and parse out an IRC statement. Additionally, on failure, the reason for failure is returned.

Namespace: NetIrc2.Parsing
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool TryParse(
    byte[] buffer,
    ref int offset,
    int count,
    out IrcStatement statement,
    out IrcStatementParseResult parseResult
)
public static bool TryParse(
    byte[] buffer,
    ref int offset,
    int count,
    out IrcStatement statement,
    out IrcStatementParseResult parseResult
)
Public Shared Function TryParse ( _
    buffer As Byte(), _
    ByRef offset As Integer, _
    count As Integer, _
    <OutAttribute> ByRef statement As IrcStatement, _
    <OutAttribute> ByRef parseResult As IrcStatementParseResult _
) As Boolean
Public Shared Function TryParse ( _
    buffer As Byte(), _
    ByRef offset As Integer, _
    count As Integer, _
    <OutAttribute> ByRef statement As IrcStatement, _
    <OutAttribute> ByRef parseResult As IrcStatementParseResult _
) As Boolean
public:
static bool TryParse(
    array<unsigned char>^ buffer,
    int% offset,
    int count,
    [OutAttribute] IrcStatement^% statement,
    [OutAttribute] IrcStatementParseResult% parseResult
)
public:
static bool TryParse(
    array<unsigned char>^ buffer,
    int% offset,
    int count,
    [OutAttribute] IrcStatement^% statement,
    [OutAttribute] IrcStatementParseResult% parseResult
)
static member TryParse :
        buffer : byte[] *
        offset : int byref *
        count : int *
        statement : IrcStatement byref *
        parseResult : IrcStatementParseResult byref -> bool
static member TryParse :
        buffer : byte[] *
        offset : int byref *
        count : int *
        statement : IrcStatement byref *
        parseResult : IrcStatementParseResult byref -> bool

Parameters

buffer
Type: Online System Byte
The buffer to read from.
offset
Type: Online System Int32
The offset to begin reading. The parser may advance this, even if parsing fails.
count
Type: Online System Int32
The maximum number of bytes to read.
statement
Type: NetIrc2.Parsing IrcStatement
The statement, if parsing succeeds, or null.
parseResult
Type: NetIrc2.Parsing IrcStatementParseResult
The result of parsing. On failure, this is the reason for the failure.

Return Value

true if parsing succeeded.
See Also
IrcStatement Class
IrcStatement Members
TryParse Overload
NetIrc2.Parsing Namespace


IrcStatement Properties

IrcStatement Properties NetIRC2 IRC Client Library for .NET
The IrcStatement type exposes the following members.
Properties
 | Name | Description
Public property | Command | The command, or if the IRC statement is a reply, a three-digit number.
Public property | Parameters | The parameters of the statement.
Public property | ReplyCode | The numeric reply code, if the IRC statement is a reply.
Public property | Source | The source of the statement, if any. This is called the prefix in the IRC specification.
Back to Top
See Also
IrcStatement Class
NetIrc2.Parsing Namespace


Command Property

IrcStatement Command Property NetIRC2 IRC Client Library for .NET
The command, or if the IRC statement is a reply, a three-digit number.

Namespace: NetIrc2.Parsing
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcString Command { get; set; }
public IrcString Command { get; set; }
Public Property Command As IrcString
    Get
    Set
Public Property Command As IrcString
    Get
    Set
public:
property IrcString^ Command {
    IrcString^ get ();
    void set (IrcString^ value);
}
public:
property IrcString^ Command {
    IrcString^ get ();
    void set (IrcString^ value);
}
member Command : IrcString with get, set
member Command : IrcString with get, set
See Also
IrcStatement Class
IrcStatement Members
NetIrc2.Parsing Namespace


Parameters Property

IrcStatement Parameters Property NetIRC2 IRC Client Library for .NET
The parameters of the statement.

Namespace: NetIrc2.Parsing
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IList<IrcString> Parameters { get; private set; }
public IList<IrcString> Parameters { get; private set; }
Public Property Parameters As IList(Of IrcString)
    Get
    Private Set
Public Property Parameters As IList(Of IrcString)
    Get
    Private Set
public:
property IList<IrcString^>^ Parameters {
    IList<IrcString^>^ get ();
    private: void set (IList<IrcString^>^ value);
}
public:
property IList<IrcString^>^ Parameters {
    IList<IrcString^>^ get ();
    private: void set (IList<IrcString^>^ value);
}
member Parameters : IList<IrcString> with get, private set
member Parameters : IList<IrcString> with get, private set
See Also
IrcStatement Class
IrcStatement Members
NetIrc2.Parsing Namespace


ReplyCode Property

IrcStatement ReplyCode Property NetIRC2 IRC Client Library for .NET
The numeric reply code, if the IRC statement is a reply.

Namespace: NetIrc2.Parsing
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcReplyCode ReplyCode { get; set; }
public IrcReplyCode ReplyCode { get; set; }
Public Property ReplyCode As IrcReplyCode
    Get
    Set
Public Property ReplyCode As IrcReplyCode
    Get
    Set
public:
property IrcReplyCode ReplyCode {
    IrcReplyCode get ();
    void set (IrcReplyCode value);
}
public:
property IrcReplyCode ReplyCode {
    IrcReplyCode get ();
    void set (IrcReplyCode value);
}
member ReplyCode : IrcReplyCode with get, set
member ReplyCode : IrcReplyCode with get, set
See Also
IrcStatement Class
IrcStatement Members
NetIrc2.Parsing Namespace


Source Property

IrcStatement Source Property NetIRC2 IRC Client Library for .NET
The source of the statement, if any. This is called the prefix in the IRC specification.

Namespace: NetIrc2.Parsing
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcIdentity Source { get; set; }
public IrcIdentity Source { get; set; }
Public Property Source As IrcIdentity
    Get
    Set
Public Property Source As IrcIdentity
    Get
    Set
public:
property IrcIdentity^ Source {
    IrcIdentity^ get ();
    void set (IrcIdentity^ value);
}
public:
property IrcIdentity^ Source {
    IrcIdentity^ get ();
    void set (IrcIdentity^ value);
}
member Source : IrcIdentity with get, set
member Source : IrcIdentity with get, set
See Also
IrcStatement Class
IrcStatement Members
NetIrc2.Parsing Namespace


IrcStatementParseResult Enumeration

IrcStatementParseResult Enumeration NetIRC2 IRC Client Library for .NET
The result of attempting to parse an IRC statement.

Namespace: NetIrc2.Parsing
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum IrcStatementParseResult
public enum IrcStatementParseResult
Public Enumeration IrcStatementParseResult
Public Enumeration IrcStatementParseResult
public enum class IrcStatementParseResult
public enum class IrcStatementParseResult
type IrcStatementParseResult
type IrcStatementParseResult
Members
Member name | Value | Description
OK | 0 | Parsing succeeded.
NothingToParse | 1 | A full statement has not yet been received.
InvalidStatement | 2 | The statement failed validation.
StatementTooLong | 3 | Either no statement has been received, or the statement that was received is too long. IRC does not allow more than 510 bytes (plus CR+LF) for a statement.
Disconnected | 4 | The connection was lost. IrcStatement will not return this, but IrcStatementReceiver may.
TimedOut | 5 | The read timed out. IrcStatement will not return this, but IrcStatementReceiver may.
See Also
NetIrc2.Parsing Namespace


IrcStatementReceiver Class

IrcStatementReceiver Class NetIRC2 IRC Client Library for .NET
Receives IRC statements from a stream.
Inheritance Hierarchy
Online System Object
NetIrc2.Parsing IrcStatementReceiver

Namespace: NetIrc2.Parsing
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class IrcStatementReceiver
public sealed class IrcStatementReceiver
Public NotInheritable Class IrcStatementReceiver
Public NotInheritable Class IrcStatementReceiver
public ref class IrcStatementReceiver sealed
public ref class IrcStatementReceiver sealed
[<SealedAttribute>]
type IrcStatementReceiver =  class end
[<SealedAttribute>]
type IrcStatementReceiver =  class end
See Also
IrcStatementReceiver Members
NetIrc2.Parsing Namespace


IrcStatementReceiver Members

IrcStatementReceiver Members NetIRC2 IRC Client Library for .NET

The IrcStatementReceiver type exposes the following members.
Constructors
 | Name | Description
Public method | IrcStatementReceiver | Creates a new receiver.
Back to Top
Methods
 | Name | Description
Public method | TryReceive | Tries to receive an IRC statement. A blocking read is used. If you have a timeout set, parseResult may be TimedOut.
Back to Top
See Also
IrcStatementReceiver Class
NetIrc2.Parsing Namespace


IrcStatementReceiver Constructor

IrcStatementReceiver Constructor NetIRC2 IRC Client Library for .NET
Creates a new receiver.

Namespace: NetIrc2.Parsing
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public IrcStatementReceiver(
    Stream stream
)
public IrcStatementReceiver(
    Stream stream
)
Public Sub New ( _
    stream As Stream _
)
Public Sub New ( _
    stream As Stream _
)
public:
IrcStatementReceiver(
    Stream^ stream
)
public:
IrcStatementReceiver(
    Stream^ stream
)
new :
        stream : Stream -> IrcStatementReceiver
new :
        stream : Stream -> IrcStatementReceiver

Parameters

stream
Type: Online System.IO Stream
The stream to read from.
See Also
IrcStatementReceiver Class
IrcStatementReceiver Members
NetIrc2.Parsing Namespace


IrcStatementReceiver Methods

IrcStatementReceiver Methods NetIRC2 IRC Client Library for .NET
The IrcStatementReceiver type exposes the following members.
Methods
 | Name | Description
Public method | TryReceive | Tries to receive an IRC statement. A blocking read is used. If you have a timeout set, parseResult may be TimedOut.
Back to Top
See Also
IrcStatementReceiver Class
NetIrc2.Parsing Namespace


TryReceive Method

IrcStatementReceiver TryReceive Method NetIRC2 IRC Client Library for .NET
Tries to receive an IRC statement. A blocking read is used. If you have a timeout set, parseResult may be TimedOut.

Namespace: NetIrc2.Parsing
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TryReceive(
    out IrcStatement statement,
    out IrcStatementParseResult parseResult
)
public bool TryReceive(
    out IrcStatement statement,
    out IrcStatementParseResult parseResult
)
Public Function TryReceive ( _
    <OutAttribute> ByRef statement As IrcStatement, _
    <OutAttribute> ByRef parseResult As IrcStatementParseResult _
) As Boolean
Public Function TryReceive ( _
    <OutAttribute> ByRef statement As IrcStatement, _
    <OutAttribute> ByRef parseResult As IrcStatementParseResult _
) As Boolean
public:
bool TryReceive(
    [OutAttribute] IrcStatement^% statement,
    [OutAttribute] IrcStatementParseResult% parseResult
)
public:
bool TryReceive(
    [OutAttribute] IrcStatement^% statement,
    [OutAttribute] IrcStatementParseResult% parseResult
)
member TryReceive :
        statement : IrcStatement byref *
        parseResult : IrcStatementParseResult byref -> bool
member TryReceive :
        statement : IrcStatement byref *
        parseResult : IrcStatementParseResult byref -> bool

Parameters

statement
Type: NetIrc2.Parsing IrcStatement
The statement.
parseResult
Type: NetIrc2.Parsing IrcStatementParseResult
The parse result.

Return Value

true if a complete IRC statement was received.
See Also
IrcStatementReceiver Class
IrcStatementReceiver Members
NetIrc2.Parsing Namespace


IrcValidation Class

IrcValidation Class NetIRC2 IRC Client Library for .NET
Validates various parameter types.
Inheritance Hierarchy
Online System Object
NetIrc2.Parsing IrcValidation

Namespace: NetIrc2.Parsing
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static class IrcValidation
public static class IrcValidation
Public NotInheritable Class IrcValidation
Public NotInheritable Class IrcValidation
public ref class IrcValidation abstract sealed
public ref class IrcValidation abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IrcValidation =  class end
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IrcValidation =  class end
See Also
IrcValidation Members
NetIrc2.Parsing Namespace


IrcValidation Members

IrcValidation Members NetIRC2 IRC Client Library for .NET

The IrcValidation type exposes the following members.
Methods
Name | Description
IsChannelName | Checks if the channel name is valid. The definition used by this test is somewhat loose. Channel names may not contain spaces, commas, NULL, BELL, CR, or LF, and must start with # or &.
IsNickname | Checks if the nickname is valid. The definition used by this test is somewhat loose. Nicknames may not contain spaces, commas, NULL, BELL, CR, LF, #, &, @, or +.
Back to Top
See Also
IrcValidation Class
NetIrc2.Parsing Namespace


IrcValidation Methods

IrcValidation Methods NetIRC2 IRC Client Library for .NET
The IrcValidation type exposes the following members.
Methods
Name | Description
IsChannelName | Checks if the channel name is valid. The definition used by this test is somewhat loose. Channel names may not contain spaces, commas, NULL, BELL, CR, or LF, and must start with # or &.
IsNickname | Checks if the nickname is valid. The definition used by this test is somewhat loose. Nicknames may not contain spaces, commas, NULL, BELL, CR, LF, #, &, @, or +.
Back to Top
See Also
IrcValidation Class
NetIrc2.Parsing Namespace


IsChannelName Method

IrcValidation IsChannelName Method NetIRC2 IRC Client Library for .NET
Checks if the channel name is valid. The definition used by this test is somewhat loose. Channel names may not contain spaces, commas, NULL, BELL, CR, or LF, and must start with # or &.

Namespace: NetIrc2.Parsing
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsChannelName(
    IrcString channel
)
public static bool IsChannelName(
    IrcString channel
)
Public Shared Function IsChannelName ( _
    channel As IrcString _
) As Boolean
Public Shared Function IsChannelName ( _
    channel As IrcString _
) As Boolean
public:
static bool IsChannelName(
    IrcString^ channel
)
public:
static bool IsChannelName(
    IrcString^ channel
)
static member IsChannelName :
        channel : IrcString -> bool
static member IsChannelName :
        channel : IrcString -> bool

Parameters

channel
Type: NetIrc2 IrcString
The channel name to test.

Return Value

true if the name is valid.
See Also
IrcValidation Class
IrcValidation Members
NetIrc2.Parsing Namespace


IsNickname Method

IrcValidation IsNickname Method NetIRC2 IRC Client Library for .NET
Checks if the nickname is valid. The definition used by this test is somewhat loose. Nicknames may not contain spaces, commas, NULL, BELL, CR, LF, #, &, @, or +.

Namespace: NetIrc2.Parsing
Assembly: NetIrc2 (in NetIrc2.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static bool IsNickname(
    IrcString nickname
)
public static bool IsNickname(
    IrcString nickname
)
Public Shared Function IsNickname ( _
    nickname As IrcString _
) As Boolean
Public Shared Function IsNickname ( _
    nickname As IrcString _
) As Boolean
public:
static bool IsNickname(
    IrcString^ nickname
)
public:
static bool IsNickname(
    IrcString^ nickname
)
static member IsNickname :
        nickname : IrcString -> bool
static member IsNickname :
        nickname : IrcString -> bool

Parameters

nickname
Type: NetIrc2 IrcString
The nickname to test.

Return Value

true if the name is valid.
See Also
IrcValidation Class
IrcValidation Members
NetIrc2.Parsing Namespace